Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Автоматическое отрывание периода

Ø
Я
   trade777
02.12.04 - 12:39
1с КОМПЛЕКСНАЯ ... Кажную ночь производятся работы на базой - восстановление последовательности итд ... Наступило 1 декабря... Нужно открыть период .... Это можно тоже автоматически сделать ? А то я на работу утром, а складу доки не провести .... пришлось на работу ехать :(
 
 
   Пух
1 - 02.12.04 - 12:49
Можно :) Посмотри глобальник, там уже все написано :)
   ewc
2 - 02.12.04 - 12:59
На всякий случай...
  
//Автоматическое открытие периода
  ДатаТА=ПолучитьДатуТА();
  Если (РабочаяДата()>ДатаТА) И
  ((ДатаМесяц(ДатаТА)<>ДатаМесяц(РабочаяДата()))ИЛИ(ДатаГод(ДатаТА)<>ДатаГод(РабочаяДата()))) Тогда
    Если МонопольныйРежим()=0 Тогда
      Ответ=Вопрос("Не открыт период!"+РазделительСтрок+
      "Для открытия периода запустите программу в монопольном режиме!"+РазделительСтрок+
      "Завершить работу программы?","Да+Нет");
      Если Ответ="Да" Тогда
        СтатусВозврата(0);
        Возврат;
      КонецЕсли;
    Иначе // монопольный режим
      Ответ=Вопрос("Не открыт период!"+РазделительСтрок+
      "Выполнить открытие периода?","Да+Нет");
      Если Ответ="Да" Тогда
        УстановитьТАНа(РабочаяДата());
        Предупреждение("Выполнено открытие периода. Можно работать.");
      КонецЕсли;
    КонецЕсли;
  КонецЕсли;



Список тем форума

Форум Территория 1С

Рекламное место пустует   Рекламное место пустует
Чтобы обнаруживать ошибки, программист должен иметь ум, которому доставляет удовольствие находить изъяны там, где, казалось, царят красота и совершенство.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует