Вход | Регистрация

1С:Предприятие ::

Метки:

определение процедур и функций

Я
   Term2
 
25.02.04 - 07:42
У меня такой вот модуль формы:

Процедура Печать()
   ...........текст процедуры
КонецПроцедуры;


Процедура ПриОткрытии() 
   ...........текст процедуры
КонецПроцедуры;


В результате выдает ошибку
<<?>>Процедура ПриОткрытии()
{Документ.КомандировочноеУдостоверение.Форма.Модуль(13)}: Определения процедур и функций должны размещаться перед операторами основной программы

Не совсем пойму, что за фигня?
 
 
   skunk
 
1 - 25.02.04 - 07:55
убери ; после КонецПроцедуры
   Львенок
 
2 - 25.02.04 - 08:58
Сам частенько люблю точку с запятой воткнуть куда не следует. Ну правда ошибку нахожу и исправляю иногда даже раньше синтаксис контроля...
___
Искренне Ваш, Львенок.
   Term2
 
3 - 25.02.04 - 11:05
Причем что интересно, все работало и сточкой с запятой, пока была только одна процеДУРА ПриОткрытии() А как только добавилась вторая - начались глюки.
   Bzzzzz
 
4 - 25.02.04 - 12:18
(3) потому что ";" отделяет операторы и у тебя при таком раскладе получалось:
Процедура1
пустой оператор модуля (или как он там называется)
Процедура2
, а операторы должны располагаться ниже всех процедур


Список тем форума
  Рекламное место пустует
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует