Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Подскажите, в чем ошибка

Ø
Я
   ВладимирЧ
01.12.04 - 20:47
Вот две таких строки. СчетУчета 41.1
Количество считает - сумма - 0
по отчетам сумма есть. Почему не считает - ???
ОстатокК = БухИт.СКД(СчетУчета, "К",, ВыбрТовар, МестоХранения);
ОстатокС = БухИт.СКД(СчетУчета, "S",, ВыбрТовар, МестоХранения);
 
  Рекламное место пустует
   Убитая С Тазом
1 - 01.12.04 - 20:50
Тема должна отражать суть сообщения...
Рекомендую сунуть в нужное место знак =
   ОбезьянаСГранатой
2 - 01.12.04 - 20:53
сумма = 0, потому что отключен суммовой учет по складам
   SnarkHunter
3 - 01.12.04 - 20:55
Возникает мысль о ДНК...
   ВладимирЧ
4 - 01.12.04 - 20:55
А где его включить ?
   Убитая С Тазом
5 - 01.12.04 - 20:58
4. Спроси у родителей...
По нам с Владом ходит кошак и нажимает ненужные клавиши
вот пример фыкеасьлфеглсаф0зк
   ОбезьянаСГранатой
6 - 01.12.04 - 20:58
4 см.(3) зачем включать?!
   Uno
7 - 01.12.04 - 21:13
Возьми основы бухучета иты поймешь что сумовой учет по складам это нонсенс.
И тех кто его делает или заставляет делать гнать надо в 3 шеи.
Этоже 1. клас вторая четверть в бух школе, не вру скорее всего первая.
   ВладимирЧ
8 - 01.12.04 - 21:13
А надо сумму товара на складе узнать
   ОбезьянаСГранатой
9 - 01.12.04 - 21:15
СуммаНаСкладе= количествоНаСкладе*средняяЦенаНаПредприятии
   ВладимирЧ
10 - 01.12.04 - 21:15
Нужен количественно-суммовой учет по закупочным ценам без ндс
 
 
   ВладимирЧ
11 - 01.12.04 - 21:17
(9) А где взять Среднюю по предприятию ???
   Uno
12 - 01.12.04 - 21:32
2(10)Для чего экономичиский смысл этого?
2(11) чтото вроде БухИт.СКД(СчетУчета, "S",, ВыбрТовар, );
   Uno
13 - 01.12.04 - 21:37
+12 конечно разделив на количество по предприятию.
   sdaf
14 - 01.12.04 - 22:18
ф дисятке
ПРОПАЛ КОТ В РАЙОНЕ ФАБРИКИ ШАПОК
   owen
15 - 01.12.04 - 22:40
13)
а если в себестоимоть товара падают какието суммы,
и один и тот же товар на разных складах может иметь ее разную
хот и поступил он по одной?
   2S
16 - 02.12.04 - 07:29
ня...
БИ = СоздатьОбъект("БухгалтерскиеИтоги");
БИ.ИспользоватьСубконто(ВидыСубконто.Номенклатура,,1);
БИ.ИспользоватьСубконто(ВидыСубконто.МестаХранения,,1);
БИ.ВыполнитьЗапрос(....);
БИ.ВыбратьСубконто(1);
БИ.ВыбратьСубконто(2);
Пока БИ.ПолучитьСубконто(1) = 1 Цикл
СредняяПоПредприятию = БИ.СКД("С") / БИ.СКД("К");
Если БИ.ПолучитьСубконто(2,НужныйСклад) = 1 Тогда
СуммаПоСкладу = БИ.СКД("К") * СредняяПоПредприятию;
КонецЕсли
КонецЦикла;
   SnarkHunter
17 - 02.12.04 - 07:45
В коде содержится потенциальная ошибка...
   АБЗ
18 - 02.12.04 - 07:49
Две
   2S
19 - 02.12.04 - 07:53
сорри..
  БИ = СоздатьОбъект("БухгалтерскиеИтоги");
  БИ.ИспользоватьСубконто(ВидыСубконто.Номенклатура,,1);
  БИ.ИспользоватьСубконто(ВидыСубконто.МестаХранения,,1);
  БИ.ВыполнитьЗапрос(,ТекущаяДата(),"41.1",,,,,5);
  БИ.ВыбратьСубконто(1);
  Пока БИ.ПолучитьСубконто(1) = 1 Цикл
    СредняяПоПредприятию = БИ.СКД("С") / Макс(БИ.СКД("К"),1);
    БИ.ВыбратьСубконто(2);
    Пока БИ.ПолучитьСубконто(2) = 1 Цикл
      СуммаПоСкладу = БИ.СКД("К") * СредняяПоПредприятию;
      Сообщить(БИ.Субконто(1));
      Сообщить(БИ.Субконто(2));
      Сообщить(СуммаПоСкладу);
      Сообщить("__________________")
    КонецЦикла
  КонецЦикла;



Список тем форума

Форум Территория 1С

  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует