Вход | Регистрация


Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Перлы кодеров 1С (продолжение)

Ø
Я
   progr1c
30.11.04 - 18:45
    Если ЗапросМВ.Выполнить(ТекстЗапросаМВ)=0 Тогда
      Сообщить ("Зови Мишеля!!! - БЛИН");
    КонецЕсли;
...
    Если ЗапросикМВ.Выполнить(ТекстЗапросаМВ)=0 Тогда
      Сообщить ("Зови Мишеля!!! - БЛИН два раза");
    КонецЕсли;
 
 
   Господин Забалуев
1 - 30.11.04 - 18:57
Сам видел...
Если ОстатокТМЦ<ТребуемыйОстатокДляБлюда Тогда
Сообщить("Свелана ! Документ проводить нельзя.");
КонецЕсли;
   Убитая С Тазом
2 - 30.11.04 - 19:13
Писала в ЗиКе "Катя, руки помой"... исключительно для себя
   SlonSpb
3 - 30.11.04 - 19:16
см. мою тему про сводный остаток.
рез = макс(0,рез) афигенный спосап откинуть отрицательные остатки. правда, здорово ?
   Los
4 - 30.11.04 - 19:28
При проведении документа при определенных условиях вываливалось подрят три окошка: "У пользователя ... нет прав на отгрузку со склада ... Отгружаем несмотря ни на что? (Да/Нет)", "А смерти боишься? (Да/Нет)", "Ну смотри, ты сам под этим подписался... (ОК)". Фразы запомнил на всю жизнь, поскольку занимался перепроведением документов, прав на отгрузку не было, а в конфу лезть было нельзя :)
   Los
5 - 30.11.04 - 19:34
Ну и еще - вот такой вот крик души в отчете по остаткам:
//Как вы мне все надоели со своими ящиками!!!!!!!!
Если ВыводитьЯщики=1 Тогда
   ...
   Убитая С Тазом
6 - 30.11.04 - 19:44
офф, внутри оффа:
Народ кто вхож в МистУ опубликуйте вот это в ветке
ОФФ: Миста в 2050 году. Пятничный вечер.>от меня
   trdm
7 - 30.11.04 - 20:47
(5) Конфа ТиС 9..?
в расходной накладной есть реквизиты "Ящик, Блок, Штука"?
   AnMoOr
8 - 30.11.04 - 21:43
Не столько прикол, скоко совет не увлекатся копи-пастом.
Вот такое в одной конфе нашел...
...
Если ЕстьТовар = 1 Тогда
СписатьОстаток(Товар);
ИначеЕсли ЕстьТовар = 0 Тогда
Сообщить ("Нет Товара");
ИначеЕсли ЕстьТовар = 0 Тогда
Сообщить ("Нет Товара");
ИначеЕсли ЕстьТовар = 0 Тогда
Сообщить ("Нет Товара");
КонецЕсли;
...
   GarryLider
9 - 30.11.04 - 22:45
(4,5)Улёт
   Вадя
10 - 01.12.04 - 06:11
(4) Очень понравилось!
 
  Рекламное место пустует
   Vint Kras
11 - 01.12.04 - 06:33
Директор вызвал и говорит сравни мне документы с двух баз, чего-то не сходится...
сделав, вывожу: такой-то док.|такой-то док.|сошлось
                ...................
                такой-то док.|такой-то док.|ОПА, СМОТРИ НЕ СОШЛОСЬ
                ...............
прихожу отдаю, тот как давай закатываться, я сначала то и не въехал....
или переменные вороде: "ЧтоТоНеРаботалоВотИВпендюрил"...
   РБ
12 - 01.12.04 - 06:43
// <== Кто так перебирает строки, мать вашу? Автор, покайся! :( жопа.
   pit
13 - 01.12.04 - 07:27
Копи-пасте матофильтр не пропускает...
   РБ
14 - 01.12.04 - 07:39
(13) Петр, привет! интресно, а у меня пропустит?
// в рублях
   Гурон
16 - 01.12.04 - 08:04
эхх... чего только не встретишь на бескрайних просторах родного глобальника...
//Оплата бывает только не оплаченного товара
Взаиморасчет="U";// Добавлено сергей для документа Взаимозачет
ВзаимозачетВнутр="U"//Добавлено Борис вместо тупого на строку выше
   ANik
17 - 01.12.04 - 08:12
Константа "Девачка"
На форме журнала внизу кнопка по ширине журнала "Нажми меня, чтобы распечатать журнал".
И т.д. Автор уволен по истечении испытательного срока.
   РБ
18 - 01.12.04 - 08:14
в начале модуля:
//Всё-гон! (народная мудрость)
   Tinamu1
19 - 01.12.04 - 08:51
При переходе в новую базу, в старой вывел предупреждение что в ней работать нельзя, но доступ был, а путь к новой базе не всем прописал. Ну пользователи подходят говрят, чтобы путь прописал к новой базе. Прошел месяц. И выяснилось что одна бухша наплевала на это сообщение и вколачивала данные в старую базу. :)
   snif
20 - 01.12.04 - 09:03
В выходные звонят мне домой: "Катастрофа! У нас рухнула база! Пишет - система нуждается в реконфигурации!". Плюнул на культурный поход с супругой, приезжаю в филиал и что же я вижу..... Оказывается, хитрый юзверь создал нового пользователя и под ним ломится в базу . В окошке "Права" (я им по телефону говорил, что надо ВЫБРАТЬ "Администратор") они НАПИСАЛИ - "Админисратор"!!!
   Зубов
21 - 01.12.04 - 09:12
в документе возврат от покупателя:
  Если ИмяПользователя() = "АТ" Тогда
<--skip-->
  Передупреждение("Если Вы, Антон Евгеньевич, будете продолжать
возвращать левый товар от охреневших покупателей, Ваша работа на нашем
предприятии закончится прежде, чем наступит следующий понедельник.
|          Директор",3600)
 
to 4 & 5 -> Los! здарова, когда опять к нам? Швейк работает!
 
   Dav
22 - 01.12.04 - 09:31
(21) У вас директор кодит? Совмещает или хобби?
   Кирилл
23 - 01.12.04 - 09:41
2(21)гыыыыыыыыы
   Пух
24 - 01.12.04 - 09:41
Немного в сторону от 1с :)
C:\Program Files\Common Files\Microsoft Shared\Grphflt\CDRIMP32.FLT
Строка 4918-4921
:)
   Кирилл
25 - 01.12.04 - 09:43
2(24)А еси такого файла не наблюдается, что делать?
   Frog
26 - 01.12.04 - 09:45
Клево у меня их 1814:)
   Frog
27 - 01.12.04 - 09:47
Винда какая? (24)
   Пух
28 - 01.12.04 - 09:48
Это файл импорта cdr файлов в офис. Если его нет, значит просто не установлен. Для тех у кого его нет, там вот такие строчки:
,----------------------.
| Lexa Lexa ty mogu~ |
|  movet dave zloebu~  |
`----------------------'
:)))
   Chastiser
29 - 01.12.04 - 09:52
Вот, что пришлось ваять для корректной печати ордера на списание материалов М-11 в конфе, где документом "СписаниеМатериалов" списывается все что угодно, а реквизит "Единица измерения" имеет тип строка :((
ЕдиницаИзмеренияКод = "796";// По умолчанию - штуки
Если Номенклатура.Вид() = "ОсновныеСредства" Тогда
  ЕдиницаИзмерения    = "шт";
Иначе// Товары, материалы
  ЕдиницаИзмерения = СокрЛП(Номенклатура.ЕдИзм);
  Если ПустоеЗначение(ЕдиницаИзмерения) > 0 Тогда
    ЕдиницаИзмерения = "шт";
  Иначе
    ПерваяБукваЕдИзм = НРег(Лев(СокрЛП(Номенклатура.ЕдИзм), 1));
    Если ПерваяБукваЕдИзм = "т" Тогда // Скорей всего тонны ;-))
      ЕдиницаИзмеренияКод = "168";
    ИначеЕсли ПерваяБукваЕдИзм <> "ш" Тогда // Если уж не штуки
      ЕдиницаИзмеренияКод = "";
    КонецЕсли;
  КонецЕсли;
КонецЕсли;
Из этой же базы:
Сообщить("Р "+ШоЗаДокумэнт+Строка(БухИтоги90.Операция.Документ.НомерДок)+"  ПродажаКво "+Строка(БухИтоги90.КО("К")));//--- Следующая строка работает, если остатки и обороты по первому уровню запроса нулевые, а по второму разворачиваются в плюс-минус
Предупреждение("Фактуры регистрируются только под договорами. Перенесите это под желтенькую папочку.");
Предупреждение("Удалять документ в закрытом периоде вредно. Даже опасно.");
Сообщить("--- "+ТекСФ+" согласна начислить "+СуммаНДСпоСФ+". Да нечем. Да и зачем?");
   Пух
30 - 01.12.04 - 09:53
(27) Это файлик от офиса. office xp sp2. Говорят, что после наката sp3 этого уже нет.
   туча
31 - 01.12.04 - 09:57
Встречал такое сообщение, если пользователь редактирует справочник и у него нет прав, вылазит сообщение: "БОГ не дал вам прав на редактирование! Звоните программисту!
   Кортес
32 - 01.12.04 - 10:17
(24),(28): это, по-твоему, смешно?
   Сияющий асинхраль
33 - 01.12.04 - 10:19
//*******************************************
Процедура АнализТаблицыЗначений(ТЗнач)
.....
    //Добавляем в таблицу значений поля контрагент и счет
.....
    //Добавили, а дальнейший изврат по просьбе вышестоящих инстанций предназначен для
    //упорядочения документов по контрагентам. Наверно можно проще, но как я не знаю.
.....		
          //А здесь пора упорядочивать документы по контрагентам, из-за чего собственно весь сыр-бор и начинался
.....
          //И, наконец, необходимо вытащить итоги по контрагенту, (чертовски медленно работать все это будет)
          //а также запихнуть итоговые суммы по контрагенту в формируемую нами таблицу значений
.....
    //Заносим итог по последней промежуточной таблице значений, еще строчек пятьдесят
.....
    //Вот теперь похоже все, интересно как эта хрень работать будет
КонецПроцедуры
 
  Рекламное место пустует
   PS
34 - 01.12.04 - 10:22
Сообщить("Раньше думать было надо, милочка").
Это я видел в чужой конфе при попытке переделать документ в закрытом периоде.
А вот был у меня хитрый док, который закрывал че попало куда попало.
Там было две галки, закрывать по дебету или по кредиту. Док для ГБ офигенно опытного и мудрого.
Галки были по-дефолту пустые, и сделано так, чтоб думал куда закрывать прежде чем ОК жать.
ГБ неоднократно валялся по-полу, от сообщения "В какую сторону закрывать будем, Уважаемый?"
   Пух
35 - 01.12.04 - 10:27
(34) Сообщить("Раньше думать было надо, милочка")
5 баллов!!! Сейчас в своей конфе исправлю на такую :))
   Полный Рост
36 - 01.12.04 - 10:31
Если ТакойУжеЕсть = 1 Тогда
 Предупреждение("Эх, мамуля, мамуля ...  Склад-то " + перСклад.Наименование + " уже выбран!");
Иначе ...
   Glide
37 - 01.12.04 - 10:46
ставил запрет на копирование ПКО, если контрагент в группе с частным лицом:
Если Скопирован = 1 Тогда//копирование документа
  Если Клиент.Родитель=Константа.ОсновнойПокупатель.Родитель Тогда
    Предупреждение("                 ПНХ!"+РазделительСтрок+"Для неграмотных нужен перевод?",2);
    Форма.Закрыть(0);
    Возврат;
  КонецЕсли;
КонецЕсли;
   ОМКО
38 - 01.12.04 - 10:51
А я такое вот видел в глобальнике:)
//НАЧАЛО ГОМНОКОДА
<...>
   koord
39 - 01.12.04 - 10:53
(33) Вполне вменяемый комментарий. Побольше бы таких кодеров. Я серьёзно.
   Митхун Чакраборти
40 - 01.12.04 - 10:57
Процедура ИнициализацияТаблиц() //К сожалению не знаю, что значит слово "Инициализация", но очень уж умное - не мог куда-нибудь не всунуть
   Кортес
41 - 01.12.04 - 10:57
У меня в конфе перлов нет. Абидна...
   Los
42 - 01.12.04 - 11:01
(7) ТиС 9 с чем то. Но таких реквизитов нет.
(21) Привет! Кстати вероятно скоро :-) В понедельник, скорее всего, прилечу утренней птицей :) Если ничего не изменится :)
   koord
43 - 01.12.04 - 11:01
(41) Желание вставлять такие перлы с возрастом пропадает. С ростом ЗП и ответственности. Хотя бывает и наоборот.
   Los
44 - 01.12.04 - 11:14
Еще нарыл тут в одной старой конфе (фамилию изменил):
//Я еще не писал, что директор с правами администратора - это обезьяна с гранатой?
Если ИмяПользователя()="Иванов" Тогда
   Форма.ФлагПроверки.Доступность(0);
   Форма.СлойАдминистратора.Видимость(0);
КонецЕсли;
   pit
45 - 01.12.04 - 11:20
В Перли кодеру 1С (продолжение) ......
   Eugene G
46 - 01.12.04 - 11:24
(39) поменьше бы таких кодеров...качественно написанный код практически не нуждается в комментариях...
   Зубов
47 - 01.12.04 - 11:29
to 44
давай приезжай, у меня телефон не изменился, звони. одевайся потеплее - у нас
под 20 давит.
 
to 22
эт не у меня. это в дружественной конторе. а там директор - да, шарит, йопт,
технический вуз заканчивали! а вставить две строчки - это еще не программирование
   Сияющий асинхраль
48 - 01.12.04 - 11:31
(46) Насколько я представляю код без комментариев является признаком дурного тона. Наверно не от некомпетентности кодеров 1С все типовые тщательно прокомментарены. Другое дело конкретные случаи (33).
   Frog
49 - 01.12.04 - 11:34
(46)Согласен что можно разобраться, но ремки очень облегчают читабельность особенно свои. Я за неделю пишу гору обработок и делаю кучу изменений и если бы не ремки, то притамился бы потом искать. Конечно если пишешь 1 раз в месяц, то тогда вопросов нет.
 
 
   Eugene G
50 - 01.12.04 - 11:43
(46, 49) Я не говорил про полное отсутствие комментариев. 90% программ страдают от некачественных и избыточных комментрариев, которые только затрудняют понимание кода. Читайте XP, и вы узнаете много интересного ;))
   Eugene G
51 - 01.12.04 - 11:47
(+50) вместо 46 нужно 48 :))
   noook
52 - 01.12.04 - 11:50
Хоть это и не профессилнально (Сабж) но зато без юмора хуже намного
сам иногда пишу бредятину для себя
   Frog
53 - 01.12.04 - 11:52
Так слово "излишние" я не наблюдал, поэтому и высказал
   ANik
54 - 01.12.04 - 11:52
(48) Главное - идентификаторы. А программа и так на русском написана.
ХорошийИдентификаторСодержитПолноеОписаниеАлгоритма.
   МоральныйУродец
55 - 01.12.04 - 11:56
Вчера коллега нашел в моём коде переменную СписДел.
Звучит, блин :-)
Долго смеялись.
   fez
56 - 01.12.04 - 11:57
(51) Экзамен сдал, XP-шник?
   Eugene G
57 - 01.12.04 - 12:00
(56) Да, сдал :)))))))))))))))))))))))))))))))))))))))))))) еле-еле, препод сказал если не время за которое я решил задачу (1 ч 50 мин) я б не сдал...
Есть некоторые мысли по поводу контроля целостности данных в ИБ, сейчас с делами разгребусь, зайду к тебе на форум ;)
   Сияющий асинхраль
58 - 01.12.04 - 12:07
(54) А я разве против. Но название (0) "Перлы кодеров 1С", а не "правильные подходы к написанию кода".
   fisher
59 - 01.12.04 - 12:10
2(50) Везёт челу... А я вот не могу сказать, что 90% программ, которые мне доводилось сопровождать, страдали от избыточных комментариев. Скорее они ими не страдали вообще.
   ЛеХа
60 - 01.12.04 - 12:29
Если Найти(Клиент.Наименование,"Федина")<>0 Тогда
   Сообщить("Передайте привет моей любимой учительнице!");
КонецЕсли;
   MAAAS
61 - 01.12.04 - 12:47
Переменная "ПервыйРазЗаМужем".
ПервыйРазЗаМужем = 0;
Пока ... цикл
Если тот-то тот-то тогда
ПервыйРазЗаМужем = 1; ...
информативно... :)
   Максим1
62 - 01.12.04 - 12:57
// Делаем Записи в книгу продаж по НАЛ и БН.
// ЭТО ОЧЕНЬ ВАЖНО !!!! КУСОК КОДА, КОТОРЫЙ НАПИСАН НИЖЕ НИКОГДА НЕ БУДЕТ ИСПОЛЬЗОВАН.// Т.К. У НАС НЕ БЫВАЕТ НЕ АВАНСОВЫХ ПЛАТЕЖЕЙ (ПОТОМУ, ЧТО РЕАЛИЗАЦИЯ ДЕЛАЕТСЯ ВСЕГДА КОНЦОМ МЕСЯЦА)
// СЛЕДОВАТЕЛЬНО ЕСЛИ ОПЛАТА ЕСТЬ , ТО ОНА ДО РЕАЛИЗАЦИИ Т.Е. - АВАНС.
Нашел в обработке, которую товарищ сделал. (как в анекдоте: "Береженого бог бережет" сказала монашка одевая презерватив на свечку :)
   ANik
63 - 01.12.04 - 13:05
(62) Молодец! (без иронии)
   dma
64 - 01.12.04 - 13:24
После досадного непоздравления уважаемого сотрудника в день его рождения сделал обработку по проверке сего грядущего. За 3 дня выдавались предупреждения, а при наступлении события выводилось окошко с изображением торта (чего угодно).
   Рамиль
65 - 01.12.04 - 13:25
Процедура ПриЗакрытииНарядЗаказа(//Передача через ОЛЕ
.
.
.
  Если Вопрос("Вы уверены, что хотите передать данные в автосервис и закрыть наряд - заказ?","Да+Нет")="Нет" Тогда Возврат; КонецЕсли;
  Если Вопрос("Вы АБСОЛЮТНО в этом уверены?","Да+Нет")="Нет" Тогда Возврат; КонецЕсли;
  Если Вопрос("Ну Вы точно определились?","Да+Нет")="Нет" Тогда Возврат; КонецЕсли;
  Предупреждение("Даю Вам последнюю возможность подумать. До завтра.")
  Возврат;
   seugenys
66 - 01.12.04 - 13:28
  Если ПустоеЗначение(НомерСтроки) = 0 Тогда
    Если ТипЗначенияСтр(Товар) = "Справочник" Тогда
      Вид = Товар.Вид();
      Если Вид = "Материалы" Тогда
        ЗапТипНоменклатуры = перТипНоменклатуры;
        //перТипНоменклатуры = 1;
      ИначеЕсли Вид = "Номенклатура" Тогда
        ЗапТипНоменклатуры = перТипНоменклатуры;
        //перТипНоменклатуры = 2;
      ИначеЕсли Вид = "ОсновныеСредства" Тогда
        ЗапТипНоменклатуры = перТипНоменклатуры;
        //перТипНоменклатуры = 3;
      ИначеЕсли Вид = "ОбъектыСтроительства" Тогда
        ЗапТипНоменклатуры = перТипНоменклатуры;
        //перТипНоменклатуры = 4;
      Иначе
        ЗапТипНоменклатуры = перТипНоменклатуры;
        //перТипНоменклатуры = 0;
      КонецЕсли;
    КонецЕсли;
  Иначе
    ЗапТипНоменклатуры = перТипНоменклатуры;
    //перТипНоменклатуры = 0;
  КонецЕсли;
   Смотрящий от 1С
67 - 01.12.04 - 13:59
(66) Даешь построчную оплату!
   TTT155
68 - 02.12.04 - 01:25
Если ДатаДок <= Константа.ДатаЗапретаРедактирования Тогда
   Предупреждение("Ковыряние в заднем числе приводит к повисшему сальдо !!!");
КонецЕсли;
И еще немножко порно ...
Видел распечатанные карточки на сотрудника
Базелев Сергей Анальевич
с подписью самого сотрудника ;-)




Список тем форума

Форум Территория 1С

Рекламное место пустует  
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует