Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Бух. подскажите....

Ø
Я
   Брат2
01.12.04 - 12:42
ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
БИ_Период.ИспользоватьСубконто(ВидыСубконто.Номенклатура,Товар,2,0);
БИ_Период.ИспользоватьСубконто(ВидыСубконто.МестаХранения,МХ,2,0);
БИ_Период.ВыполнитьЗапрос(, ТекущийДокумент(),"41.1",,, 1, "Операция");
БИ_Период.ВыбратьПериоды();
Пока БИ_Период.ПолучитьПериод() = 1 Цикл
  Сообщить(БИ_Период.Операция.Документ);
КонецЦикла;	
КонецЦикла;
Цикл не попадает в ПолучитьПериод()...вроде все просто..:(
 
 
   Брат2
1 - 01.12.04 - 12:57
ап
   Chastiser
2 - 01.12.04 - 13:04
БИ_Период.ВыполнитьЗапрос(НачалоПериодаНадоБыУказать, ...
   Брат2
3 - 01.12.04 - 13:06
неа, условие в одном месте перепутал..спасибо, вопрос снимаю.
   Frog
4 - 01.12.04 - 13:07
Похоже? Зато работает.
  ИтЛП1.ВыполнитьЗапрос(ДатаОпл, ДатаДок, "ЛП.1",,Константа.ОсновнаяВалюта,1,"Проводка","С,В");	
    ИтЛП1.ВыбратьСубконто(1);
    Если ИтЛП1.ПолучитьСубконто(1,,ЛизДоговор)=1 Тогда
      НачОстаток = ИтЛП1.СНД("В") - ИтЛП1.СНК("В");
      Остаток=НачОстаток;
      ИтогоОплаченоВал = ИтЛП1.КО("В");
      ИтЛП1.ВыбратьПериоды();
      Флаг=0;
      СуммаПрОпл=0;
      Пока ИтЛП1.ПолучитьПериод()=1 Цикл		
        ТекДок = ИтЛП1.Операция.Документ;
        Если ИтЛП1.ДО("В")<>0 тогда
          Начислено      = ИтЛП1.ДО("В");
        КонецЕсли;				
        Если ИтЛП1.КО("В") <> 0 Тогда // Выписки или ручные проводки					
          ОплаченоВал    = ИтЛП1.КО("В");
          ОплаченоРуб    = ИтЛП1.КО("С");
          Курс 		   = Окр(ОплаченоРуб / ОплаченоВал, 4);
          ТекДок.ВыбратьСтроки();
          Пока ТекДок.ПолучитьСтроку()=1 Цикл
            Если ТекДок.ВидДвижения = Перечисление.ВидыДвиженийПоРасчетномуСчету.Лизинг Тогда					
              Если (ТекДок.Субконто1 = ВыбКлиент) И (ТекДок.Субконто2.ДоговорЛизинга = ЛизДоговор) И (ТекДок.ВалСумма = ОплаченоВал) Тогда
                Если ПустоеЗначение(ТекДок.датаПлательщика)=1  тогда
                    ДатаПлатежа = ТекДок.ДатаДок;
                Иначе
                  ДатаПлатежа = ТекДок.датаПлательщика;
                КонецЕсли;
                Прервать;						
              КонецЕсли;
            Иначе
              Продолжить;
            КонецЕсли;
          КонецЦикла;					



Список тем форума

Форум Территория 1С

Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует