Вход | Регистрация


1С:Предприятие ::

Метки:

Отчет по перемещению ТМЦ без регистров

Я
   VetalDark
06.12.04 - 11:42
Здравствуйте, уважаемые. Подскажите, плиз, как создать отчет по перемещению товаров без использования запросов к регистрам (их попросту нет, т.е. не используются) или хотя бы направьте на правильный путь.
 
 
   GrayT
 
1 - 06.12.04 - 11:53
А что есть?
   MegaBlast
 
2 - 06.12.04 - 11:59
Напиши запрос к тому, что есть.
   427
 
3 - 06.12.04 - 12:26
????????
   laeg
 
4 - 06.12.04 - 12:35
А как тогда они двигаются - по счетам ?
Конфа какая ?
   Asmody
 
5 - 06.12.04 - 12:38
мдя...
   vS
 
6 - 06.12.04 - 12:45
запрос по документам рулит :) не забудь про непроведенные и удаленные :)
   Asmody
 
7 - 06.12.04 - 12:50
(6) да не... простым перебором (Док.ПолучитьДокумент()) круче будет... >;))
   laeg
 
8 - 06.12.04 - 12:50
+(6) Если конфа не типовая, и документы не делают движения не по Счетам и не по Регистрам.
   427
 
9 - 06.12.04 - 13:50
Я балдю с тупых одноЭсников...
   vS
 
10 - 06.12.04 - 13:59
а сами они тихо повизгивают и похрюкивают... странно улыбаясь беспорядочна вращая зрачками глаз в тишине склепа...
 
  Рекламное место пустует
   GrayT
 
11 - 06.12.04 - 14:13
Тю, млин. Тут все по-прежнему :)
   VetalDark
12 - 06.12.04 - 14:16
Конфа типа АБТ3. Движение происходит только по счетам. Как грамотно выдрать перемещение товаров по складам?
   laeg
 
13 - 06.12.04 - 14:16
Черз БухИтоги
   VetalDark
14 - 06.12.04 - 14:21
Я конечно извиняюсь за хрючество, но через БухИтоги не получается. В АБТ3 есть стандартный отчет Движение ТМЦ, но она работает через запросы к регистрам (все оччень просто). Нужна такая же форма, но только без использования регистров.
   laeg
 
15 - 06.12.04 - 14:22
(14)
Ты хоть сам понял что сказал ?
   GrayT
 
16 - 06.12.04 - 14:26
Ты че laeg? Ведь все предельно просто.....
   laeg
 
17 - 06.12.04 - 14:29
(16)
1. Фиг его хнает что такое АБТЗ
2. Цитата (12) "Движение происходит только по счетам."
3. Цитата (14) "но через БухИтоги не получается. В АБТ3 есть стандартный отчет Движение ТМЦ, но она работает через запросы к регистрам"

ТОды тебе в (6) или (7) ... Только остатки не получишь.
   GrayT
 
18 - 06.12.04 - 14:33
(17)Так я и говорю - пойти туда не знаю куда..... взять такой же но только другой
   VetalDark
19 - 06.12.04 - 14:55
GrayT: Все были чайниками, но у некоторых это состояние не проходит.
Я - пока что чайник в 1С, поэтому просьба не ругаться и не выдавать издевательские высказывания.
Всем спасибо за советы. Попробую через запросы по документам.
   GrayT
 
20 - 06.12.04 - 15:00
А я и не издевался. Просто ты толком не расказываешь что за задача у тебя.
Тут любят поговорку - Правильно заданный вопрос - 50% ответа
   VetalDark
21 - 06.12.04 - 15:15
OK. Проблема в следующем. Нужно создать отчет по перемещения товаров в разрезе складов. В отчете долны присутствовать Начальный остаток, Поступления, Расход и Конечный остаток. Печатную форму, которую требуется создать можно глянуть в стандартной АБТ3.х.х ПРОФ конфигурации (там этот отчет называется Движение ТМЦ в отчетах Оперативного учета). В той конфигурации, в которую нужно добавить данный отчет не ведутся регистры - не знаю почему, но не хотят они их вести :) Можно конечно перебрать все документы (Приходные Расходные Перемещения и др.) простым перебором, но как сделать отбор по Фирмам и Складам и при этом еще вычислить Остатки, поступления и расход. Получается большая каша (я уже в ней совсем запутался): с одной стороны Отбор ТМЦ из документов, с другой расчет бухитогов для получения остатков.
Вобщем, если где сказал глупость, извините.
   VetalDark
22 - 06.12.04 - 15:19
Да, забыл сказать, партионный учет также отсутствует.
   laeg
 
23 - 06.12.04 - 15:21
(21) почти все глупость ...

Все же советую разобраться с документами движения ТМЦ, какие движения они делают и где.
Или вызвать спеца который сделает.
   Лошадка в пальто
 
24 - 06.12.04 - 15:21
22. Документы что двигают?
   Ёжик в тумане
 
25 - 06.12.04 - 15:22
"Правильно поставленный вопрос содержит до 95% ответа" (с)
   GrayT
 
26 - 06.12.04 - 15:29
(21)Что ты подразумеваешь под понятием не ведутся регистры?
Это ведь такие сволочи, что их развести очень трудно - только документам это и удается....
   1С Дурачок
27 - 06.12.04 - 15:34
Да никакой он(VetalDark) не чайник, просто других чайников разводит...
Цирк удался
   VetalDark
28 - 06.12.04 - 15:36
Это такое требование. Не я это придумал. Моя задача стоит составить такой отчет, а так как в 1С я новичек, то тут же и запутался. Задачу поставил главбух одного из наших регионов :( Насколько я понимаю регистр - это многомерный массив данных, движение по которому происходит при проведении документов. Само движение описывается в модуле документа. Правильно? Если закомментировать строки кода, отвечающие за фиксацию данных в регистрах, то они соответсвенно будут бусполезны.
   laeg
 
29 - 06.12.04 - 15:38
мдя ....
интересная задача

Вопрос:
А оно тебе надо ? Если надо то ЗАЧЕМ ?
   Лошадка в пальто
 
30 - 06.12.04 - 15:38
28. Щелки в журнале документов правой кнопкой на документе и посмотри движения документа. Расскажи, что ты там видишь
   1С Дурачок
31 - 06.12.04 - 15:41
фигу...
   VetalDark
32 - 06.12.04 - 15:42
Лошадка в пальто: у меня только md-шный файл. Скажи что из конфы тебе показать.
   Лошадка в пальто
 
33 - 06.12.04 - 15:44
32. Покажи к примеру модуль докукмента какого нибудь. Без закоментированных кусков
 
  Рекламное место пустует
   VetalDark
34 - 06.12.04 - 15:53
Вот к примеру документ Внешнего Перемещения:

//Начало текста, вставленного Инсталлятором МОД

Процедура ОбработкаПроведения() Далее
//Конец текста, вставленного Инсталлятором МОД

Процедура стар_ОбработкаПроведения()
    
//Закомментировано Инсталлятором МОД:Процедура ОбработкаПроведения()


    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    Спр = СоздатьОбъект("Справочник.Партии");
    Спр.ИспользоватьВладельца(ТМЦ);
КвоУч=ИтОстаток.СККРС(СчетОткуда,"К",,Откуда,"!",ТМЦ,"!");
"+ТМЦ+ ". Кол-во на складе:"+КвоУч);
Проводка(Контекст,СчетУчета,СчетОткуда,,"Перемещение",Кво,Куда,ТМЦ,,Откуда,ТМЦ,,,,);

    КонецЦикла;    
    
    Операция.Содержание = "Перемещение";
   //Закомментировано Инсталлятором МОД:Операция.Записать();

   //Начало текста, вставленного Инсталлятором МОД

    ОбъектЗаписать(Операция, )
   //Конец текста, вставленного Инсталлятором МОД

;
    ;
        
КонецПроцедуры
//Начало текста, вставленного Инсталлятором МОД

Процедура ОбработкаПроведения()
       //Внимание: данная процедура при обновлении Менеджера будет перезаписана заново

       //без сохранения текущего кода !!!

       //Рекомендуем собственные алгоритмы записывать в старую процедуру с префиксом стар_

        Если ПроведениеМОД(Контекст)=1 Тогда
            Возврат;
        КонецЕсли;
    стар_ОбработкаПроведения();
КонецПроцедуры
//Конец текста, вставленного Инсталлятором МОД

//Начало текста, вставленного Инсталлятором МОД
Процедура ОбработкаУдаленияПроведения()
       //Внимание: данная процедура при обновлении Менеджера будет перезаписана заново

       //без сохранения текущего кода !!!

       //Рекомендуем собственные алгоритмы записывать в старую процедуру с префиксом стар_

        Если ПроведениеПоАлгоритмуМОД=1 Тогда
            Возврат;
        КонецЕсли;
        ПриИзмененииОбъектаМОД(Контекст, ТекущийДокумент(), ДатаДок);
КонецПроцедуры
//Конец текста, вставленного Инсталлятором МОД
   Лошадка в пальто
 
35 - 06.12.04 - 16:12
На бухгалтерской компоненте писано. Делай отчет через БухИтоги



Список тем форума
Рекламное место пустует  
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует