Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Проверка на кавычки

Ø
Я
   sdaf
30.11.04 - 12:46
как проверить наличие " в названии контрагента например?
Найти(Наименование,""")>0 не работает
 
 
   Diм
1 - 30.11.04 - 12:47
Найти(Наименование,""""")>0
так попробуй
   ValeraVV
2 - 30.11.04 - 12:49
Найти(Наименование, Симв(34))>0
--)
   dma
3 - 30.11.04 - 12:50
В каждом справочнике, где необходимо контролировать отсутствие кавычек, в процедуре ПриЗаписи() я вызываю эту глобальную процедуру. Она просматривает все строковые реквизиты справочника и меняет парные кавычки на 2-е одинарные.
Процедура глУбратьКавычки(Конт) Экспорт
  Стр=Симв(34);
  СтрЗамена="''";
  СпрВид=Конт.Вид();
  СтарЗнач=Конт.Наименование;
  Если Найти(СтарЗнач,Стр)<>0 Тогда
    Конт.Наименование=СтрЗаменить(СтарЗнач,Стр,СтрЗамена);
  КонецЕсли;
  
  Для б=1 По Метаданные.Справочник(СпрВид).Реквизит() Цикл
    Если Метаданные.Справочник(СпрВид).Реквизит(б).Тип<>"Строка" Тогда
      Продолжить;
    КонецЕсли;
    ИдРеквизита=Метаданные.Справочник(СпрВид).Реквизит(б).Идентификатор;
    СтарЗнач=Конт.ПолучитьАтрибут(ИдРеквизита);
    Если Найти(СтарЗнач,Стр)=0 Тогда
      Продолжить;
    КонецЕсли;
    НовЗнач=СтрЗаменить(СтарЗнач,Стр,СтрЗамена);
    Конт.УстановитьАтрибут(ИдРеквизита,НовЗнач);
  КонецЦикла;
КонецПроцедуры
   sdaf
4 - 30.11.04 - 12:51
Пасибо - работает
   sdaf
5 - 30.11.04 - 12:53
работает и (1) и (2)
спасибо всем!



Список тем форума

Форум Территория 1С

  Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует