Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Методы для календарей ЗИК!!!

Ø
Я
   РК
30.11.04 - 10:08
Календ = СоздатьОбъект("Календарь.Служащие");
подскажите, метод
Календ.УстановитьАтрибут("Значение",1);
в 2-ке ЗИК может установить значение и что для этого нужно сделать
 
 
   РК
1 - 30.11.04 - 10:45
помогите!
   АБЗ
2 - 30.11.04 - 10:50
Ниче не понял
   РК
3 - 30.11.04 - 10:57
у календаря есть метод "УстановитьАтрибут"
так вот он почему-то ничего не устанавливает
что делать если календари нужно заполнить не вручную
   Gloom
4 - 30.11.04 - 11:01
Автозаполнение сделай...
   глюкер
5 - 30.11.04 - 11:03
сначала автозаполнение, потом УстановитАтрибут.
   РК
6 - 30.11.04 - 11:21
Календ.УстановитьАтрибут("Значение",1);
не фурычит
автозаполнение сделала
   Gloom
7 - 30.11.04 - 11:28
(6)На нужную дату спозиционировалась?
   РК
8 - 30.11.04 - 11:32
Кал.ВыбратьДаты(ДатаН, ДатаО);
  
Пока Кал.СледующаяДата() = 1 Цикл
  Сообщить(Кал.ПолучитьАтрибут("Дата"));
Кал.УстановитьАтрибут("Значение",1);
  КонецЦикла;
   РК
9 - 30.11.04 - 12:01
Gloom, ну что скажешь?
   Gloom
10 - 30.11.04 - 12:09
(9)А так работает?
Календ.Значение=1;
 
  Рекламное место пустует
   РК
11 - 30.11.04 - 12:23
вроде записалось, но вопрос №2
Если я делаю
Пока Календ.СледующаяДата(0 = 1 Цикл
   Сообщить(Календ.Значение);//выводит 1
КонецЦикла;
Если я смотрю просто в календарь для этого периода
(например, с 01 января 2004 по 31 января 2004 года)
там для дней и часов стоят те же значения что и раньше
вопрос - куда записывается эта единица
   РК
12 - 30.11.04 - 13:30
жду ответа!
   РК
13 - 30.11.04 - 15:19
жду...
   РК
14 - 30.11.04 - 15:29
народ, ну помогите!
   Gloom
15 - 30.11.04 - 15:37
(11)Может в другой календарь?
Специально проверил - работает/показывает всё пучком:
=====================================================
  Календ=СоздатьОбъект("Календарь.Шестидневка");
  Календ.Автозаполнение('01.01.2005', '02.01.2005');
  Календ.ВыбратьДаты('01.01.2005', '02.01.2005');
  Пока Календ.СледующаяДата() = 1 Цикл
    Календ.УстановитьАтрибут("Значение",1);
  КонецЦикла;
   РК
16 - 30.11.04 - 15:55
Gloom, показывает, когда ты открываешь этот календарь из меню, за день 01.01.2005 единицу?
   Gloom
17 - 30.11.04 - 15:57
(16)Да.
   РК
18 - 30.11.04 - 16:12
попробуй изменить в календаре, в котором при автозаполнении разные часы
   Gloom
19 - 30.11.04 - 16:29
(18)В шестидневке и так разные: 1-5 - по 7 часов, 6 - 5, 7 - 0
   РК
20 - 30.11.04 - 16:31
да, правда, работает
что со мной? долбаюсь по полдня с простыми задачами



Список тем форума

Форум Территория 1С

 
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует