Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Название организаций в транслите.

Ø
Я
   Abver
29.11.04 - 12:56
Никто никогда не озадачивал себя следующей проблемой: перевод названия с русского языка в латиницу. К примеру: "Калинка" - > "Kalinka"
Как проще всего это сделать?
 
 
   OFF
1 - 29.11.04 - 13:02
Спроси у Camino
на сайте у него болтадась обработка под это дело
   Abver
2 - 29.11.04 - 13:15
Спасибо, попробую. МОжет быть есть еще у кого-нибудь?
   dma
3 - 29.11.04 - 13:20
создаешь два массива. В одном из них русский алфавит, а в другом в тех же позициях иностранные соответсвия. Как использовать уже сам догадался?
   OFF
4 - 29.11.04 - 13:23
Смысл не меняется, ту нех изобрететь велосипед с квадратными колесами когда все ездють с круглыми
Вот от Camino
//Технологическое решение "Транслит" v.1.1
// (с) 2002, Mike R. Camino
// http://www.camino.ru<br>// 1c@camino.ru
Перем тзТранслит;
//
Функция Транслитеровать(стрДляТранслитерации ,Направление)
  // стрДляТранслитерации - строка, которую нужно транслитеровать
  // Направление: 1 - Рус-Англ, 2 - Англ-Рус
  
  тзТранслит.ВыбратьСтроки();
  Пока тзТранслит.ПолучитьСтроку()=1 Цикл
    Если Направление=1 Тогда
      стрДляТранслитерации=СтрЗаменить(стрДляТранслитерации,тзТранслит.Рус,тзТранслит.Транс);
    Иначе
      стрДляТранслитерации=СтрЗаменить(стрДляТранслитерации,тзТранслит.Транс,тзТранслит.Рус);
    КонецЕсли;
  КонецЦикла;
  
  Возврат стрДляТранслитерации;
КонецФункции//Транслитеровать(стрДляТранслитерации,Направление)
//
Процедура ДобавитьВТЗТранслита(Рус="",Транс="")
  тзТранслит.НоваяСтрока();
  тзТранслит.Рус=Рус;
  тзТранслит.Транс=Транс;
КонецПроцедуры//ДобавитьВТЗТранслита()
//
Процедура ПриОткрытии()
  // \/Инициализация транслита
  тзТранслит=СоздатьОбъект("ТаблицаЗначений");
  тзТранслит.НоваяКолонка("Рус");
  тзТранслит.НоваяКолонка("Транс");
  
  ДобавитьВТЗТранслита("щ","sch");
  ДобавитьВТЗТранслита("ё","jo");
  ДобавитьВТЗТранслита("ж","zh");
  ДобавитьВТЗТранслита("ц","ts");
  ДобавитьВТЗТранслита("ч","ch");
  ДобавитьВТЗТранслита("ш","sh");
  ДобавитьВТЗТранслита("ю","yu");
  ДобавитьВТЗТранслита("я","ja");
  ДобавитьВТЗТранслита("а","a");
  ДобавитьВТЗТранслита("б","b");
  ДобавитьВТЗТранслита("в","v");
  ДобавитьВТЗТранслита("г","g");
  ДобавитьВТЗТранслита("д","d");
  ДобавитьВТЗТранслита("е","e");
  ДобавитьВТЗТранслита("з","z");
  ДобавитьВТЗТранслита("и","i");
  ДобавитьВТЗТранслита("й","j");
  ДобавитьВТЗТранслита("к","k");
  ДобавитьВТЗТранслита("л","l");
  ДобавитьВТЗТранслита("м","m");
  ДобавитьВТЗТранслита("н","n");
  ДобавитьВТЗТранслита("о","o");
  ДобавитьВТЗТранслита("п","p");
  ДобавитьВТЗТранслита("р","r");
  ДобавитьВТЗТранслита("с","s");
  ДобавитьВТЗТранслита("т","t");
  ДобавитьВТЗТранслита("у","u");
  ДобавитьВТЗТранслита("ф","f");
  ДобавитьВТЗТранслита("х","h");
  ДобавитьВТЗТранслита("ь","");
  ДобавитьВТЗТранслита("ъ","");
  ДобавитьВТЗТранслита("ы","y");
  ДобавитьВТЗТранслита("э","e");
  ДобавитьВТЗТранслита("Щ","Sch");
  ДобавитьВТЗТранслита("Ё","Jo");
  ДобавитьВТЗТранслита("Ж","Zh");
  ДобавитьВТЗТранслита("Ц","Ts");
  ДобавитьВТЗТранслита("Ч","Ch");
  ДобавитьВТЗТранслита("Ш","Sh");
  ДобавитьВТЗТранслита("Ю","Yu");
  ДобавитьВТЗТранслита("Я","Ja");
  ДобавитьВТЗТранслита("А","A");
  ДобавитьВТЗТранслита("Б","B");
  ДобавитьВТЗТранслита("В","V");
  ДобавитьВТЗТранслита("Г","G");
  ДобавитьВТЗТранслита("Д","D");
  ДобавитьВТЗТранслита("Е","E");
  ДобавитьВТЗТранслита("З","Z");
  ДобавитьВТЗТранслита("И","I");
  ДобавитьВТЗТранслита("Й","J");
  ДобавитьВТЗТранслита("К","K");
  ДобавитьВТЗТранслита("Л","L");
  ДобавитьВТЗТранслита("М","M");
  ДобавитьВТЗТранслита("Н","N");
  ДобавитьВТЗТранслита("О","O");
  ДобавитьВТЗТранслита("П","P");
  ДобавитьВТЗТранслита("Р","R");
  ДобавитьВТЗТранслита("С","S");
  ДобавитьВТЗТранслита("Т","T");
  ДобавитьВТЗТранслита("У","U");
  ДобавитьВТЗТранслита("Ф","F");
  ДобавитьВТЗТранслита("Х","H");
  ДобавитьВТЗТранслита("Ь","");
  ДобавитьВТЗТранслита("Ъ","");
  ДобавитьВТЗТранслита("Ы","Y");
  ДобавитьВТЗТранслита("Э","E");
  // /\Инициализация транслита
КонецПроцедуры//ПриОткрытии()
НаправлениеТранс = 2;
ЗЫ.
стрДляТранслитерации - многострочная строка на форме
   Abver
5 - 29.11.04 - 14:18
(4)Большое пасиба!



Список тем форума

Форум Территория 1С

  Рекламное место пустует
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует