Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Только базовая единица

Ø
Я
   Дед Иван
29.11.04 - 09:21
Усем прЫветы !
Ребят , закачали справочник номенклатуры , вместе с единицами измерения , но товар не выписывается , потому что не стоит галочка "использовать базовую единицу" , тоесть стоит и базовая и основная единица ! Конфигураша Типовая . Как можно программно поставить по всей номенклатуре эту галочку ?
 
  Рекламное место пустует
   SiAl
1 - 29.11.04 - 09:23
(0) Ты программист?
   2S
2 - 29.11.04 - 09:24
(1) тут даже программером быть не обязательно
   SiAl
3 - 29.11.04 - 09:26
(0) +1 Есть "групповая обработка номенклатуры", посмотри что с ней сделать можно.
   Дед Иван
4 - 29.11.04 - 09:26
да блин , я то программер , тока у нас седня такая запарка , срочно делаю более важную хрень и некогда просто
   SiAl
5 - 29.11.04 - 09:32
(4) А что там делать то?
Внешняя обработка:
Процедура ПриОткрытии()
    Номен = СоздатьОбъект("Справочник.Номенклатура");
    Номен.ВыбратьЭлементы();
    Пока Номен.ПолучитьЭлемент() = 1 Тогда
        Если Номен.ЭтоГруппа() = 0 Тогда
            Если Номен.ИспользоватьБазовуюЕдиницу = 0 Тогда
                Номен.ИспользоватьБазовуюЕдиницу = 1;
                Номен.Записать();
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
    СтатусВозврата(0);
КонецЦикла;
   Дед Иван
6 - 29.11.04 - 09:35
А при этом будет выполнятся формула , которая повещена на свойство этого флажка ? или надо ее вызывать в цикле ?
   ALISA
7 - 29.11.04 - 09:35
Setattr.ert с ИТС.
   Frog
8 - 29.11.04 - 09:39
Да нифига выполняться не будет, все что прописано в формуле выполняется только в интерактивном режиме.
   castan
9 - 29.11.04 - 09:43
 Если Номен.ИспользоватьБазовуюЕдиницу = 0 Тогда
                Номен.ОсновнаяЕдиница = Номен.БазоваяЕдиница;
                Номен.Записать();
   Дед Иван
11 - 29.11.04 - 11:22
Спасибки всем огромное , отдельное спсб Вадиму ! Седня кошмарный день с этим переходом :) Сроки урезали , приходится переходить фиг знает как :)



Список тем форума

Форум Территория 1С

Рекламное место пустует   Рекламное место пустует
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует