Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Подбор без помеченных на удаление

Ø
Я
   Pride
26.11.04 - 07:12
Доброе утро
Подскажите, как лучше изменить для торгушки справочник номенклатуры - форма подбора, чтоб помеченные элементы на удаление не отображались? Если есть готовая разработочка посмотреть, буду очень признателен ...
 
 
   Pride
1 - 29.11.04 - 07:19
вверх
   callisto
2 - 29.11.04 - 07:24
у формы списка справочника есть метод:
ИспользоватьСписокЭлементов()
это тебе и нужно.
   Pride
3 - 29.11.04 - 07:58
Клева, а что при этом происходит с иерархией? Какие-то вопросики!
   MetaEditor
4 - 29.11.04 - 08:14
кажется ИерархическийСписок(0,0)
   Дяпти
5 - 29.11.04 - 08:18
Тормозить будет страшно. Лучше завести скрытый реквизит, изменяемый при установке/снятии пометки удаления и выводить с отбором по нему.
   Mihasya
6 - 29.11.04 - 08:19
(0)
Процедура ПриВыбореРодителя(Группа)
 Спр.ИспользоватьРодителя(Группа);
 Спр.ВключатьПодчиненые(0);
 Спр.ВыбратьЭлементы();
 Пока Спр.ПолучитьЭлемент() > 0 Цикл
  Если Спр.ПометкаУдаления() > 0 Тогда
   Продолжить;
  КонецЕсли;
  Список.ДобавитьЗначение(Спр.ТекущийЭлемент());
 КонецЦикла;
 ИспользоватьСписокЭлементов(Список);
КонецПроцедуры
.
Процедура ПриОткрытии()
  ИерархическийСписок(1, 0);
  ПриВыбореРодителя();
КонецПроцедуры
   Мутабор
7 - 29.11.04 - 08:32
Нужно как в ЗиКЕ - "Уволенные".
   Pride
8 - 29.11.04 - 08:33
Процедура БезУдал()
  //Нужно избавиться от помеченых на удаление элементов
  СписокДействийФильтра = СоздатьОбъект("СписокЗначений");
  СписокДействийФильтра.ДобавитьЗначение (1,"Убрать удаленные объекты");
  СписокДействийФильтра.ДобавитьЗначение (0,"Показать все объекты");
  Действие = 0 ;
  Если СписокДействийФильтра.ВыбратьЗначение(Действие,,,,1)>0 Тогда
    Список = СоздатьОбъект("СписокЗначений");
    Буфер = СоздатьОбъект("Справочник.Номенклатура");
    Буфер.ВыбратьЭлементы();
    Пока Буфер.ПолучитьЭлемент() = 1 Цикл
      Если (Буфер.ПометкаУдаления () = 0) или (Действие = 0) Тогда
        Список.ДобавитьЗначение(Буфер.ТекущийЭлемент());
      КонецЕсли;
    КонецЦикла;
    Список.Сортировать ();
    ИспользоватьСписокЭлементов(Список);
    ИерархическийСписок(0,0);		
  КонецЕсли;
КонецПроцедуры
.
Это будет тупняк? Ай яй, как не вовремя (5)!



Список тем форума

Форум Территория 1С

Рекламное место пустует   Рекламное место пустует
2 + 2 = 3.9999999999999999999999999999999...
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует