Вход | Регистрация


1С:Предприятие ::

Метки:

Таблица значений - добавил одну строку, не могу другую

Ø [Волшебник, 05.12.04 - 21:09]
Я
   Serg_Y
04.12.04 - 20:12
Процедура ВводСтроки()
        
  //ДаНет = "";

  //РезДанет = 0;

  //  

  //Пока РезДанет = 0 Цикл

   ТКол = "";
   ТКол = тбУчет.ТекущаяКолонка();
   ТСтр = 0;
   ТСтр = тбУчет.ТекущаяСтрока();
                
   Если ТСтр = 0 Тогда
                        
      Контр = "";
      Счстар = "";
      РезКонтр = 0;
      РезСчстар = 0;
                        
      Пока РезКонтр = 0 Цикл
         РезКонтр = ВвестиЗначение(Контр,"Контрагенты","Справочник.Контрагенты");
         Если РезКонтр = 0 Тогда
           Вопрос ("Вы не выбрали Контрагента !!!
                    |Выберите Контрагента !!!",0,20);
         КонецЕсли;
      КонецЦикла;
                        
      тбУчет.НоваяСтрока();
      тбУчет.Контрагент = Контр;
                        
      Пока РезСчстар = 0 Цикл
         РезСчстар = ВвестиЗначение(Счстар,"СчСтарый","Справочник.СчСтарый");
         Если РезСчстар = 0 Тогда
           Вопрос ("Вы не выбрали СчСтарый !!!
                    |Выберите СчСтарый !!!",0,20);
         КонецЕсли;
      КонецЦикла;
                
      тбУчет.СчСтарый = Счстар;
      СумБол = 0;
                        
      Пока СумБол =0 Цикл
         Сум = 0;
         РезСум = 0;
         Пока РезСум = 0 Цикл
            РезСум = ВвестиЧисло(Сум,"Сумма",13,3);
            Если РезСум  = 0 Тогда
              Вопрос ("Вы не ввели Сумму !!!
                       |Введите Сумму !!!",0,20);
            КонецЕсли;
         КонецЦикла;
        Если Сум > СуммаСНДС Тогда
           Вопрос ("Введенная сумма не может быть больше суммы с НДС !!!
                    |Введите другую сумму !!!",0,20);
         Иначе
            СумБол = 1;     
         КонецЕсли;
      КонецЦикла;
                                                
      тбУчет.Сумма = Сум;
                        
   КонецЕсли;
                
  //      ДаНет = Вопрос ("Вы хотите ввести еще одну строку?",4,5);

  //      

  //      Если ДаНет = 6 Тогда

  //              РезДанет = 1;

  //      КонецЕсли;

  //КонецЦикла;   

                
КонецПроцедуры  

// YeS
 
 
   vS
 
1 - 04.12.04 - 20:14
поконкретнее, что неможешь то?
   Serg_Y
2 - 04.12.04 - 20:15
Короче эта ТЗ расположена на форме
вот эта процедура (формула этой ТЗ)
не могу доделать что бы после первой строки создавалась вторая по такому же принцыпу
   1С Дурочка
3 - 04.12.04 - 20:21
Давай сюда весь модуль со всеми закомментированными строками. Пробелов побольше поставь.
   Serg_Y
4 - 04.12.04 - 20:23
vS
1 - 04.12.04 - 20:14
не получается организовать еще один цыкл
:-(((
   vS
 
5 - 04.12.04 - 20:24
а что делает? не добавляет или как?
   vS
 
6 - 04.12.04 - 20:24
а цыкл зачем?
   NiGMa
 
7 - 04.12.04 - 20:25
(2) А зачем все это вешать на ТЗ? Ты 1С с ума сведешь - на элементе диалога формула, добавляющая в него строки... брррр!
Сделай кнопку - на нее и повесь.
   vS
 
8 - 04.12.04 - 20:25
а....

5 сек
   vS
 
9 - 04.12.04 - 20:26
Если ТСтр = 0 Тогда
сечешь?
   Serg_Y
10 - 04.12.04 - 20:27
vS
9 - 04.12.04 - 20:26
???
 
 
   NiGMa
 
11 - 04.12.04 - 20:31
ТСтр = тбУчет.ТекущаяСтрока(); 
                
  Если ТСтр = 0 Тогда
   vS
 
12 - 04.12.04 - 20:33
если одну добавишь, то она уже не будет номер 0
   Ёжик в тумане
 
13 - 04.12.04 - 20:55
"Опять Рупор прикалывается" (с)
   vS
 
14 - 04.12.04 - 20:55
думаешь? :)
   Лошадка в пальто
 
15 - 04.12.04 - 20:59
Гавно ветка
   vS
 
16 - 04.12.04 - 21:01
хы
как и все остальные :)
   NiGMa
 
17 - 04.12.04 - 21:01
Не то слово :(
   vS
 
18 - 04.12.04 - 21:12
а вот, если не флейм был, то очень не люблю, когда не благодарят за помошь...

недавоно, ситуация:
в яшике письмо, по подписи от девушки, мол живу в дыре хрен знает где, мыло в инете нашла, помоги с 1С, ну вроде помог, выслал...
тишина...
написал что не хорошо быть неблагодарной, тишина...
написал, что ссука она :) тишина...
сегодня опять от нее же письмо, мол это снова я, помоги, заранее благодарна... а уж я то как рад...
вигвам ей короче.... :(
   Ёжик в тумане
 
19 - 04.12.04 - 21:16
(18) Какой ты нетерпеливый...
   vS
 
20 - 04.12.04 - 21:17
ага, всего 2 недели ждал благодарности :)
   Ёжик в тумане
 
21 - 04.12.04 - 22:12
(20) А из твоих показаний и не следует, что благодарность подразумевалась
   Serg_Y
22 - 04.12.04 - 22:54
Всем спасибо за помошьвроде получилось еще один цыкл организовать
единственный еще вопрос
в 7.7 одна таб часть в доке
с помощью ТЗ+Док пытаюсь создать еще одну
подскажите кому нить удавалось в одной процедуре прописать создание строк  таб части удаление и исправление уже имеющихся
как в таб части
Заранее огромное спасибо!!!
   vS
 
23 - 04.12.04 - 23:02
удавалось
я спать пошел
   vS
 
24 - 04.12.04 - 23:02
(21) а ее проситьт и не должно, сами должны разуметь
   Ёжик в тумане
 
25 - 04.12.04 - 23:48
(24) Нифига. Обязательств не брала - значит ничего не должна.
   syktyk
 
26 - 05.12.04 - 00:17
vS, адрес девушки в студию, а заоодно и вопрос, хотя конечно он гуано...
Ужо мыей намылим че-либо!
   Птица
 
27 - 05.12.04 - 00:27
Джентльмен не должен ждать, а тем более требовать благодарности
   vS
 
28 - 05.12.04 - 10:42
а порядочные девушки должны быть благодарны... а не наглы...
я удалил все...
   Guk
 
29 - 05.12.04 - 10:50
(28) Подробней. Что удалил, состав, консистенция, маркировка...
   vS
 
30 - 05.12.04 - 10:54
письма удалил :) соотв. адрес сказать не могу... Таня какая то, с приморья, не из Питера %))
   Guk
 
31 - 05.12.04 - 10:55
(30) Таня с приморья...
Такая романтика, а ты...
;)
   vS
 
32 - 05.12.04 - 10:58
хы...
вот еслиб фотку выслала, тагда да... а так одно нервенное растройство...
   Ёжик в тумане
 
33 - 05.12.04 - 12:32
Она поди и была благодарна... заочно...
Плюс вероятность склероза тоже нельзя исключать..
 
  Рекламное место пустует
   aa
 
34 - 05.12.04 - 20:04
(32)А мож до тебя просто очередь ещё не дошла?
Губы то у ней тоже отдыхать должны, или как по твоему?
   NiGMa
 
35 - 05.12.04 - 20:06
(34) Эт' зачем?
то есть эт' которые? ;)
   Мистер Крутой
36 - 05.12.04 - 20:08
(24-35) Придурки.
   aa
 
37 - 05.12.04 - 20:10
(35)Эт` те которые в наличии, обычно так бывает...
   427
 
38 - 05.12.04 - 20:18
(36) Особый экземпляр... заменишь стаю дятлов...
   Мистер Крутой
39 - 05.12.04 - 20:19
(38) Тебя долбить - клюв сломать можно.
   Guk
 
40 - 05.12.04 - 20:20
(39) Ты с майдана?...
Там дятлы стаями летают. Похоже ты из них...
   Мистер Крутой
41 - 05.12.04 - 20:22
(40) О, еще одно дерево заговорило!
Привет Буратины!...
   Guk
 
42 - 05.12.04 - 20:24
Мдя. Значит с майдана...



Список тем форума
Рекламное место пустует  
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует