Вход | Регистрация

1С:Предприятие ::

Метки:

Сообщениес кнопкой ОК

Я
   Serg_Y
04.12.04 - 16:11
Подскажите пожалуйста
Мне нада вывести сообщение "Выберите значение" и нажать кнопку ОК
заранее огромное спасибо!!!
 
 
   France
 
1 - 04.12.04 - 16:12
Предупреждение();
Вопрос()
   Serg_Y
2 - 04.12.04 - 16:14
Короче есть такой код

РезКонтр = ВвестиЗначение(Контр,"Контрагенты","Справочник.Контрагенты");
                
                Если РезКонтр = 1 Тогда
                        тбУчет.НоваяСтрока();
                        тбУчет.Контрагент = Контр;
                Иначе
                ??????        
               КонецЕсли;
Мне нада что бы юзер выбрал значение пока он не выберет дальше Конец если не пойдет :-)))))
   France
 
3 - 04.12.04 - 16:18
ничо не понял.. а в чом проблема то?... последнее предложение, если можно, по русски
   Serg_Y
4 - 04.12.04 - 16:21
Выскакивает окно для выбора значения
если юзер выбрал чтото то соответственно это записалось в ТЗ
мне нада что бы если он не выбрал ничего выскачило сообщение что нада что то выбрать с кнопокй ок и када он нажмет ОК что бы еще раз выскочило окно выбора значения
   NiGMa
 
5 - 04.12.04 - 16:24
В цикл все это.
Пока РезКонтр = 0 Цикл

КонецЦикла;
   France
 
6 - 04.12.04 - 16:26
можно так
Пока 1=1 Цикл
//Здесь твой код

 Если РезКонр = 1 Тогда Прервать;
КонецЦикла;
   France
 
7 - 04.12.04 - 16:26
(5)... неплохо))
   1С Дурочка
8 - 04.12.04 - 16:36
ВвестиЗначение(<?>,,,,)
Синтаксис:
ВвестиЗначение(<Значение>,<Подсказка>,<Тип>,<Длина>,<Точность>)
Назначение:
Вызов диалога для ввода значения заданного типа.
Возвращает: 1 - если в диалоге нажата кнопка 'ОК'; 0 - если нажата кнопка 'Отмена'.
   Serg_Y
9 - 04.12.04 - 16:57
NiGMa
5 - 04.12.04 - 16:24


РезКонтр = ВвестиЗначение(Контр,"Контрагенты","Справочник.Контрагенты");
    Пока РезКонтр = 0 Цикл
         Вопрос ("Вы не выбрали Контрагента !!!
                  |Выберите Контрагента !!!",0,20);
          РезКонтр = ВвестиЗначение(Контр,"Контрагенты","Справочник.Контрагенты");
     КонецЦикла;

   France
6 - 04.12.04 - 16:26
что то я ничего не понял
   France
 
10 - 04.12.04 - 17:01
РезКонт = 0;
Пока РезКонтр = 0 Цикл 
  РезКонтр = ВвестиЗначение(Контр,"Контрагенты","Справочник.Контрагенты"); 
 Если РезКонтр = 0 Тогда
  Вопрос ("Вы не выбрали Контрагента !!! |Выберите Контрагента !!!",0,20);      
 КонецЕсли;
КонецЦикла;
 
  Рекламное место пустует
   France
 
11 - 04.12.04 - 17:02
хотя, вместе "Вопрос()" я бы уже использовал "Предупреждение()"


Список тем форума
  Рекламное место пустует
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует