Вход | Регистрация

1С:Предприятие ::

Метки:

как из выписки достать значения?

Я
   mojo
 
03.12.04 - 13:29
дату и номер расчетных документов. которые в выписке: ДатаДокВходящий, НомерДокВходящий
 
  Рекламное место пустует
   Guk
 
1 - 03.12.04 - 13:30
А как пробовал?...
   laeg
 
2 - 03.12.04 - 13:38
Примерно так ...

ДокВыписка = СоздатьОбъект("Документ.Выписка");
ДокВыписка.ВыбратьДокументы();
Пока ДокВыписка.ПолучитьДокумент() = 1 Цикл
ДокВыписка.ВыбратьСтроки();
Пока ДокВыписка.ПолучитьСтроку() = 1 Цикл
Сообщить(ДокВыписка.НомерДокВходящий);
Сообщить(ДокВыписка.ДатаДокВходящий);
КонецЦикла;
КонецЦикла;
   vS
 
3 - 03.12.04 - 13:39
и шо, нету?
   mojo
 
4 - 03.12.04 - 13:52
...
Если ДокОсн.Вид() = "Выписка" Тогда
// Соберем проводки Выписки по полученным авансам в таблицу значений.

    Авансы = СоздатьОбъект("ТаблицаЗначений");
    Авансы.НоваяКолонка("Контрагент", "Справочник",,, "Контрагент", 20);
    Авансы.НоваяКолонка("Договор", "Справочник",,, "Договор", 12);
    Авансы.НоваяКолонка("Сумма", "Число",,, "Сумма аванса", 10);
    Авансы.НоваяКолонка("СуммаВВалютеДоговора", "Число");

//mojo 03.12.2004

    Авансы.НоваяКолонка("дата", "Дата",,, "Дата",);
    Авансы.НоваяКолонка("номер", "Число",,, "Номер", 10);
//mojo

    Авансы.ВидимостьКолонки("СуммаВВалютеДоговора", 0);

    Опер.НайтиОперацию(ДокОсн);
    СписокПроводок =    "51,62.2;
            |51,62.7;
            |52,62.22;";
    Опер.ВыбратьОперацииСПроводками(ДокОсн, ДокОсн, СписокПроводок);
    Пока Опер.ПолучитьПроводку() = 1 Цикл
        Авансы.НоваяСтрока();
    Если (Опер.Дебет.Счет = СчетПокоду("62.2")) или (Опер.Дебет.Счет = СчетПокоду("62.7")) или (Опер.Дебет.Счет = СчетПокоду("62.22")) Тогда
        Авансы.Контрагент = Опер.Дебет.Контрагенты;
        Авансы.Договор = Опер.Дебет.Договоры;
        Авансы.дата = ???;
                    
    Иначе
        Авансы.Контрагент = Опер.Кредит.Контрагенты;
        Авансы.Договор = Опер.Кредит.Договоры;
        Авансы.дата = Опер.Кредит.???;
        КонецЕсли;

...
   1С Дурочка
5 - 03.12.04 - 13:54
Ты уже определись из выписки или из проводок.
   laeg
 
6 - 03.12.04 - 13:58
Если через операцию то через СодержаниеПроводки ...
   mojo
 
7 - 03.12.04 - 13:58
а черт его знает. я плохо разбираюсь.
как я понял, тут беруться проводки, начало и конец которых задает выписка.
   1С Дурочка
8 - 03.12.04 - 13:59
Ну что тебе сказать? Черт тебя знает как тебе это сделать.
   laeg
 
9 - 03.12.04 - 14:04
(8)
Харе флудить ...

(7)
Посмотри внимательней (6) ...
   1С Дурочка
10 - 03.12.04 - 14:07
(9) Ну, если Вы разрешаете, я удаляюсь. Аппендикс.
 
 
   mojo
 
11 - 03.12.04 - 14:07
что-то вроде
Аванс.дата = Опер.СодержаниеПроводки.чтототам?
а как узнать или где искать что должно быть вместо чтототам?
спасибо
   laeg
 
12 - 03.12.04 - 14:10
Так трудно открытьБухгалтерию и посмотреть какую проводку делает Выписка и что содержит СодержаниеПроводки ...

Если мы посмотрим, то примерно увидим это
СодержаниеПроводки  = "03.12.2004, №345"

Есть вопрос как получить отселя дату и номер ?
   laeg
 
13 - 03.12.04 - 14:10
+(12) Это касается типовой бухгалтерии
   на
14 - 03.12.04 - 14:17
фихххххххххххххххххххххххххх
   mojo
 
15 - 03.12.04 - 14:42
сделал так. работает.
может еще как-нибудь можно, корректнее/быстрее?

Авансы.дата = Лев(Опер.ПервичныйДокумент, Найти(Опер.ПервичныйДокумент, ","));
Авансы.номер = Число(Прав(Опер.ПервичныйДокумент, СтрДлина(Опер.ПервичныйДокумент) - Найти(Опер.ПервичныйДокумент, "")));
   laeg
 
16 - 03.12.04 - 14:51
Через операцию больще ни как ...
Если только будешь искать соответствующую строку в Выписке и брать оттуда, но это не быстрей ...
   mojo
 
17 - 03.12.04 - 15:03
ну можно
Авансы.дата = Лев(Опер.ПервичныйДокумент, 11); 
написать

спасибо.
   laeg
 
18 - 03.12.04 - 15:08
(17)
Если это быстрее ... хех .... на 0.000001 секунды ...


Список тем форума
Рекламное место пустует   Рекламное место пустует
Выдавать глобальные идеи — это удовольствие; искать сволочные маленькие ошибки - вот настоящая работа.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует