Вход | Регистрация

1С:Предприятие ::

Метки:запросы, Запросы и построители

Выборка движений регистров запросом

Я
   kuv61
 
03.12.04 - 12:09
Почему при формировании книги продаж в 1С:Торговля+Склад 7.7 выборка движений из регистра Книга продаж выполняется, если  используется объектная переменная РегКнигаПродаж и не выполняется, если используется запрос?

Процедура Сформировать()       
    
    Перем Запрос, ТекстЗапроса;
    РегКнигаПродаж=СоздатьОбъект("Регистр.КнигаПродаж");
    РегКнигаПродаж.ВыбратьДвижения(ВыбНачПериода,ВыбКонПериода); 
    Пока   РегКнигаПродаж.ПолучитьДвижение()=1 Цикл
        Сообщить ("Регистр "+ РегКнигаПродаж.КредДокумент);    
    КонецЦикла; 
    
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)

    |Период с ВыбНачПериода по ВыбКонПериода;
    |КредДокумент = Регистр.КнигаПродаж.КредДокумент;
    |Группировка КредДокумент;"    ; 
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
    Пока Запрос.Группировка(1) = 1 Цикл 
        Сообщить ("Запрос "+Запрос.КредДокумент); 
    КонецЦикла;
КонецПроцедуры
 
 
   SnarkHunter
 
1 - 03.12.04 - 12:12
В запросе должны быть функции...

ЗЫ. Иногда документацию полезно читать...
   SnarkHunter
 
2 - 03.12.04 - 12:13
(+1)...в запросе по регистру...
   miki
 
3 - 03.12.04 - 12:13
Запрос к регистрам требует функций.
   miki
 
4 - 03.12.04 - 12:14
(3)+ Опоздал... Сорри.
   Птица
 
5 - 03.12.04 - 12:15
1 почему иногда? бывает вредно?
   321
 
6 - 03.12.04 - 12:16
Потому что инструкция для ламеров
   Птица
 
7 - 03.12.04 - 12:20
6 это заблуждение


Список тем форума
Рекламное место пустует   Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует