Вход | Регистрация


1С:Предприятие ::

Метки:

как из локального модуля вызвать функцию др локального модуля?

Я
   lenochka
03.12.04 - 11:38
как из локального модуля вызвать функцию др локального модуля? (локальный модуль - это модуль отдельного дока или чего-л другого)
 
  Рекламное место пустует
   321
 
1 - 03.12.04 - 11:41
(0)через контекст
   Птица
 
2 - 03.12.04 - 11:41
открытьформу()

приоткрытии()
если форма.параметр = чемуто тогда
вызватьлокальнуюпроцедуру();
статусвозврата(0);
конецесли;
   laeg
 
3 - 03.12.04 - 11:41
Юзайте поиск ....

Если по существу:
Открывать его и передавать параметр
ПриОТкрытии "др локального модуля" проверять параметр, и если он "ТОТ" что нам нужен, то выполнять определенные действия, в том числе и локальные процедуры ...
   Guk
 
4 - 03.12.04 - 11:41
(1) Правда?...
   lenochka
5 - 03.12.04 - 11:42
Если ТипЗначенияСтр(Форма.Параметр)="ГрупповойКонтекст" тогда 
             ДокСпис.НайтиДокумент(Форма.Параметр.ТекущийДокумент());
КонецЕсли; 
не работает
   321
 
6 - 03.12.04 - 11:44
(5) Сомневаешься?
   321
 
7 - 03.12.04 - 11:44
(6)->(4)
   lenochka
8 - 03.12.04 - 11:45
(6) констатирую факт
   Птица
 
9 - 03.12.04 - 11:49
(4) отстали мы с тобой от жизни, амиго :)
   Guk
 
10 - 03.12.04 - 11:50
(9) Да, видимо ;)...
 
  Рекламное место пустует
   lenochka
11 - 03.12.04 - 11:51
скорее всего я к функции неправильно обращаюсь:
ДокСпис = СоздатьОбъект("Документ.ПеремещениеТоваров1");
        
        Если ТипЗначенияСтр(Форма.Параметр)="ГрупповойКонтекст" тогда 
             ДокСпис.НайтиДокумент(Форма.Параметр.ТекущийДокумент());
        КонецЕсли; 

        ИсхТаблица = ДокСпис.Печать();
   lenochka
12 - 03.12.04 - 11:53
ошибка: Поле агрегатного объекта не обнаружено
   Guk
 
13 - 03.12.04 - 11:53
(11) Ну вот, я же говорил...
   lenochka
14 - 03.12.04 - 11:53
(Печать)
   1С Дурочка
15 - 03.12.04 - 11:54
Попробуйте как-нибудь шаблончик прикрутить.
   Птица
 
16 - 03.12.04 - 11:56
(12)lenochka, не получится через контекст, тебя обманули.
см.2,3 и слушай Гука
   321
 
17 - 03.12.04 - 11:57
(16)а как же FormEx, стисняюсь спросить?
   Guk
 
18 - 03.12.04 - 12:00
(17) Мы про штатные способы...
   Птица
 
19 - 03.12.04 - 12:00
(17)угу, а еще 8.0
   lenochka
20 - 03.12.04 - 12:16
я не могу при открытии формы передавать какой-л параметр, поскольку у меня там уже контекст передается
   prochor
 
21 - 03.12.04 - 12:18
   1С Дурочка
22 - 03.12.04 - 12:22
   Птица
 
23 - 03.12.04 - 12:27
20. список значений
сз.добавитьзначение(Контекст);
сз.ДобавитьЗначение(ВсеЧтоХочешь)
передавай список
з.ы. не буду спрашивать, зачем это надо
   lenochka
24 - 03.12.04 - 12:46
Процедура ПриОткрытии()
    Если ТипЗначенияСтр(Форма.Параметр)="СписокЗначений" тогда
        СЗ=Форма.Параметр;                        
        Команда=СЗ.Получить("Команда");
        Если "Печать"=Команда тогда  
            ИсхТаблица = Печать();  
            СтатусВозврата(1);
            Возврат;
        КонецЕсли;     
    КонецЕсли;     
КонецПроцедуры

ошибка: функция не обнаружена(Печать)
   Asmody
 
25 - 03.12.04 - 12:51
может так? 
   Печать();   
   СтатусВозврата(0); 
   Возврат;
   1С Дурочка
26 - 03.12.04 - 12:52
(24)
ИсхТаблица = Печать();   ?
Не будь дурочкой.
   lenochka
27 - 03.12.04 - 12:52
тогда процедура не обнаружена
   Asmody
 
28 - 03.12.04 - 12:54
так, телепат.длл поломатый сегодня. какую процедуру (функцию) вызываем?
   Птица
 
29 - 03.12.04 - 12:54
24 печать() функция или п роцедура?
   lenochka
30 - 03.12.04 - 12:56
вызываем функцию Печать() , которая возвращает таблицу
   Птица
 
31 - 03.12.04 - 12:57
27
1.печать() д.быть объявлена до ПриОткрытии
2.если процедура, то не надо никакиих присвоений, просто: Печать();
3. если ты не хочешь увидеть форму открытого документа, тогда СтатусВозврата(0);
   1С Дурочка
32 - 03.12.04 - 12:58
(30) Круто! Это ты сама придумала? Типа, нужна печатная форма - получите?
   lenochka
33 - 03.12.04 - 13:01
(31-2) мне нужно возвращать таблицу из печати, поэтому нужна функция.. может я конечно чего-то не понимаю..
 
  Рекламное место пустует
   1С Дурочка
34 - 03.12.04 - 13:03
Ты эту функцию сама писала?
   lenochka
35 - 03.12.04 - 13:03
1C Дурочка, вы уже давно в игноре, неужели еще не дошло?
   Птица
 
36 - 03.12.04 - 13:05
(33)функция так, функция, просто уточнила
а как насчет 31-1?
   lenochka
37 - 03.12.04 - 13:07
давайте разберемся, о каком модуле идет речь? из которого требуется извлечь таблицу или в котором ее получить?
   Птица
 
38 - 03.12.04 - 13:07
+(36)только тогда исхТаблицу неплохо бы вернуть, откуда вызвали, т.е. что-то типа:
Форма.параметр.Установить("Таблица",исхТаблица);
(иначе зачем ее получать?)
   lenochka
39 - 03.12.04 - 13:07
т е где писать функцию ПриОткрытии и все остальное?
   Guk
 
40 - 03.12.04 - 13:08
А об чем речь то вообще?...
   Птица
 
41 - 03.12.04 - 13:10
(39)разумеется, ПРиОткрытии() - процедура  модуля того объекта, который вы открываете черехз ОткрытьФорму, и Печать() которого хотите вызвать
   Птица
 
42 - 03.12.04 - 13:11
40 о том же, о чем и с утра :)
ты ничего не пропустил :))
   1С Дурочка
43 - 03.12.04 - 13:13
Думаю до сотни дотянем. Люблю такие вопросы и таких lenochka.
Внемательно
   lenochka
44 - 03.12.04 - 13:14
ага. так и есть
   lenochka
45 - 03.12.04 - 13:21
(38) Форма.параметр.Установить("Таблица",исхТаблица); 
это куда?
   Asmody
 
46 - 03.12.04 - 13:22
развод?! >;))
   lenochka
47 - 03.12.04 - 13:23
ну не сердитесь :) сами ведь когда начинали
   Птица
 
48 - 03.12.04 - 13:24
а я-то откуда знаю, куда? это же твоя таблица, делай с ней что хочешь.
просто, раз ты ее получила, было бы логично как-то ее использовать.
ну вставь сразу после исхТаблица = Печать();
   DimG
 
49 - 03.12.04 - 13:25
Прикольно, а. С умными лицами ведь контекст обсуждают.
 
  Рекламное место пустует
   Хто
50 - 03.12.04 - 13:27
сказал???
   lenochka
51 - 03.12.04 - 13:28
вывод один: мы не понимаем друг друга. возникает ошибка "Функция не обнаружена (Печать)" Кто-нибудь знает ответ?
   Guk
 
52 - 03.12.04 - 13:29
(51) Я знаю.
Её нет!...
   Asmody
 
53 - 03.12.04 - 13:31
(51) тебе ссылку, где это все толково описано в самом начале дали. иди читай. и не занимайся церебральным коитусом
   1С Дурочка
54 - 03.12.04 - 13:32
Хоть я уже давно в игноре я знаю много ответов на это вопрос. Выбирай любой:
1. Автор - дурочка
2. Автор - разводит кроликов
3. Функции Печать нет
4. Расположена в тексте модуля ниже чем приоткрытии
5. Мы не понимаем друг друга
   lenochka
55 - 03.12.04 - 13:33
неправильно, cflbcm? 2. она есть, в другом модуле.. и никакие списки значений, контексты и прочие советы не помогают ее вызвать
   1С Дурачок
56 - 03.12.04 - 13:33
Системная функция
Синтаксис:
ОбнаружитьФункцию(Процедуру)ВоВсехМодулях(Ид)
Параметры:
Ид-идентификатор функции или процедуры, как они прописаны в конфигураторе
   Птица
 
57 - 03.12.04 - 13:34
я устала...
товарищ, я вахту не в силах держать, сказал кочегар кочегару..
может, позже...
   1С Дурочка
58 - 03.12.04 - 13:36
Товарищи, не расходитесь!
Сейчас небольшой перерыв и, затем, энергично продолжим.
   1С Дурачок
59 - 03.12.04 - 13:40
(58)номер аси? может энергично продолжим?
   1С Дурочка
60 - 03.12.04 - 13:47
(59)номер аси? Ты что больной?
   1С Дурачок
61 - 03.12.04 - 13:48
(60)Я всегда удивлялся женской логике :)
   Ёжик в тумане
 
62 - 03.12.04 - 21:30
Вот и не верь после этого, что от 1С тупеют...
   Unforgiven
 
63 - 03.12.04 - 21:43
Прочитал все ветки и заметил что Ежик не дал не одного дельного совета в последнизх ветках. Опять Еж гонит



Список тем форума
Рекламное место пустует  
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует