Вход | Регистрация

1С:Предприятие ::

Метки:

Организовать Печать Ценников в три ряда

Я
   John
02.12.04 - 16:29
Как правильно написать код, чтоб ценники печатались не в 2, а в 3 ряда на стр.

в типовой типовой  ТиС такой код:

Процедура ДобавитьЦенник(Таб, Фирма, ПечНаименование, ПечЕдиница, ПечРозн, Столбик, Ряд) Экспорт
         
    Столбик    = ?(Столбик = 0, 1      , 0  );
    Ряд        = ?(Столбик = 0, Ряд + 1, Ряд);

    Если Ряд > 3 Тогда
         Таб.НоваяСтраница();
         Ряд = 1;
     КонецЕсли;
     
     Если Столбик = 0 Тогда
         Таб.ВывестиСекцию("Товар|Ценник");
     Иначе
         Таб.ПрисоединитьСекцию("Товар|Ценник");
     КонецЕсли;

КонецПроцедуры// ДобавитьЦенник()


//*******************************************

Процедура Сформировать(ТаблицаТоваров,Фирма)

   //  Создание Таблицы для выходного отчета

    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
     
    Столбик = 1;
     Ряд     = 0;

     ТаблицаТоваров.ВыбратьСтроки();
     Пока ТаблицаТоваров.ПолучитьСтроку() = 1 Цикл
         Если ПустоеЗначение(ТаблицаТоваров.Цена) = 1 Тогда
             Сообщить("У товара """ + ТаблицаТоваров.Товар + """ отсутствует цена.");
         Иначе
             ПечРозн    = глФРМ(ТаблицаТоваров.Цена, ТаблицаТоваров.Валюта);
             
             ПечНаименование    = ТаблицаТоваров.Товар;
             ДобавитьЦенник(Таб, Фирма, ТаблицаТоваров.Товар, ТаблицаТоваров.Единица, ПечРозн, Столбик, Ряд);
             глОживить(1);
         КонецЕсли;
    КонецЦикла;
     
   //Вызов выходного отчета в окно просмотра и редактирования.

    Таб.Опции(0,0,0,0,"ПечатьЦенников","ПечатьЦенников");
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Товарные ценники","");

КонецПроцедуры

Не могу догнать, что исправить... хелп
 
  Рекламное место пустует
   AlexMan
 
1 - 02.12.04 - 16:39
Если Ряд > 3 Тогда
       Таб.НоваяСтраница(); 
       Ряд = 1; 
   КонецЕсли; 
//поменяй на

   Если Ряд > 4 Тогда 
       Таб.НоваяСтраница(); 
       Ряд = 1; 
   КонецЕсли;
   John
2 - 02.12.04 - 16:49
Упс... Поправка в 3 столбца, а не ряда
   John
3 - 04.12.04 - 12:30
Вопрос с 3-мя столбцами решен. Теперь косяк именно с рядами. голову сломал, если кто может помогите найти ошибку.

Печатается лишняя НоваяСтраница через каждую полную... хде бага...
вот код:

//----------------------------------


Таб = СоздатьОбъект("Таблица");
Столбик = 2;
 Ряд     = 0;
        ВыбратьСтроки();
        
        Пока ПолучитьСтроку() > 0 Цикл
                Если Ряд > 3 Тогда
          Таб.НоваяСтраница();
          Ряд = 0; 
     КонецЕсли;
                
        ПечНаименование=Товар.Наименование;
        ПечЦена    = Цена;
        ПечДата    = РабочаяДата();
        ЕдИзм      = Товар.Ед;
        
        Если  Столбик > 1 Тогда
            Таб.ВывестиСекцию("Товар|Ценник");
            Столбик = 0;
            Ряд = Ряд + 1;
        Иначе
            Таб.ПрисоединитьСекцию("Товар|Ценник");
            Столбик = Столбик + 1;
        КонецЕсли;
            КонецЦикла;
    Таб.Опции(0,0,0,1,"ПечатьЦенников","ПечатьЦенников");
    
    Таб.ТолькоПросмотр(0);
    Таб.Показать("Ценник","");
КонецПроцедуры
   Старуха Юзергиль
 
4 - 04.12.04 - 14:03
(3)Дай адрес, свои ценники кину.
   John
5 - 04.12.04 - 14:16
2СЮ
Astralityanin@yandex.ru
//-----------------------
Заранее огромное спасибо! :)
   Старуха Юзергиль
 
6 - 04.12.04 - 14:20
(5)Кинула
   Ёжик в тумане
 
7 - 04.12.04 - 14:51
(6) Ты что же это демпинг тут разводишь??
Теперя это продают в соответствующих местах..
   Старуха Юзергиль
 
8 - 04.12.04 - 15:20
(7)Глядишь, на том свете реструктуризацию грехов сделают...


Список тем форума
  Рекламное место пустует
Здесь во втором сообщении вам дадут решение, а в двадцатом дадут правильное решение. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует