Вход | Регистрация

1С:Предприятие ::

Метки:регистры

вопрос про Партионный учет

Я
   boom
 
02.12.04 - 10:24
В приходной накладной я двигаю и Рег.ОстаткиТов и Рег.ПартииТов, а вот в накладной по перемешению??
нужно ли двигать Рег.ПартииТов??
 
 
   Eugene G
 
1 - 02.12.04 - 10:26
Как хочешь, лично я двигаю, поскольку есть потребность именно в перемещении конкрентных партий.
   boom
 
2 - 02.12.04 - 10:40
мне, просто, нужен партионный отчет, я хочу брать данные из Рег.ПартииТов, если его не двигать, то как же он будат менятся/двигаться. Сам же он не может двигаться :/

если двигать, то как? Мое квалификации хватило на это:
==============================================================
РегОст=СоздатьОбъект("Регистр.ОстаткиТоваров");
Если СравнитьТА()=-1 Тогда
   РегОст.ВременныйРасчет(1);
   РассчитатьРегистрыНа(ТекущийДокумент());
КонецЕсли;

     // Проверка на наличие на остатке

      ВыбратьСтроки();
      ФлагОтказа=0;
      Пока (ПолучитьСтроку()>0) Цикл
        Остат=РегОст.СводныйОстаток(СкладОткуда,ПММ,"Количество");
        Если Остат<КоличествоФакт Тогда       
            Сообщить("Нет товара "+СокрЛП(ПММ.Наименование)+" в колич. "
              +КоличествоФакт+" (имеется "+Остат+")");
              ФлагОтказа=1;
          КонецЕсли;    
      КонецЦикла;
  
      Если ФлагОтказа=1 Тогда
        НеПроводитьДокумент();
        Возврат;
      КонецЕсли;
  
         // Здесь будет записана методика списания по FIFO

    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
        КолСпис=КоличествоФакт;
          Запрос="";
          ТекстЗапроса="";
          Если ИтогиАктуальны()=0 Тогда
            ТекстЗапроса="
            |Период с ДатаДок по ДатаДок;";   
          КонецЕсли;
      
          ТекстЗапроса=ТекстЗапроса+"
          |РегСклад=Регистр.ОстаткиТоваров.Склад;
          |РегПММ=Регистр.ОстаткиТоваров.ПММ;
          |РегКолич=Регистр.ОстаткиТоваров.Количество; 
          |РегДок = Регистр.ОстаткиТоваров.ТекущийДокумент, Регистр.ПартииТоваров.Партия;
         //|РегПартия = Регистр.ПартииТоваров.Партия;

         //|ПартПММ = Регистр.ПартииТоваров.ПММ;

         //|Группировка Документ;

         // Упорядочить по РегДок.ДатаДок;

          |Функция КолКонОст=КонОст(РегКолич);
          |Условие (РегСклад=СкладОткуда);
         //|Условие (РегПММ=ПартПММ);

          |Условие (РегПММ=ПММ);";
          Запрос=СоздатьОбъект("Запрос");
      
          Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда
            Сообщить("Документ не проведен");
            НеПроводитьДокумент();
            Возврат;
          КонецЕсли;
          
          ТЗРегОстатков = СоздатьОбъект("ТаблицаЗначений");      
          Запрос.Выгрузить(ТЗРегОстатков);  
          
          ТЗРегОстатков.ВыбратьСтроку();
=============================================================
на этом мои знания заканчиваются. в Запросе что-то не так, где взять Партию, что бы двигать Рег.ПартииТов?
   boom
 
3 - 02.12.04 - 10:44
^ это из ОбработкаПроведения() Док.Перемещение :)
   Eugene G
 
4 - 02.12.04 - 10:47
Всер просто: если у тебя партионный учет в разрезе складов, то перемещение двигает партии, в противном случае нет.


Список тем форума
Рекламное место пустует   Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует