Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

7.7. Как выкинуть всех пользователей из базы?

Ø
Я
   HelpFinder
25.11.04 - 13:24
Как выкинуть всех из базы. Допустим обработкой изменяю значение константы, которая в глобальнике должна обработаться. но как выплнить закрытие по этому событию всех баз?
 
 
   Решил тоже сказать
1 - 25.11.04 - 13:39
Тебе нужно выгнать всех из ОДНОЙ базы или одного из ВСЕХ баз ?
   Решил тоже сказать
3 - 25.11.04 - 13:45
Вообще в инете обработок полно.
берешь обработку ожидания, она смотрит каждые 10 сек на константу, как только она равна 0, то начинает процедура завершить... не помню как пишется.
Или проверяется на наличие в определенного файла, создаешь файл - все вылетают ии базы :)
   drugC
4 - 25.11.04 - 13:49
Процедура ПроверитьКоманду()
Если Константа.ЗавершитьРаботу=Перечисление.Булево.Да тогда
Если Итерация=0 тогда
Итерация = 1;
Сигнал();Сигнал();Сигнал();
Сообщить("Через 1 минуту БАЗА ЗАКРОЕТСЯ (сама).","!!!");
Сообщить("У Вас есть 1 минута на СОХРАНЕНИЕ открытых документов!","!!!");
ИначеЕсли Итерация=1 тогда
Итерация = 2;
ЗавершитьРаботуСистемы(1);
ИначеЕсли Итерация>1 тогда
Итерация = 3;
ЗавершитьРаботуСистемы(0);
КонецЕсли;	
Иначе
Итерация = 0;		
КонецЕсли;	
КонецПроцедуры	
   WAR
6 - 25.11.04 - 14:44
(5) ЗавершитьРаботуСистемы() работает только для юзверей у которых ничего не запущено, т.е. если у кого то выполняется обработка, то его из базы не выгонит. Надежней так: КомандаСистемы("start tskill *1c* /A /V"); Выкидывает всех без исключения. Это на 2000 и 2003 виндах. На 2003 можно сделать еще умнее, чтобы выкидывало всех пользователей, кроме Администратора. Почитай taskkill /?.
   Fеникс
7 - 25.11.04 - 14:46
(6) RESET всё равно надёжней.
   WAR
8 - 25.11.04 - 14:49
Самый надежный способ не подцепить что-нить во время секса это им не заниматься вообще. Каждый раз грузить сервак для того чтобы выгнать всех юзверей это дилетанство или онанизм. ИМХО.
   Fеникс
9 - 25.11.04 - 14:51
(8) Килять вслепую процессы - не меньшее дилетанство. Последствия те же.
   WAR
10 - 25.11.04 - 14:53
(9) Только могут не тратиться несколько драгоценных иногда минуток на перезагрузку сервака.
 
 



Список тем форума

Форум Территория 1С

Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует