Вход | Регистрация


Информационные технологии ::

Метки:

Заполнить таблицу цен в справочнике номенклатура с помощью прогр.

Я
   Ann
 
20.02.04 - 18:56
Необходимо пройтись по всему справочнику номенклатура
и заполнить таблицу цен. Таблицу цен для одного элемента я заполнила. А как автоматически во всем справочнике сделать?
 
  Рекламное место пустует
   Черт
 
1 - 20.02.04 - 18:58
Ну и переберай элементы справочника и заполняй эту таблицу
   Ann
 
2 - 20.02.04 - 19:05
Спасибо за предложение, а как это сделать.
Я написала:
Спр = СоздатьОбъект("Справочник.Номенклатура");
Спр.ВыбратьЭлементы();
ПОка спр.получитьэлемент() = 1 Цикл
ОткрытьФорму("Справочник.номенклатура",,0);
Форма.Закрыть;
КонецЦикла;

_______________________
А форму я открываю и закрываю потому, что при открытии у меня таблица цен заполняется.
   Просто Феликс
3 - 20.02.04 - 19:06
(2) В таких случаях говорят: Мдя...
   Ann
 
4 - 20.02.04 - 19:08
(3) Что значит Мдя...
Спасибо ребята вы мне очень помогли... так, что я уже все сама сделала
   ally
 
5 - 20.02.04 - 19:08
зачем открытьформу то
   Ann
 
6 - 20.02.04 - 19:10
А у вас есть предложения лучше?
Но я не знаю как по другому сделать...
   Железный Феликс
7 - 20.02.04 - 19:10
(4) См. 5. Вот это и есть: Мдя...
   Ann
 
8 - 20.02.04 - 19:11
(5) а по какой процедуре мне таблицу цен на форме справочника номенклатуры заполнять?
   Железный Феликс
9 - 20.02.04 - 19:12
(6) Цена - это реквизит справочника "Номенклатура" или элемент подчиненного справочника "Цены"?
   Ann
 
10 - 20.02.04 - 19:14
Цена - это элемент подчиненного справочника "Цены"
 
  Рекламное место пустует
   ally
 
11 - 20.02.04 - 19:15
ну и обращайся реквизиту подчиненного справочника
   Ann
 
12 - 20.02.04 - 19:16
да сейчас попробую...
   Ann
 
13 - 20.02.04 - 19:29
Спасибо большое. Да действительно все уместилось в одной процедуре без всяких открытий дополнительных форм.
Еще раз спасибо...
   ally
 
14 - 20.02.04 - 19:30
Пжлст, приходи еще
   Ann
 
15 - 20.02.04 - 19:39
Но у меня еще вот какой вопрос.
Мне надо считать значение цены в справочнике цен у определенного элемента. Справочник цен подчиненный к справочнику номенклатура.

Спр = СоздатьОбъект("Справочник.Цены");
Спр.ВыбратьЭлементы();
Пока спр.получитьэлемент() = 1 Цикл
ОснЦена = Спр.Цена;
КонецЦикла;
________
ОснЦена -  переменная
   Железный Феликс
16 - 20.02.04 - 19:45
(15) Анечка, с удовольствием бы Вам помог, но код пишу только под ником Композитор. Лычку зарабатываю :). Пока ник забанен. Так что, извините.

Код неверный. Изучите процедуру ИспользоватьВладельца()
   Железный Феликс
17 - 20.02.04 - 19:47
+16 Точнее, метод.
   Ann
 
18 - 20.02.04 - 19:51
Спасибо, сейчас почитаю
   Ann
 
19 - 20.02.04 - 20:12
Спр1 = СоздатьОбъект("Справочник.Номенклатура");
...
...
Спр = СоздатьОбъект("Справочник.Цены");
Спр.ИспользоватьВладельца(Спр1.ТекущийЭлемент());
Спр.ВыбратьЭлементы();
Пока спр.получитьэлемент() = 1 Цикл
ОснЦена = Спр.Цена;
КонецЦикла;

Все равно ничего не выходит. В отладчике видно, что Спр.Цена = НеизвестныйОбъект  ... А что это значит?
   Ann
 
21 - 20.02.04 - 20:31
Может быть как-нибудь по другому можно узнать значение цены в этом справочнике?
   skunk
 
23 - 21.02.04 - 02:15
345


используй Получить(НужнаяДата)

P.S. а вообще то нужно говорить, какая конфа и какая редакция ...
   __345__
24 - 21.02.04 - 07:15
(23) Ну вот, видишь, кого то даже моя правильная подсказка достает...
   skunk
 
25 - 21.02.04 - 07:32
pit, ты же прекарсно знаешь, что почем...

правильную подскаску показали даже сказали что ее сказал ты
убили и за первой части...

ps в следующий раз не связывай их вместе тогда правильные ответы бить не будут



Список тем форума
  Рекламное место пустует
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует