Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:Запросы и построители

Не получается запрос?

Ø
Я
   tnpandrew
25.11.04 - 10:06
Формирую запрос который выбирает только те документы которые не имеют подчиненных документов функцией ДокОсн.ВыбратьПодчиненныеДокументы(,,Док)=0, при выпонении выдает ошибку о невозможности переопределения ссылок.
Как всетаки в рамках запроса можно использовать функции если не выборки документов, то хотябы проверки есть ли подчиненные или нет.
 
 
   NS
1 - 25.11.04 - 10:09
Текст запроса привести - ну очень тяжело.
   Mihasya
2 - 25.11.04 - 10:10
Функция ЕстьПодчиненные(Док)
Докум = СоздатьОбъект("Документ");
Возврат Докум.ВыбратьПодчиненныеДокументы(, , Док);
КонецФункции
Процедура Твоя()
ТекстЗапроса = "<
...
|Док = ТвойДокумент.ТекущийДокумент();
|Условие (ЕстьПодчиненные(Док) = 0);
КонецПроцедуры
   NS
3 - 25.11.04 - 10:11
Что такое
|Док = ТвойДокумент.ТекущийДокумент();?
Я таких методов в запросе не знаю.
   Mihasya
4 - 25.11.04 - 10:14
2(3) А подумать?
это например Документ.РасходнаяНакладная.ТекущийДокумент
ЗЫ Со скобками проперся...
   NS
5 - 25.11.04 - 10:15
(4) Ты издеваешься, или просто даже копи-пасте делать не умеешь?
Текст в форум скопируй.
   Mihasya
6 - 25.11.04 - 10:17
(5) Зачем копировать?
   NS
7 - 25.11.04 - 10:17
перем докум;
Функция ЕстьПодчиненные(Док)
Если док.Выбран()=1 тогда
Возврат Докум.ВыбратьПодчиненныеДокументы(, , Док);
Иначе
Возврат 1;// 0 - если надо.
КонецФункции
.........
Докум = СоздатьОбъект("Документ");
   NS
10 - 25.11.04 - 10:22
(9) О чем разговаривать можно, если человек даже текст запроса приводить не хочет.
Я так понимаю, что перед группировкой по документу, у него еще другая группировка есть.
 
  Рекламное место пустует
   NS
12 - 25.11.04 - 10:33
Прикольно...
(0) с (2) перепутал...



Список тем форума

Форум Территория 1С

  Рекламное место пустует
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует