Вход | Регистрация

1С:Предприятие ::

Метки:

Подчиненные документы

Я
   tonic
20.02.04 - 15:42
Люди помогите!!!
Как в модуле определить есть ли у документа подчиненные?
 
  Рекламное место пустует
   GrayT
 
1 - 20.02.04 - 15:45
ВыбратьПодчиненныеДокументы()
   tonic
2 - 20.02.04 - 15:55
ТекущийДокумент.ВыбратьПодчиненныеДокументы()=1
Почему 1С ругаеться?
Пишет что ему нехватает условий?:(
Что упустил?
   shura
 
3 - 20.02.04 - 15:58
Док=СоздатьОбъект("Документ");
Если Док.ВыбратьПодчиненныеДокументы(,,ТекущийДокумент())=1 Тогда будет тебе счастье...
   tonic
4 - 20.02.04 - 16:07
НЕА не хочет делать, вот кусок кода:
Функция ПроверитьВид()
    Док=СоздатьОбъект("Документ"); 
    Если ПустоеЗначение(ТекущийДокумент) = 0 Тогда
        Если  (ТекущийДокумент.ДатаДок=ТекущаяДата()) И (ТекущийДокумент.РаботСкл=1) Тогда
            Возврат "BRUSH["+ПолучитьЦвет(255,0,0)+"]";
        ИначеЕсли ТекущийДокумент.ДатаДок=ТекущаяДата() Тогда
            Возврат "BRUSH["+ПолучитьЦвет(255,150,150)+"]";
        ИначеЕсли (ТекущийДокумент.ДатаДок=ТекущаяДата()) И (Док.ВыбратьПодчиненныеДокументы(,,ТекущийДокумент())=1) Тогда
            Возврат "BRUSH["+ПолучитьЦвет(255,250,250)+"]";
        КонецЕсли;
    КонецЕсли;
    Возврат "";
КонецФункции
   GrayT
 
5 - 20.02.04 - 16:08
Это модуль чего?
   Композитор
 
6 - 20.02.04 - 16:11
(4) В контексте данного кода параметром функции должен быть ТекущийДокумент, а не ТекущийДокумент()
   GrayT
 
7 - 20.02.04 - 16:12
Так модуль формы журнала
После ВыбратьПодчиненные... нужно ПолучитьДокумент()
Но он туды все одно не дойдет - на первом ИначеЕсли свернет
   tonic
8 - 20.02.04 - 16:12
GrayT: для смены цвета в Журнале Счетов
   GrayT
 
9 - 20.02.04 - 16:13
(6) угу, сам заметил, когда присмотрелся :)
   tonic
10 - 20.02.04 - 16:15
Спасибо все заработало:)))
 
 
   GrayT
 
11 - 20.02.04 - 16:18
Впрочем, можно и без Получить...
   tonic
12 - 20.02.04 - 16:22
GrayT Можно я так и cделал:)


Список тем форума
  Рекламное место пустует
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует