Вход | Регистрация


1С:Предприятие ::

Метки:

Как менять цвет шрифта в таблице?

Я
   zx
 
30.11.04 - 12:04
Напишите пллиз метод, те последоваетльность команд чтобы, изменить цвет шрифта при выводе строк таблицы.
 
 
   miki
 
1 - 30.11.04 - 12:06
Метод вот: ЦветТекста().
А последовательность команд, это, кажется, алгоритм.
   big
 
2 - 30.11.04 - 12:07
1. ТаблицаЗначений
2. Таблица 
3. Таблица Ексель
4. Таблица результатов по гольфу

В какой?
   Бивень
 
3 - 30.11.04 - 12:07
Становись! Равняйсь! Смирно! Таб.Область(Таб.ВысотаТаблицы(),1).ЦветТекста(255)! Вольно! Разойдись! ...
   big
 
4 - 30.11.04 - 12:08
(3) Разрешите бегом!!??
   zx
 
5 - 30.11.04 - 12:12
big - вот тестывый код.
Таб = СоздатьОбъект("Таблица");
Пока Запрос.Группировка(1) = 1 Цикл
// Заполнение полей ТМЦ

Таб.ВывестиСекцию("ТМЦ");
ОблСут = Таб.Область("R4C2");

ОблСут.Шрифт("Arial"); 
ОблСут.РазмерШрифта(10);
 ОблСут.ЦветТекста(233, 67 , 1); 
 ОблСут.ЦветТекста(233, 67 , 1); 


    КонецЦикла;

miki я знаю команды но мне нужен алгоритм их применения, потомучто не работает.
   zx
 
6 - 30.11.04 - 12:17
Бивень мне нада только некоторые ячейки вывести др. цвет.
   big
 
7 - 30.11.04 - 12:23
(5) ИМХО область неверно задана. Должно быть что-то типа:
ОблСут = Таб.Область("R4C2:R6C2");
попробуй.
   Бивень
 
8 - 30.11.04 - 12:24
(7) Иногда лучше жевать (с) СнаркХантер
   zx
 
9 - 30.11.04 - 12:34
big поборабону. просто выводятся пустые строки после заголовка....а потом уже строки данных отчета
   miki
 
10 - 30.11.04 - 12:35
(7)Можно и так задавать. Щас проверил.
(5)А что конкретно не работает? Ты, по-ходу, разукрашиваешь пустую ячейку.
 
  Рекламное место пустует
   zx
 
11 - 30.11.04 - 12:41
вместо разукрашенного текста который должен выводиться "Таб.ВывестиСекцию("ТМЦ");" просто выводится пустая строка
   miki
 
12 - 30.11.04 - 12:43
Вот только что сделал цветомузыку:

...    Цикл    
            E=E+1;Ном=Ном+1;
        Таб.ВывестиСекцию("Строка");
        ОблСут=Таб.Область("R"+(5+Ном)+"C"+E);
        ОблСут.ЦветТекста(20+E*40, 100+E*10 , E*50);
        Если E>3 Тогда E=0 КонецЕсли;

... КонецЦикла;

Работает.
Тебе надо вычислять адреса нужных ячеек. А ты красишь одну и ту-же. Причем пустую, по-ходу.
   big
 
13 - 30.11.04 - 12:48
(12) Однозначно. Сам только что проверил.
   Бивень
 
14 - 30.11.04 - 12:51
(12) Зачем вычислять адреса нужных ячеек? Почему просто нельзя их тупо брать и подставлять?
   miki
 
15 - 30.11.04 - 12:51
(12)+ Только косяк все-равно какой-то лезет - пустая строка, после первой в цикле. Пока не понял почему.
   miki
 
16 - 30.11.04 - 12:51
(14)Откуда брать?
   big
 
17 - 30.11.04 - 12:53
(16) Он имеет ввиду именованные области.
   miki
 
18 - 30.11.04 - 12:54
(17)Кто "он"? Ты тоже телепат?
   Бивень
 
19 - 30.11.04 - 12:54
(17) Нет, не именованые ...
(16) Смотря, что красить надо ...
   Прапорщик Задов
 
20 - 30.11.04 - 12:56
Бивень, ты запятые наугад ставишь?
   big
 
21 - 30.11.04 - 12:56
(18) Он - это Бивень. Бивень, или ты это "она".
(19) Именованные тоже красит, но только в той позиции где "поименовали" в Конфигураторе.
   Бивень
 
22 - 30.11.04 - 13:01
(20) Меня по русскому в школе еле-еле за уши на трояк вытянули ...
А где я сейчас не попал?
(21) Я - мужчина!
   zx
 
23 - 30.11.04 - 13:03
Да красит строки .. но у меня пару пустых строк еще добавляется..
   miki
 
24 - 30.11.04 - 13:04
По старой доброй традиции автор канул в лету. По англицки. Теперь должны прийти Атцы и навешать трендюлей.
   miki
 
25 - 30.11.04 - 13:04
(23)+24 Ой. Ты еще здесь? Все стереть.
   zx
 
26 - 30.11.04 - 13:06
понял проблему 
     ОблСут=Таб.Область("R"+(5+Ном)+"C"+E);
нада поменять на
     ОблСут=Таб.Область("R"+(1+Ном)+"C"+E);
   big
 
27 - 30.11.04 - 13:06
(22) Не то чтобы не попал - вообще зря стрЕльнул (во второй строке (19))
   miki
 
28 - 30.11.04 - 13:07
(26) Ну да. У меня шапка высотой в 5 строк.
Пустую строку выводит? Победил? Как?
   Бивень
 
29 - 30.11.04 - 13:08
(27) Ааа ... Ну, может быть ...



Список тем форума
Рекламное место пустует   Рекламное место пустует
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует