Вход | Регистрация

1С:Предприятие ::

Метки:

Реализация подбора...

Я
   Slovar
 
30.11.04 - 10:24
Попробывыл организовать подбор складов следующим образом:

Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)
    
Если ТипЗнч(ЗначениеВыбора) = Тип("СправочникСсылка.СкладКомпании") Тогда
    Строка = ТПСклады.Найти(ЗначениеВыбора,"СкладКомпании");
    Если Строка = Неопределено Тогда

        Строка = ТПСклады.Добавить();
        Строка.Склад = ЗначениеВыбора;
        Строка.Количество = 1;
        КонецЕсли; 
 КонецЕсли;
КонецПроцедуры

В итоге при выборе склада  программа даже не заходит в эту процедуру...
Подскажите в чем моя ошибка?:-(
 
 
   Иешуа
 
1 - 30.11.04 - 10:36
Эта процедура назначена обработчиком события?
   Slovar
 
2 - 30.11.04 - 10:42
Ну да!Обработчик у формы ОбработкаВыбора
   Иешуа
 
3 - 30.11.04 - 10:50
В УТ это реализовано так: В командной панели привязанной к табличной части есть кнопка подбора у которой в свойствах в поле действие задана процедура обрабатывающая подбор.


Список тем форума
 
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует