Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

как красиво свернуть тз

Ø
Я
   коля
24.11.04 - 18:11
есть таблица значений с колонками
номенклатура,документ,количество
хх,№1,1шт
хх,№75,2шт
хх,№4,4шт
уу,№5,1шт
zz,№48,4шт
zz,№47,1шт
нужно свернуть
хх,7шт,№1,№75,№4
уу,1шт,№5
zz,5шт,№48,№47
те нужно в колонке тз иметь список документов
у кого какие идеи
 
 
   дущ
1 - 24.11.04 - 18:16
красиво не получится, не меньше 4-х строчек кода
   коля
2 - 24.11.04 - 18:17
а как ?
   Гений 1С
3 - 24.11.04 - 18:22
Скачай разработку РедакторТЗ (там есть обработка Группировка ТЗ).
Она тебе поможет.
Группируй так номенклатура - документ, суммируем по количеству
Даст тебе таблицу:
номенклатура тз_дети количество,
а тз_дети - документ количество...
то, что доктор прописал, только вызвать ее и все.
Может и больше чем четыре строчки на вызов внешней обработки, но красиво и писать ничего не надо и вообще полезно.
   коля
4 - 24.11.04 - 18:24
3-а где скачать?
   Редкий гость
5 - 24.11.04 - 18:29
ТЗ.НоваяКолонка("Красота")
ТЗ.Сортировать("Полеxxyyxx")
Для й=-ТЗ.КоличествоСтрок() по -2 цикл
Если ТЗ.Полеxxyyzz=ТЗ.ПолучитьЗначение(-й-1,"Полеxxyyzz") тогда
ТЗ.УстановитьЗначение(-й-1,ТЗ.ПолучитьЗначение(-й-1,"Красота")+Строка(Чтохочудобавить));
ТЗ.УдалитьСтроку(-й);
КонецЦикла
   Rizvan
6 - 24.11.04 - 18:32
НовТабл = создатьОбъект("ТаблицаЗначений");
НовТабл.НоваяКолонка("К1");
НовТабл.НоваяКолонка("К2");
НовТабл.НоваяКолонка("К3");
СтарТабл.ВыбратьСтроки();
Пока СтарТабл.Получитьстроку() = 1 Цикл
НомСтр = 0;
Если НовТабл.НайтиЗначение(СтарТабл.К1, НомСтр, "К1") = 1 Тогда
НовТабл.ПолучитьСтроку(Номстр);
НовТабл.К2 = НовТабл.К2 + СтарТабл.К3;
НовТабл.К3 = НовТабл.К3 + ", " + СтарТабл.К2;
Иначе
НовТабл.К1 = СтарТабл.К1;
НовТабл.К2 = СтарТабл.К3;
НовТабл.К3 = СтарТабл.К2;
КонецЕсли;
КонецЦикла;
   Редкий гость
7 - 24.11.04 - 18:33
(+5)Сорри немного нетрезв
В 4-й строке прпущен 2-й аргумент
   Гений 1С
8 - 24.11.04 - 18:53
(4) http://1c.proclub.ru/modules/mydownloads/personal.php?cid=5&lid=1877<br>Пригодится для отчетов и других



Список тем форума

Форум Территория 1С

Рекламное место пустует   Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует