Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Делитантский вопрос

Ø
Я
   SaLLIok
24.11.04 - 14:28
Хочу сделать типа чата в 1С, например: если нужно чтобы все вышли из базы, для того чтобы всем не звонить, написал месагу всем и все. В принципе я сделал но только с помощью процедуры ОбработкаОжидания. Как это можно еще сделать?
 
 
   Рамиль
1 - 24.11.04 - 14:34
где-то я уже видел готовый чат для 1С.
а ОбработкаОжидания ресурсов много ест?
   Antaid
2 - 24.11.04 - 14:35
1c.proclub.ru
   Fеникс
3 - 24.11.04 - 14:35
(1) Почти совсем не ест.
Только не будет никто в этом чате сидеть.
   2S
4 - 24.11.04 - 14:36
видел аську написанную на 1С, поспрашивай
   sashat
5 - 24.11.04 - 14:38
А тетенька уйдет пить чай и оставит 1С.
И пиши не пиши сообщения ей, а толку небудет.
   SaLLIok
6 - 24.11.04 - 14:40
В принципе мне даже не чат нужен, сколько месагу всем послать а то пользователей дофига всем звонить влом. Какой процедурой можно активировать проверку например изменения константы у другого пользователя, кроме ОбработкаОжидания? Допустим если ПриЗаписиКонстанты но она не реагирует если константу изменяешь программно.
   Antaid
7 - 24.11.04 - 14:40
Поставь Admin1C и не парься.
   Рамиль
8 - 24.11.04 - 14:41
(5) встречается вдоль и поперек. Просишь выйти на 5 минут всез, а одна овца или один овёц все равно найдется, который часами на экран не смотрит. Или смотрит, но не видит - закрывает не читая.
   NS
9 - 24.11.04 - 14:41
Сообщения были в типовых (Блокнот)
Чатов на 1С куча разных - внешние отчеты, встраиваемые в конфигурацию и т.д. + куча выгонов из бызы, с задержкой и отправкой соответствующего предупреждения.
   Uho
10 - 24.11.04 - 14:51
(5),(8) При входе юзер регистрируется в справочнике (статус 1) (при выходе-0)
в любой момент читаю справочник, смотрю, кто в базе, заполняю таблицу(пользователь,имякомпа). Ставлю галочки, кого выгнать (с предупреждением).
Нажимаю на кнопочку:
КомандаСистемы("net send "+таб.Комп+" Сообщение для "+Врег(СокрЛП(таб.Имя))+" от АДМИНИСТРАТОР: "+стрСообщение);
Но без ОбработкиОжидания не обойтись... Если кто-то не хочет выходить ставлю ему статус=2, а на его компе ОбработкаОжидания и он вылетает... И кстати больше не входит (ПриНачалеРаботыСистемы), пока я не разрешу...
 
  Рекламное место пустует
   SaLLIok
11 - 24.11.04 - 14:57
(10) а как быть если пользователь заполнял документ и не успел сохранить его?
   SaLLIok
12 - 24.11.04 - 15:01
(10) Так то не плохо придумал
   SlonSpb
13 - 24.11.04 - 15:04
(11) Обрати внимание на параметры ЗавершитьРаботуСистемы() ...
(0) "Делитантский" - это от слова Delete, или же Т1С вконец разучилась по русски общаться ?
   SaLLIok
14 - 24.11.04 - 15:06
(11) спасибо, обратил внимание :)
   Смотрящий от 1С
15 - 24.11.04 - 15:13
В каталоге ИБ из которой все идут в сад переименовывается файлик из stop2.all в stop/all и начинает работать процедурка...
//----------------------------------------------------------------------------------
Процедура ОстановкаСистемы() Экспорт
  ОчиститьОкноСообщений(); Сигнал();
  Сообщить("                                ВНИМАНИЕ! ОСТАНОВКА ПРОГРАММЫ.                                ","!!!");
  Сообщить("            Просьба сохранить все необходимые документы или элементы справочников.            ","!!!");
  Если ПопыткаВыхода=1 Тогда
    Коммент="Предупреждение об остановке системы.";
    ЗаписьЖурналаРегистрации(Коммент,,,,4);
  КонецЕсли;
  Предупреждение("Пожалуйста закройте все документы и выйдите из программы, автоматическое отключение произойдет через 1 минуту",10);
  ОбработкаОжидания("ОстановкаСист",60);
КонецПроцедуры//---------------------------------------------
Процедура ПроверкаОстановки() Экспорт
  Каталог=КаталогИБ();
  СтопФайл="stop.all";
  ФИмя=Каталог+СтопФайл;
  Если ФС.СуществуетФайл(ФИмя)=1 Тогда
    СохранитьЗначение("Табличка",1);
      ОстановкаСистемы();
  Иначе	
    СохранитьЗначение("Табличка",0);
  КонецЕсли;
  ФИмя="";
КонецПроцедуры//---------------------------------------------
   Смотрящий от 1С
16 - 24.11.04 - 15:17
Еще кусок ...
//---------------------------------------------
Процедура ПросмотрБлокнота() Экспорт
  // Вставлена проверка сигнала на завершение работы системы
  ПроверкаОстановки();
КонецПроцедуры//**************************************************************************
//Авто выключение клиентов программы у юзеров
//
ОбработкаОжидания("ПросмотрБлокнота",10);
ПопыткаВыхода=1;
Самых стойких достреливаем из PCAnywhere.
   Uho
17 - 24.11.04 - 15:24
А для самых стойких отключаем доступ к папке с 1С.
   SaLLIok
18 - 24.11.04 - 15:29
(17) Полностью поддерживаю :)



Список тем форума

Форум Территория 1С

  Рекламное место пустует
Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует