Вход | Регистрация

1С:Предприятие ::

Метки:формы

Картинка в форме

Я
   Dema
 
29.11.04 - 17:44
как хранить, как правильно загрузить...
подскажите, может в какой типовой конфе есть а то что-то ничего не получается.
 
 
   Dema
 
1 - 29.11.04 - 17:53
{Справочник.Прайс_лист.Форма группы.Модуль(53)}: Общая файловая ошибка при доступе к
что это значит
   Dema
 
2 - 29.11.04 - 18:05
ну в какой нибудь типовой картинки есть, так что их загрузить мона было
   big
 
3 - 29.11.04 - 18:10
Не знаю как там в типовых, у меня так...
На форме реквизит (не справочника!!) Картинка с идентификатором Фотография и невидимый текстовый реквизит с функцией ОбработкаСписка(). В справочнике текстовый реквизит ФайлФото, в каталоге ИБ папка с фотографиями, путь к которой хранится в глобальной переменной ФотоЯщик. Остальное смотри ниже.

Функция ОбработкаСписка()
    Сотр=ТекущийЭлемент();
    Форма.Фотография.Видимость(0);
   // выводим фотографию для просмотра

    Если СокрЛП(Сотр.ФайлФото)="" Тогда
        Возврат "";
    КонецЕсли;
    ИмяФайла=ФотоЯщик+СокрЛП(Сотр.ФайлФото);
    Если ФС.СуществуетФайл(ИмяФайла)=0 Тогда
        Возврат "";
    КонецЕсли;
    Форма.Фотография.Видимость(1);
    Фотография.Загрузить(ИмяФайла);
    Возврат "";
КонецФункции
   Dema
 
4 - 30.11.04 - 09:33
а еще что нибудь
   Dema
 
5 - 30.11.04 - 09:49
фото.Загрузить(путь);
{Справочник.Прайс_лист.Форма группы.Модуль(55)}: Общая файловая ошибка при доступе к  
что это значит, как исправить
   Dema
 
6 - 30.11.04 - 10:32
умников до ... а умных мало


Список тем форума
Рекламное место пустует  
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует