Вход | Регистрация


1С:Предприятие ::

Метки:

Как получить результат по колонкам табицы?

Я
   koshechka
 
29.11.04 - 13:02
Таблица в документе, колонок(столбцов) таблицы где-то 30, каждый столбец имеет свой идентификатор Д1, д2, д3 и т.п., последний д30.
В колонки записываются значения из перечислений. В конце хотелось бы получить количество перечислений одного типа. Мож. у кого есть идеи? Или это надо отдельно для каждой колонки прописывать?
 
 
   Diter
 
1 - 29.11.04 - 13:05
Сврнуть() не помогает?
   koshechka
 
2 - 29.11.04 - 13:05
Это таблица Документа!
   Diter
 
3 - 29.11.04 - 13:06
(+1) Я имел в виду доп.колонку с "1" и сворачивание по нужной колонке с данными с суммированием по доп.колонке. Цифра в ней после сворачивания - количество повторов.
   Diter
 
4 - 29.11.04 - 13:07
(2) Выгрузи в ТЗ.
   miki
 
5 - 29.11.04 - 13:08
(4) И так 30 раз.
   Ёжик в тумане
 
6 - 29.11.04 - 13:08
"...В конце хотелось бы получить..."?
P.S. Сейчас придёт прапорщик и всё опошлит.
   Бивень
 
7 - 29.11.04 - 13:08
(3) СвернутьПоСтолбцам()?
   Diter
 
8 - 29.11.04 - 13:10
(5) Ваши варианты?
(7) ???
   Diter
 
9 - 29.11.04 - 13:11
(5) В цикле батенька, в цикле.
   koshechka
 
10 - 29.11.04 - 13:13
Реквизит | д1 | д2 | д3 | Значение |
Где значение - это результат:
Если Д1=Этому тогда Значение=Значение+1;
Иначе Значение=Значение;
КонецЕсли;
Как получить по всей строке, или надо писать для каждого д?
 
 
   koshechka
 
11 - 29.11.04 - 13:14
(6) рада что тебе так весело
   Бивень
 
12 - 29.11.04 - 13:15
(10) См. ПолучитьАтрибут()
   miki
 
13 - 29.11.04 - 13:15
(8)А я не прикалываюсь, а дополняю. Если ей надо не 30 итогов, а один общий, то можно выгрузить все колонки в одну общую, а потом (1).
   Diter
 
14 - 29.11.04 - 13:16
(11) см. 9+12
   koshechka
 
15 - 29.11.04 - 13:16
Мне надо для каждой строки по всем столбца строки
   miki
 
16 - 29.11.04 - 13:21
(15) Два цикла - по строкам и по колонкам - при записи дока.
Или один после окончания редактирования строки - по колонкам.
   Diter
 
17 - 29.11.04 - 13:21
(15) И что...
ВыгрузитьТабличнуюЧасть(ТЗ);
ТЗ.ВыбратьСтроки()
Пока ТЗ.ПолучитьСтроку()=1 Цикл
Колонка=1;
Значение=0;
Пока Колонка<=ТЗ.КоличествоКолонок(0) Цикл
Контроль=ТЗ.ПолучитьЗначение(ТЗ.НомерСтроки,Колонка);
Если Контроль=ТоЧтоНужно Тогда
Значение=Значение+1;
КонецЕсли;
Колонка=Колонка+1;
КонецЦикла;
КонецЦикла;
   koshechka
 
18 - 29.11.04 - 13:24
Всем спасибо!
(17) - гораздо короче :-)))
ВыбратьСтроки();
Пока ПолучитьСтроку()>0 Цикл
М=1;    ДВ=0;
Пока (М>0) И (М<32) Цикл
К=ПолучитьАтрибут((СокрЛП("Д")+СокрЛП(М)));
Если К=Перечисление.Работа.Рабочий Тогда
ДВ=ДВ+1;
Иначе
ДВ=ДВ;
КонецЕсли;
ДВ=ДВ;
М=М+1;                                                                  
КонецЦикла;
Количество=ДВ;
КонецЦикла;
   miki
 
19 - 29.11.04 - 13:28
(18)Это что ты там считаешь?
   Diter
 
20 - 29.11.04 - 13:28
(18) Да, но неуниверсально. При добавлении новой колонки, даже с именем "Д33" прийдётся переписывать код. :) А так конечно, правда непонятно наличие трёх строк
ДВ=ДВ+1; 
Иначе // вот этой

ДВ=ДВ;// и вот этой

КонецЕсли; 
ДВ=ДВ;// и вот этой
   Бивень
 
21 - 29.11.04 - 13:29
(18)
СокрЛП("Д") - 5+
ДВ=ДВ; - 5++
   Пролд
 
22 - 29.11.04 - 13:32
Я ставлю 1 монгольский тугрик на то, что на 1С:Бухгалтерии самописные табеля для загадочных целей пишутся.
   Diter
 
23 - 29.11.04 - 13:35
(22) Похоже.
Я как то писал такую вещь как табеля для водителей и автозаполнял их (табеля) из путевых листов.
   koshechka
 
24 - 29.11.04 - 13:37
Мож. и для загадочных :-)))
   miki
 
25 - 29.11.04 - 13:39
(24)Так ты задачу опиши, загадочная. Может тебе проще 0/1 рисовать, чем перечисление тулить куда не треба.
   Diter
 
26 - 29.11.04 - 13:42
(24) А перечисления какие - "Работал", "Неработал"? Или "Восемь", "Шесть", "Двенадцать", "Сутки"? Или "Вышел", "Не вышел"?
   Пролд
 
27 - 29.11.04 - 13:44
+(26) Перечисления.П427.Нах, Перечисления.П427.Пох, и т.д.
   koshechka
 
28 - 29.11.04 - 14:55
(25) Я не загадочная, это табель. Просто если  б сразу сказала что табель делаю, сразу бы такие ответы были типа "смотри ЗиК, там все есть" Или еще лучше "купи ЗиК и все тебе будет".
(26) Перечисления да ты почти угадал работал, прогул, отгул, отпуск, больничный, безсодержания, ОднаВторая, ОднаВосьмая и проч.
   Diter
 
29 - 29.11.04 - 15:17
(28) Тогда посоветую не перечисления а количество отработанных часов. Тем более, что в табеле так и ставится количество часов.
   007
 
30 - 29.11.04 - 15:45
(22)
"Я как то писал такую вещь как табеля для водителей и автозаполнял их (табеля) из путевых листов"
В какой конфе, я сталкнулся с такой же проблемой?
   Diter
 
31 - 29.11.04 - 16:05
(30) АБТ-3.5 Украина.
   koshechka
 
32 - 29.11.04 - 18:21
(29) А если человек в отпуске, или у него прогул? А командировка? Тута с количеством часов в лужу сядешь
   koshechka
 
33 - 29.11.04 - 18:21
(30) Бухия для Беларуси
 
  Рекламное место пустует



Список тем форума
  Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует