Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

При проведении документа создавать и проводить другой документ на то же время

Ø
Я
   lukinskiy
23.11.04 - 20:26
Вопрос - правильно и разумно ли я ее решил? Может можно как-то лучше?
А то как-то коряво выглядит...
Решил так:
==========================================================================
Модуль документа, который должен создать и провести документ вида "XXX":
   
Процедура ПриЗаписи()
  _Час = 0; _Мин = 0; _Сек = 0;
  ПолучитьВремя(_Час,_Мин,_Сек);
  Док = СоздатьОбъект("Документ");
  Док.УстановитьФильтр(1,1,0,1,1,1);
  Док.ВыбратьПодчиненныеДокументы(,,ТекущийДокумент());
  Пока Док.ПолучитьДокумент() = 1 Цикл
    Если Док.Вид() = "РасчетыПоЗаявке" Тогда
      Док.Удалить();
    КонецЕсли;
  КонецЦикла;
  ОткрытьФорму("Документ.РасчетыПоЗаявке", 1, ТекущийДокумент());
  Док = СоздатьОбъект("Документ");
  Док.УстановитьФильтр(1,1,0,1,1,1);
  Док.ВыбратьПодчиненныеДокументы(,,ТекущийДокумент());
  Пока Док.ПолучитьДокумент() = 1 Цикл
    Если Док.Вид() = "РасчетыПоЗаявке" Тогда
        	Прервать;
    КонецЕсли;
  КонецЦикла;
  Док.УстановитьВремя(_Час,_Мин,_Сек);
  Док.ДатаДок = ДатаДок;
  Док.НомерДок = НомерДок;
  Док.Провести();
КонецПроцедуры// ПриЗаписи()
  
  
Модуль документа вида "XXX":
   
Процедура ПриОткрытии()
  Если Форма.Параметр = 1 Тогда
    Записать();
      СтатусВозврата(0);
    Возврат;
  КонецЕсли;
КонецПроцедуры// ПриОткрытии()
==========================================================================
 
 



Список тем форума

Форум Территория 1С

Рекламное место пустует   Рекламное место пустует
Прочитай, хотя бы, Митичкина "Разработка в системе 1С:Предприятие 8". Волшебник
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует