Вход | Регистрация

1С:Предприятие ::

Метки:

В языке 1С есть макроподстановки?

Я
   Linkovich
28.11.04 - 17:52
Помогите пож.! В таблице значений 50 полей с названиями п1, п2, п3...
Как мне их в цикле обойти? Есть ли в языке макроподсановки?
 
 
   ОбезьянаСГранатой
 
1 - 28.11.04 - 18:04
ТаблицаТвоя.ПолучитьЗначение(НомерСтроки,"п"+СчЦикла)
   Linkovich
2 - 28.11.04 - 18:11
ОбезьянаСГранатой, ну спасибо! Фу я тупняк поймал:)
   Ёжик в тумане
 
6 - 28.11.04 - 20:34
Не исчерпала себя тема.
Можно ещё вот так извратиться:
Для Колонка=1 По ТаблицаЗначений.КоличествоКолонок() Цикл
  Если Лев(ТаблицаЗначений.ПолучитьПараметрыКолонки(Колонка),1)<>"п" Тогда
    Продолжить;
  КонецЕсли;
  ЧегоТоТам=ТаблицаЗначений.ПолучитьЗначение(НомерСтроки,Колонка);
...
Вот теперь можно закрывать :)
   uchenik
 
10 - 28.11.04 - 23:53
(9) Про БухИтоги мыслей не возникло?
 
  Рекламное место пустует
   GrayT
 
12 - 28.11.04 - 23:55
(10)Слушай поднимай заного. Бывают глюки не только у меня.....
   uchenik
 
13 - 29.11.04 - 00:02
Процедура ПриИзмененииДаты()
        
    Если ДатаДок>БухИтог.КонПериода()
    Тогда
        Состояние("Расчет итогов. Подождите.");
        Сообщить("Не рассчитаны бухитоги на дату "+ДатаДок+Разделительстрок+"Выполните расчет итогов на нужную дату, а то будет тормозить.");
        Бухитог.Актуальность(1);
        Бухитог.ПериодД(,КонМесяца(ДатаДок));
        БухИтог.Рассчитать(,КонМесяца(ДатаДок));  
    Иначе
    БухИтог.ВыполнитьЗапрос(,ДатаДок,Сч41_4);
    КонецЕсли;
КонецПроцедуры
Пробую еще раз.
При выборе даты, за основн. итогами, расчет идет. Затем, если выбрать дату меньше, но после кон.периода осн. итогов, кричит что итоги не рассчитаны. Как быть?


Список тем форума
  Рекламное место пустует
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует