Вход | Регистрация


Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Итог()

Ø
Я
   Дед Иван
22.11.04 - 18:48
Создал таблицу печатную , есть столбец "сумма" и в секции "Итог" мне надо просуммировать значения в поле "сумма" . Пишу Итог("Сумма") #Ч015.2 ! После того как показываю таблицу , выводиться сообщение "функция Итог<>? не найдена
Че за замес может быть ?
 
 
   Синяя Птица
1 - 22.11.04 - 18:50
откуда показываешь таблицу?
   Lock
3 - 22.11.04 - 18:51
А откуда данные то выводятся? Из запроса или ТЗ?
   Дед Иван
4 - 22.11.04 - 19:13
я не в ТЗ делаю итог , а в таблице печатной хочу просто в секции его вывести
   дущ
5 - 22.11.04 - 19:21
очень надеюсь что ты это делаешь в модуле формы документа
   Синяя Птица
6 - 22.11.04 - 19:21
Дедушко, ты таблицу-то где формируешь? в обработке или в модуле формы документа?
   dma
7 - 22.11.04 - 19:29
Формат(Итог("Сумма"),"Ч015.2")
   Дед Иван
8 - 22.11.04 - 19:42
Я таблицу формирую в модуле , шапку и строки вывожу - все тип-топ ! а когда вывожу "подвал" - итоговую секцию то пишу в этой секции в таблице Итог(...)
   Дед Иван
9 - 22.11.04 - 19:44
В самом модуле я не пишу ф-цию Итог , я ее пишу именно в таблице в секции.
Мне просто в подвале надо просуммировать какой-нить столбец !
   Синяя Птица
10 - 22.11.04 - 19:49
(8)в модуле чего ты формируешь таблицу?
а. в модуле формы документа
б. в модуле обработки
в. не знаю
подсказка: посмотри, что написано в самой верхней строчке (белым по синему)
 
  Рекламное место пустует
   dma
11 - 22.11.04 - 19:54
Можно и так: Итог("Сумма") #Ч015.2
В реквизите документа "Сумма" должна стоять галка "Итог по колонке"
   Птица
12 - 22.11.04 - 20:07
Дед, это тебе не эксель, если речь не о модуле формы документа, а "сумма" - не его реквизит с проставленным флагом суммирования, то столбец сам по себе не просуммируется, итог вычислять нужно.
ты что за строки выводишь-то?
   Дед Иван
13 - 22.11.04 - 20:22
(8) В модуле документа формирую (и нефЫг меня считать за идиота :) )
(12) Строки вывожу : товар , цена , кол-во , сумма. Вот эту сумму и хочу именно не в модуле проссумировать , а в таблице в определенной ячейке
   Дед Иван
14 - 22.11.04 - 20:26
Итог по колонке стоит
   Oblomov
15 - 22.11.04 - 20:31
2(14) У тебя, как сумма в строках выводиться? "Запрос.Сумма" так?
Тогда и в итоге напиши "Запрос.Сумма"
   Дед Иван
16 - 22.11.04 - 20:32
в строке выводиться "сумма" и в итоге пишу "сумма" !
   Oblomov
17 - 22.11.04 - 20:34
Что такое "сумма"?
   Дед Иван
18 - 22.11.04 - 20:37
Сумма - это колонка в табличной части документа ! Я ее вывожу в секцию строка , а в итоговой секции в таблице именно в ячейке пишу Итог("сумма")
   Oblomov
19 - 22.11.04 - 20:49
Забудь про документ, сейчас речь об отчете. Как ты выбираешь данные? Запросом, перебором, как называеться переменная в которую данные попадают.
А лучше код покаж. (только самую суть)
   Дед Иван
20 - 22.11.04 - 21:03
Здесь в коде я присваиваю тоьлко значение переменной "сумма" и вывожу в секцию СТРОКА и именно в отчете хочу подвести ИТОГ
Пока ТЗ.ПолучитьСтроку() =1 Цикл
  
  Если НомерТабл = 0 Тогда
    Таб = СоздатьОбъект("Таблица");
    тМесто = ТЗ.КодКомнаты ;
    Таб.ВывестиСекцию("Шапка");
  КонецЕсли ;
  
  Если тМесто = ТЗ.КодКомнаты Тогда
    НомСтроки = НомСтроки + 1;
    КодМестаХранения_Строка = ТЗ.МестоХранения.ПолныйКод();
    СпрНом.НайтиЭлемент(ТЗ.Номенклатура);
    Код = СпрНом.ТекущийЭлемент().Код ;
    Наименование = ТЗ.Номенклатура;
    ЕдиницаИзмерения = ТЗ.Единица;
    Завод = ТЗ.Изготовитель;
    Серия = ТЗ.Серия ;
    КолПоДок = ТЗ.Количество;
    Количество = ТЗ.Количество;
    Цена = ТЗ.Цена ;
    СтавкаНДС = ТЗ.СтавкаНДС;
    НДС = ТЗ.СуммаНДС;
    ЦенаРозн = ТЗ.Цена;
    Сумма = ТЗ.Сумма;
    Сертификат = ТЗ.Сертификат;		
    Таб.ВывестиСекцию("Строка");
    НомерТабл = НомерТабл + 1 ;
  Иначе
    НомерТабл = 0 ;
    ТЗ.ПолучитьСтрокуПоНомеру(ТЗ.НомерСтроки - 1 ) ;
    Таб.ВывестиСекцию("Подвал");
    Таб.ПараметрыСтраницы(,,,,,,,,,,,"\\srv-pdc-01\po01");
    //Таб.Напечатать(0);
    Таб.Показать();
    НомСтроки =0 ;
  КонецЕсли;
КонецЦикла;
 Таб.ВывестиСекцию("Подвал");
 Таб.ПараметрыСтраницы(,,,,,,,,,,,"\\srv-pdc-01\po01");
 //Таб.Напечатать(0);
 Таб.Показать();
   Дед Иван
21 - 22.11.04 - 21:06
Вот упрощенный вариант :
    Таб = СоздатьОбъект("Таблица");
    Таб.ВывестиСекцию("Шапка");
Пока ТЗ.ПолучитьСтроку() =1 Цикл
  
    НомСтроки = НомСтроки + 1;
    КодМестаХранения_Строка = ТЗ.МестоХранения.ПолныйКод();
    СпрНом.НайтиЭлемент(ТЗ.Номенклатура);
    Код = СпрНом.ТекущийЭлемент().Код ;
    Наименование = ТЗ.Номенклатура;
    Сумма = ТЗ.Сумма;
КонецЦикла;
 Таб.ВывестиСекцию("Подвал");
 Таб.ПараметрыСтраницы(,,,,,,,,,,,"\\srv-pdc-01\po01");
 Таб.Показать();
   Полный Рост
22 - 22.11.04 - 21:07
"Заводи" новые переменные, в которые и суммируй соответствующие значения.
   Полный Рост
23 - 22.11.04 - 21:09
Перед циклом
СуммаОбщ = 0;
В цикле после
Сумма = ТЗ.Сумма;
добавляй
СуммаОбщ = СуммаОбщ + Сумма;
и в секции "Подвал" выводи СуммаОбщ
   Дед Иван
24 - 22.11.04 - 21:10
Мля-ха , походу я вкурил сам . Я то из таблицы Значений все выгребаю и присваиваю , поэтому "итог по колонке" не будет работать . Не буду париться и сделаю пременную лучше и буду присваивать в коде !
Извиняюсь за свои тормоза !!! Бывает к концу дня :((




Список тем форума

Форум Территория 1С

  Рекламное место пустует
Выдавать глобальные идеи — это удовольствие; искать сволочные маленькие ошибки - вот настоящая работа.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует