Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Собственно строки и операции

Ø
Я
   Dusseldorf
22.11.04 - 12:41
Д = СоздатьОбъект("Документ.Операция");
Д.ВыбратьДокументы(Дата1,Дата2);
Пока Д.ПолучитьДокумент()=1 Цикл
  Д.ВыбратьСтроки();
  Сообщить("Вот моя Супер_операция");// виводит, как раз те операции что были созданы пользователем путем: Документ->"Операция"
  Пока Д.ПолучитьСтроку()=1 Цикл
      Сообщить("Вот моя Супер_строка");// не выводит
  КонецЦикла;
КонецЦикла;
Если делать так:
, то будет уж очень медленно .. так, как выборка проходит по всех операциях(по операциях созданых "банковской випиской", "прходной накл." и т.д.)
Пока Опер.ПолучитьОперацию()=1 Цикл
  Опер.ВыбратьПроводки();
  
  Пока Опер.ПолучитьПроводку()=1 Цикл
    Если Опер.Дебет.Счет=СчетПоКоду("6811") Тогда
      Сообщить("Субконто "+Опер.Документ);
    КонецЕсли;
  КонецЦикла;
КонецЦикла;
а я вот хочу работать с документом "операция" как с "банковской випиской", "прходная накл.", как в примере (1)
 
 
   vitfil
1 - 22.11.04 - 12:43
Док=СоздатьОбъект("Документ");
Если Опер.Дебет.Счет=СчетПоКоду("6811") Тогда
Док.НайтиДокумент(Опер.Документ);
КонецЕсли;
   Vitlick
2 - 22.11.04 - 12:46
Попробуй так:
О = Д.Операция;
О.ВыбратьПроводки()
Пока О.ПолучитьПроводку() = 1 цикл
    ........
КонецЦикла;
   Chastiser
3 - 22.11.04 - 12:49
Д.ВыбратьСтроки() - ??? Может быть нада так:
Состояние("Обработка "+Д.ТекущийДокумент());
Опер = Д.Операция;
Опер.ВыбратьПроводки();
Пока Опер.ПолучитьПроводку() > 0 Цикл
   mvk
4 - 22.11.04 - 12:51
Д = СоздатьОбъект("Документ.Операция");
Опер = СоздатьОбъект("Операция");
Д.ВыбратьДокументы(Дата1,Дата2);
Пока Д.ПолучитьДокумент()=1 Цикл
  Опер.НайтиОперацию(Д.ТекущийДокумент());
  Опер.ВыбратьПроводки();
  Пока Опер.ПолучитьПроводку()=1 Цикл
    Если Опер.Дебет.Счет=СчетПоКоду("6811") Тогда
      Сообщить("Субконто "+Опер.Документ);
    КонецЕсли;
  КонецЦикла;
КонецЦикла;
   Dusseldorf
5 - 22.11.04 - 19:38
mvk истинно помог, пасибки!



Список тем форума

Форум Территория 1С

Рекламное место пустует   Рекламное место пустует
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует