Вход | Регистрация

Форумы на Кубань.Ру


О жизни... ::

Метки:

OFF. v8. Какой процент программного кода придется перенести в 8.0

Ø
Я
   shaor
19.11.04 - 07:11
Реклама утверждает, что в 8.0 будет меньше работы для программиста, благодаря построителю отчетов, ПВХ, новым отчетам. Интересует мнение глубокоуважаемого All - насколько меньше? Более конкретно: какой процент
своих настроек сделанных в 7-ке, Вы будете переносить в 8.0?
 
 
   SnarkHunter
1 - 19.11.04 - 07:14
Реклама - двигатель торговли...
 
   Guk
2 - 19.11.04 - 07:21
(0) Пордон, а ПВХ, это куда?...
   shaor
3 - 19.11.04 - 07:23
(2) ПВХ = Планы видов характеристик
   который не честный
4 - 19.11.04 - 07:50
я сконвертировал базу 7.7 в 8.0. Потихоньку переписываю справочники. Пока что заметил такую вещь - несколько строк доступа к элементу справочника в 7.7 превращаются в 1-2 в 8.0
   shaor
5 - 19.11.04 - 07:54
(4) Не затруднит ли Вас привести пример?
   vi0
6 - 19.11.04 - 08:07
(0) в этой ветке поищи посты со словом "скорость"
http://www.kuban.ru/forum_new/forum9/files/207425.html</a>
   который не честный
7 - 19.11.04 - 08:08
Пример, при открытии элемента справочника Номенклатура заполняется таблица значений на форме. Только в 8.0 там ставится не ТЗ а таблица типа СправочникСписок.Цены
--------------------------------------------------
Это в 8.0 хотя есть подозрение что делается это по другому...
  СписокЦен.Отбор.Владелец.Значение=Ссылка;
  СписокЦен.Отбор.Владелец.Использование=Истина;
---------------------------------------------------
Это в 7.7
//
// ЦеныТовара = СоздатьОбъект("Справочник.Цены");
// ЦеныТовара.ИспользоватьДату(РабочаяДата());
// ЦеныТовара.ИспользоватьВладельца(ТекущийЭлемент());
//
// // очищаем все строки
// СписокЦен.УдалитьСтроки();
//
// // заполняем таблицу
// ЦеныТовара.ВыбратьЭлементы();
// Пока ЦеныТовара.ПолучитьЭлемент() = 1 Цикл
// Если ЦеныТовара.ПометкаУдаления() = 0 Тогда
// СписокЦен.НоваяСтрока();
// СписокЦен.Ссылка= ЦеныТовара.ТекущийЭлемент();
// СписокЦен.Валюта = ЦеныТовара.Валюта;
// СписокЦен.Единица = ЦеныТовара.Единица;
// СписокЦен.КатегорияЦены = ЦеныТовара.КатегорияЦены;
// СписокЦен.Наценка = ЦеныТовара.Наценка;
// СписокЦен.Цена = ЦеныТовара.Цена;
// КонецЕсли;
// КонецЦикла;
   который не честный
8 - 19.11.04 - 08:12
правда в данном случае добавится еще работа с РегистрСведений...
   который не честный
9 - 19.11.04 - 08:22
или такое
Удалить_=ЭлементыФормы.КатегорииТоваров.ТекущаяСтрока;
Если Удалить_<>НеОпределено Тогда
  Удалить_.ПолучитьОбъект().Удалить();
КонецЕсли;
Если без проверки то
ЭлементыФормы.КатегорииТоваров.ТекущаяСтрока.ПолучитьОбъект().Удалить();
   shaor
10 - 19.11.04 - 09:29
(7) Согласен, есть отдельные примеры уменьшения кода. Точно так же как и увеличения. Видимо, рассмотрение частных случаев не позволит оценить ситуацию в целом. Может быть посчитать количество отчетов доделанных в 7-ке и не требующих переноса в 8.0, поскольку они там уже есть в типовой конфигурации?
 
  Рекламное место пустует
   shaor
11 - 19.11.04 - 09:33
(6) В той ветке нет конкретных цифр. Есть мнение, что уменьшится (для небольших доработок типовых) , есть, что увеличится (для больших разработок).
   vi0
12 - 19.11.04 - 11:43
(11) и я о том же, конкретных цифр тебе никто не скажет, каждый своё гнет
   shaor
13 - 19.11.04 - 12:53
(12) Я хочу просто собрать статистику по конкретным настройкам. Какой процент объектов конфигурации (или строк кода) All переносит (или будет переносить) из 7 в 8. Процент от имеющихся дополнительных настроек в 7.7.
   shaor
14 - 20.11.04 - 09:35
up
   Guk
15 - 20.11.04 - 09:48
Дети. Что тут ещё сказать...
   BOPOH
16 - 20.11.04 - 09:52
По моим расчетам - 67% старого кода можно использовать - это то где бизнес логика описана, Остальное пришлось менять - доступ к объектам и структура БД в приложении к предметной области.
Тут пишут про скорость!
Ну скорость постепенно растет! Первые формы - писал вообще не вылезая из кники - теперь больше по памяти помню :)
Конструкторы - вещь хорошая, особенно конструктор запроса.
Но самое лучшее- сделать свой инструментарий и наработки.
Их пока с 77 не все перенес - все некогда но и они дадут свой плюс!
Остально - все условности - комуто может на столько интерфейс новый не понравяться, что это и будет главный тормаз!
А считать статистику - толку нет!
Ну укусили меня на речке 145 комаров летом - и че? :)
   shaor
17 - 22.11.04 - 11:24
(16) Большое спасибо за ответ. Хотя, наверное, меня больше интересует,
какой процент кода переносить не надо, из-за вновь появившихся возможностей.
А статистка нужна, чтобы не переходить на флейм.
   shaor
18 - 22.11.04 - 11:28
(15) Это неправильный ответ.



Список тем форума

Форум Территория 1С

Рекламное место пустует  
Здесь во втором сообщении вам дадут решение, а в двадцатом дадут правильное решение. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует