Вход | Регистрация


1С:Предприятие ::

Метки:Запросы и построители

Проблема с выгрузкой запроса

Я
   max76
 
26.11.04 - 16:08
Есть запрос.
|Период с текДата По ДатаДок;
|МПЗ = Регистр.АнализУчета.МПЗ;
|ТекДок = Регистр.АнализУчета.ДокументПрихода;         
|СрокИспользования = Регистр.АнализУчета.Срокиспользования;
|Количество = Регистр.АнализУчета.Количество;
|Сумма = Регистр.АнализУчета.Сумма;
|
|Функция КонОстКоличество = КонОст(Количество);
|Функция КонОстСумма = КонОст(Сумма);
|
|Группировка МПЗ;
|Группировка ТекДок;
|Группировка СрокИспользования;                            
|

Выгружаю результаты:
Запрос.Выгрузить(ТЗ);

В запросе 3 значения, а ТЗ выгружается только 1, а значения группировок (2) и (3) пустые

Не подскажите, в чем проблема?
 
 
   miki
 
1 - 26.11.04 - 16:11
Поиграй со вторым параметром.
   miki
 
2 - 26.11.04 - 16:13
(1)Или с третьим.
Откуда знаешь что в запросе три значения?
   max76
 
3 - 26.11.04 - 16:18
После запроса написал

Пока Запрос.Группировка(1) = 1 Цикл
 Пока Запрос.Группировка(2) = 1 Цикл
    Пока Запрос.Группировка(3) = 1 Цикл
          Сообщить("+");
    КонецЦикла;
  КонецЦикла;
КонецЦикла;

В отладчике видно, что обходит все значения, их всего 3. Одно МПЗ с разными
текДок и СрокИспользования
   miki
 
4 - 26.11.04 - 16:21
Так это и есть одна строки выборки.
   AlexMan
 
5 - 26.11.04 - 16:22
(4) да нет просто выгружает он криво...
(0) почитай описалово к методу Выгрузить();
   max76
 
6 - 26.11.04 - 16:25
Одно МПЗ оприходовалось в регистр тремя разными документами. В регистре три записи с тремя разными ДокументПоставки
   miki
 
7 - 26.11.04 - 16:25
(5)А сколько записей в выборке должный дать три (каждой по одной) значения группировок из всего имеющихся трех группировок?
   max76
 
8 - 26.11.04 - 16:28
(5) Описалово прочитал, я перепробовал все возможные варианты с параметрами, лучше не получается
   miki
 
9 - 26.11.04 - 16:30
(8) А что кажут функции?
   max76
 
10 - 26.11.04 - 16:32
(7) что то я не понял. Записей в регистре 3, а почему в ТЗ выгружается только 1
 
 
   miki
 
11 - 26.11.04 - 16:36
(10) я (6) не успел прочесть. Что показывают функции?
Чему равны значения группировок на в каждом цикле?
Откуда достаешь ТЗ?
   max76
 
12 - 26.11.04 - 16:37
(9) Документами ДокПоставки оприходуется количество и сумма МПЗ с СрокИспользования. Запрос проверяет конечный остаток по этим реквизитам
   miki
 
13 - 26.11.04 - 16:37
(11)Уверен, что в выборку попадают эти три разных документа?
   miki
 
14 - 26.11.04 - 16:39
(12) Я имел ввиду ЗНАЧЕНИЯ функций, возращаемых запросом.
Уверен что остатки есть по ВСЕМ ТРЕМ документам?
   miki
 
15 - 26.11.04 - 16:39
Короче, читай (4).
   max76
 
16 - 26.11.04 - 16:42
(12) цикл 1 - только МПЗ с общим количеством и суммой по всем документамПоставки, цикл  2 - МПЗ и ДокПоставки с итогом по каждому документу, цикл 3 - тоже самое + Срок использования, т.к. в каждом документе стоит только один СрокИспользования
   miki
 
17 - 26.11.04 - 16:43
(16) И что, ДокПоставки все разные?
   max76
 
18 - 26.11.04 - 16:44
(14) Уверен, в отладчике проверял, списание вообще еще небыло, только три оприходования
   miki
 
19 - 26.11.04 - 16:46
Откуда берешь ТЗ и что в неё попадает через Выгрузить()?
   max76
 
20 - 26.11.04 - 16:49
ТЗ через СоздатьОбъект , а попадает туда только первая группировка, т.е. МПЗ есть, ДокПоставки и СрокИспользования - пустые, и функции общие сумма и количество по МПЗ
   miki
 
21 - 26.11.04 - 16:53
Ну не знаю. Запрос целиком в (0) нарисрван? Долби второй параметр.
   max76
 
22 - 26.11.04 - 16:55
(17) ДокПоставки все разные
   max76
 
23 - 26.11.04 - 16:57
(21) Да, запрос весь.
   miki
 
24 - 26.11.04 - 18:41
Дай кусок кода побольше. От Запрос=СоздатьОбъект("Запрос") /или ТЗ=СоздатьОбъект("Таблица"), что там у тебя раньше/ до Запрос.Выгрузить(ТЗ);
   miki
 
25 - 26.11.04 - 18:42
Оприходуй еще пару МПЗ и грузани в ТЗ. Посмотри.
Что такое текДата и ДатаДок?



Список тем форума
Рекламное место пустует  
Основная теорема систематики: Новые системы плодят новые проблемы.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует