Вход | Регистрация


1С:Предприятие ::

Метки:

Вопрос по справочникам и таблицам значений

Я
   Demokratizator
 
18.02.04 - 21:11
Есть такая тема:
Есть внешний отчет с таблицей значений на форме.
Одна колонка имеет тип Справочнок.Товар
причем Справочник имеет несколько уровней вложенности(несколько папок с товаром в каждой)
реализована процедура "кликанья" на эту таблицу.
Как сделать, что-бы при каждом кликанье на наблицу открывался Справочник.Товар в нужной папке(например в папке товар1)?
Заранее спасибо!
 
  Рекламное место пустует
   dimoff
1 - 18.02.04 - 21:20
Попробуй
Спр = Создатьобъект("Справочник.Товар");
Спр.ИспользоватьРодителя(Товар1);
Спр.Выбрать("Выберите элемент","ФормаСписка");
   GrayT
 
2 - 18.02.04 - 21:29
спр = СоздатьОбъект("Справочник.Материалы");
    конт="";
    текГруппа = ПолучитьПустоеЗначение("Справочник.Материалы");
    Если спр.НайтиЭлемент(НужнаяГруппа)=1 Тогда
        текГруппа = спр.ТекущийЭлемент();
    КонецЕсли;
    ОткрытьФорму("Справочник.Материалы.ФормаСписка",Конт);
    Конт.ИспользоватьРодителя(текГруппа);
   dimoff
3 - 18.02.04 - 21:43
2 Скажи пожалуйста зачем нужно писать
текГруппа = ПолучитьПустоеЗначение("Справочник.Материалы"); 
   Если спр.НайтиЭлемент(НужнаяГруппа)=1 Тогда 
       текГруппа = спр.ТекущийЭлемент(); 
   КонецЕсли; 

а не сразу
Конт.ИспользоватьРодителя(НужнаяГруппа);

или если не напишешь кучу бесполезного кода звездочку не дадут?
   dimoff
4 - 18.02.04 - 21:49
Уж не говоря о том, что откроется форма для редактирования и выбрать пользователь там ничего не сможет.
   GrayT
 
5 - 18.02.04 - 21:59
:(( Не буду больше спешить. Это был большой кусок из которго я лишнее вырезал, да на поговорку нарвался "поспешишь людей...". А (0) и не говорилось что для выбора открыть надо :)
   dimoff
6 - 18.02.04 - 22:00
5 В принципе да :)
   Demokratizator
 
7 - 18.02.04 - 22:15
мне  ошибка лезит:
что неизвестна переменная НужнаяГруппа или,как писали выше, Товар1?
вот мой код может кто поправит:
Процедура ПриВыбореЯчейки()
    Перем НомКол;
    Спр = СоздатьОбъект(\"Справочник.Товар\");
    Таблица.ТекущаяКолонка(3, НомКол);
    Если (Таблица.ТекущаяСтрока() = 1)  И  (НомКол = 3)  Тогда
        Спр.ИспользоватьРодителя(Товар1);
        Если Спр.Выбрать(\"Выберите Товар\", \"ФормаСписка\") > 0 Тогда
        Таблица.Товар = Спр.ТекущийЭлемент();
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

а не надо при выборе проверять группа это или нет?
Спасибо?
   dimoff
8 - 18.02.04 - 22:22
Кто определяет в какой папке должен справочник открываться?
   GrayT
 
9 - 18.02.04 - 22:23
Так у тебя в первой строке, третьей колонке уже стоит нужная группа?
   Demokratizator
 
10 - 18.02.04 - 22:27
в данном случае справочник токрывается в группе Товар1.
GrayT: тута будет заноситься значение из справочника.
 
  Рекламное место пустует
   GrayT
 
11 - 18.02.04 - 22:44
Тогда см (8). Откуда у тебя взялся Товар1. Кто определил что это за папка
   Demokratizator
 
12 - 18.02.04 - 22:48
я железно забил, а что так нальзя?
   IAm
 
13 - 18.02.04 - 22:49
12 куда?
   Demokratizator
 
14 - 18.02.04 - 22:51
что?
   IAm
 
15 - 18.02.04 - 22:52
14 Да так, не обращай внимания, я о своем.
   GrayT
 
16 - 18.02.04 - 22:54
Куда забил? И как.
В модуле обоработке написал Товар1=..... как написал?
И в самом вверху написал Перем Товар1;  ?
   Demokratizator
 
17 - 18.02.04 - 22:55
ну ладно, а тогда как будет выглядеть выбор товара из справочника, если не требуется что-бы сразу открывалась группа Товар1.
ели делать просто Спр.Выбрать(,);
Таблица.Товар = Спр.ТекущийЭлемент();
Просто открываеться справочнок, а при выборе ничего в ячейку не заносится???????????
   IAm
 
18 - 18.02.04 - 22:57
17 Развод или ты действительно не в состоянии четко сформулировать вопрос и понимать ответы? :)
   GrayT
 
19 - 18.02.04 - 23:00
А у колонки Товар Тип "Справочник.Товар".
Иль я уже на кролика похож?
   Demokratizator
 
20 - 18.02.04 - 23:01
да
   IAm
 
21 - 18.02.04 - 23:03
По всем вопросам да.
   Demokratizator
 
22 - 18.02.04 - 23:04
по 18 НЕТ!
   GrayT
 
23 - 18.02.04 - 23:05
Диверсанты :)
   IAm
 
24 - 18.02.04 - 23:06
22 НЕТ на левую часть вопроса или на правую?
   Demokratizator
 
25 - 18.02.04 - 23:07
что там исправить надо?
   IAm
 
26 - 18.02.04 - 23:09
25 В моем вопросе? Да что хочешь. Некоторые мои вопросы полностью стирают. Тут это нормально.
   Demokratizator
 
27 - 18.02.04 - 23:11
хочу чтобы при нажатии на таблицу значений открывался справочник и юзер мог выбрать товар при условии что справочник многоуровневый!
   skunk
 
28 - 19.02.04 - 05:21
а ОткрытьПодбор() и ПолучитьЗначениеИзПодбора() тут не канает...
   345
29 - 19.02.04 - 06:17
Ндя.... но коммент ....
   skunk
 
30 - 19.02.04 - 06:36
а если про комментировать...
   345
31 - 19.02.04 - 06:58
..........................................
..........................................
..........................................
..........................................
..........................................
..........................................
..........................................

не пропущено цензурой ....
   skunk
 
32 - 19.02.04 - 07:03
таможня дает добро

пока дургих модеров нет, цензура я... надо же когда то учиться
   SnarkHunter
 
33 - 19.02.04 - 07:05
"Королевство - это я..." (с)Людовик XIV
 
  Рекламное место пустует
   skunk
 
34 - 19.02.04 - 07:07
(33)Государство... но в приципе не важно

так почему подбор нельзя здесь использовать
   skunk
 
35 - 19.02.04 - 07:09
опс Алла появилась... ну думаю с ней договоримся ;-)
   skunk
 
36 - 19.02.04 - 07:50
просьба ко всем модерам, если 345 напишет ченить не цензурное объясня почему нельзя здесь юзать подбор... короче не фиха не делать... я полетел иногда на хлебушек надо работать
   ally
 
37 - 19.02.04 - 07:52
(35) о чем договоримся?
   ally
 
39 - 19.02.04 - 08:07
:-)
   skunk
 
40 - 19.02.04 - 09:56
самый простой ответ, канает, и людям становиться все ясно ;-)
   skunk
 
41 - 19.02.04 - 12:12
up
   IAm
 
42 - 19.02.04 - 12:12
41 Зачем ветку поднял? Это ты вопрос задавал?
   skunk
 
43 - 19.02.04 - 12:13
смотри внимательно
   IAm
 
44 - 19.02.04 - 12:18
Куда?
   skunk
 
45 - 19.02.04 - 12:19
   IAm
 
46 - 19.02.04 - 12:21
45 Посмотрел что ты цензура, и что? Ветку-то зачем поднял? Я ж не со зла, может помогу чем.
   skunk
 
47 - 19.02.04 - 12:24
опс промазал
Вопрос по справочникам и таблицам значений

интерсно, почему подбор здесь не подойдет
   skunk
 
48 - 19.02.04 - 12:26
тут уже поработали

народ просил же
   IAm
 
49 - 19.02.04 - 12:26
47 Не понял, в 28 утвердительное предложение и вопросительное. Если утвердительное то позволю себе осведомиться почему???
 
 
   skunk
 
50 - 19.02.04 - 12:28
я спрашиваю: подбор почему здесь не подойдет?
   GrayT
 
51 - 19.02.04 - 12:29
Так вроде ни кто и не говорил, что он не пройдет
   IAm
 
52 - 19.02.04 - 12:30
50 Подойдет. Только зачем.
   skunk
 
53 - 19.02.04 - 12:36
по моему так удобнее...

через обработку можно сразу кучу натолкать в ТЗ а не по одному клыкать каждый раз... или я чего не так понял
   bs
 
54 - 19.02.04 - 15:41
52. и проще... и откроется в нужной группе - конечно если вежливо попросить (сим-сим, откройся)
   IAm
 
55 - 19.02.04 - 16:41
53, 54
Читайте сабж и не сочиняйте.
   IAm
 
56 - 19.02.04 - 16:41
впрочем сочиняйте если хотите.
   bs
 
57 - 20.02.04 - 11:51
56
- 17 пишет, что ему нужен именно подбор



Список тем форума
  Рекламное место пустует
Ошибка? Это не ошибка, это системная функция.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует