Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Как вытащить данные из Регистра (Ресурсы, Реквизиты, Измерения...)

Ø
Я
   fantomask
20.11.04 - 19:33
Приветствую всех...
Как вытащить имена Ресурсов, Реквизитов, измерений из Регистров???
Конечно для профи эта не проблема но я работаю над 1Ской всего месяц...
Заранее Спасибо...
 
 
   IAm
1 - 20.11.04 - 19:41
      Для А = 1 По Метаданные.Регистр(<ИмяРегистра>).Реквизит() Цикл
    ИдентификаторРеквизита =  Метаданные.Регистр(<ИмяРегистра>).Реквизит(А).Идентификатор;
  КонецЦикла;
  Для А = 1 По Метаданные.Регистр(<ИмяРегистра>).Измерение() Цикл
    ИдентификаторИзмерения =  Метаданные.Регистр(<ИмяРегистра>).Измерение(А).Идентификатор;
  КонецЦикла;
  Для А = 1 По Метаданные.Регистр(<ИмяРегистра>).Ресурс() Цикл
    ИдентификаторРесурса =  Метаданные.Регистр(<ИмяРегистра>).Ресурс(А).Идентификатор;
  КонецЦикла;



Список тем форума

Форум Территория 1С

Рекламное место пустует  
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует