Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

V8: Как перебрать строки поля табличного документа?

Ø
Я
   gomunkul2
20.11.04 - 15:18
Я не догадался ...
 
 
   gomunkul2
1 - 20.11.04 - 15:24
... конечно же строки табличного поля
   Lys
2 - 20.11.04 - 15:33
Откуда? Из модуля формы, модуля документа или откуда-то еще?
   Lys
3 - 20.11.04 - 15:38
Если из модуля формы или модуля документа - тогда:
Для Каждого ТекСтрокаТабличногоПоля Из НазваниеТабличногоПоля Цикл
    //Делаем нужные действия с "ТекСтрокаТабличногоПоля"
    ...
КонецЦикла;
   Zamestas
4 - 20.11.04 - 15:41
(1) Если из модуля формы, то:
Для каждого СтрокаТП Из ТабличноеПоле Цикл
   СтрокаТП.Ревизит1 = 1;
   СтрокаТП.Ревизит2 = "1";
КонецЦикла;
   gomunkul2
5 - 20.11.04 - 15:46
Модуль формы документа, но необходимо перебрать не табличную часть документа, а табличное поле, где часть данных - из табличной части, а часть - других настроек. ОНА ругается "итератор не определен", по индексу доступа тоже нет. При этом добавить реквизит в табличную часть документа нельзя, так как при каждом закрытии будет предлагать сохранение.
   Lys
6 - 20.11.04 - 15:51
(5) А так не подойдет?
     
Для Каждого ТекСтрокаТабличногоПоля Из ЭлементыФормы.НазваниеТабличногоПоля Цикл
    ...
КонецЦикла;
   gomunkul2
7 - 20.11.04 - 15:58
ВОТ ИМЕННО НА ЭТО:
Для Каждого Стр из ЭлементыФормы.Ресурсы Цикл
  
КонецЦикла;
ОНА И РУГАЕТСЯ:
{Документ.Калькуляция1.Форма.ФормаДокумента(45)}: Итератор для значения не определен
  Для Каждого Стр из ЭлементыФормы.Ресурсы Цикл
ВСЕ ТАКИ ДОЛЖЕН ЖЕ БЫТЬ КАКОЙ-ТО СПОСОБ?
   Lys
8 - 20.11.04 - 16:08
(7) Поставь на строку "Для Каждого Стр из ..." точку останова и запусти отладчик. Посмотри по Shift+F9 тип значения выражения "ЭлементыФормы.Ресурсы".



Список тем форума

Форум Территория 1С

Рекламное место пустует  
Кaк может человек ожидaть, что его мольбaм о снисхождении ответит Тот, кто превыше, когдa сaм он откaзывaет в милосердии тем, кто ниже его? Петр Трубецкой
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует