Вход | Регистрация

1С:Предприятие ::

Метки:

Что делать дальше, после ВыполнитьЗапрос?

Я
   SemT
 
25.11.04 - 17:17
Наиглупейший вопрос в сабже. Что использовать после чтобы данные достать?
 
 
   Нюша
 
1 - 25.11.04 - 17:21
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
                    Возврат;
                КонецЕсли; 
                Пока Запрос.Группировка(1) = 1 Цикл 
                    Пока Запрос.Группировка(2) = 1 Цикл 
----------операторы-----
КонецЦикла;
КонецЦикла;
   SemT
 
2 - 25.11.04 - 17:23
А что это и к бухгалтерским итогам относится?:
   Guk
 
3 - 25.11.04 - 17:23
(2) Так запрос то покажи...
   SemT
 
4 - 25.11.04 - 17:25
ТестЗапрос = БухИтоги.ВыполнитьЗапрос(НачДатаОпл,КонДатаОпл,ВыбрСчет,,ВыбрВалюты,1,,);

По окончании если запрос прошел
ТестЗапрос = 1 (это в отладчике)

А как сами данные получить?
   База Данных
5 - 25.11.04 - 17:27
Ctrl+F1+"обращ"
   Нюша
 
6 - 25.11.04 - 17:29
БухИт.ВыбратьСчета();    
 Пока БухИт.ПолучитьСчет() = 1 Цикл
конеццикла;
если используются субконто, то можно еще и субконто повыбирать
   SemT
 
7 - 25.11.04 - 17:29
(5)Вот это ближе к телу. Пошел ковырять.


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует