Вход | Регистрация


1С:Предприятие ::

Метки:Приемы программирования

Табличная часть Справочника

Я
   Nikrub
 
25.11.04 - 15:50
как можно изменить значение табл. части справочника?
 
 
   Волшебник
 
1 - 25.11.04 - 15:51
подробнее
   Лохматые Уши
2 - 25.11.04 - 15:54
Кстати, действительно, что-то пытаешься добавить в табл. часть справочника, и хрен! При нажатии Enter текстовое поле фиксируется и очищается. Странно.., сам вроде справочник я создал ;)
   Nikrub
 
3 - 25.11.04 - 15:55
мне надо циклом забить значение в табличную часть справочника.
как объект получить?
   Лохматые Уши
4 - 25.11.04 - 15:57
А у меня там текстовые поля, и не сохраняются. Кто знает?
   Волшебник
 
5 - 25.11.04 - 15:57
А дерево значений позволяет хранить иерархию!

(вроде в тему, да как-то не очень)
   Лохматые Уши
6 - 25.11.04 - 15:59
Мне кажется, совсем не в тему, но спасибо :)
   Волшебник
 
7 - 25.11.04 - 16:00
(6) Ты не прав! Ведь справочники бывают иерархическими, это тоже нужно учитывать!
   Лохматые Уши
8 - 25.11.04 - 16:01
Да, но речь то о табличной части справочника, причём тут иерархия.., хотя я сам пока не врубился :)
   Волшебник
 
9 - 25.11.04 - 16:03
(8) Один начал про табличную часть, второй - про текстовые поля, а я про ирерахию. Три ветки в одной - бальзам и кондиционер в одном флаконе...
   Лохматые Уши
10 - 25.11.04 - 16:05
Ты сам всё и запутал, мы о текстовых значениях, которые почему-то не сохраняются в табл. части справочника. То ли какие-то реквизиты ещё надо добавлять, то ли ...пока непонятно :)
 
  Рекламное место пустует
   Волшебник
 
11 - 25.11.04 - 16:09
(10) Это ты о текстовых значениях, а он о том, чтобы "циклом забить значение в табличную часть". А я об иерархии. Каждый о своем. Все по-честному, как в Ростокино-Лада.
   Лохматые Уши
12 - 25.11.04 - 16:12
Хм..
Пойду сегодня за новой книжкой, форум путает всё, запутывает ;)
   Nikrub
 
13 - 25.11.04 - 16:15
так, восстановыим ясность.
Я планирую циклом забить столбик табл. части справочника. как мне добраться программно до объекта "табл. части", по аналогии с "Таблицей значений"???
   Волшебник
 
14 - 25.11.04 - 16:16
(12) Форум - это инструмент типа молотка. При правильном использовании им можно вбить первый гвоздь в решение проблемы, при неправильном - сломать голову.
   Волшебник
 
15 - 25.11.04 - 16:17
Об = Ссылка.ПолучитьОбъект();

далее:

Нов = Об.ИмяТабЧасти.Добавить();
Нов.ИмяКолонки = Знач;

или:

Для каждого стр Из Об.ИмяТабЧасти Цикл
   Стр.ИмяКолонки = Знач;
   Nikrub
 
16 - 25.11.04 - 16:19
(15)
ок, пробую...
Заранее спасибо!
   Волшебник
 
17 - 25.11.04 - 16:21
(16) Не забудь 
Об.Записать();
   Nikrub
 
18 - 26.11.04 - 12:47
(17)
Работет, но только после того как закроешь и откроешь снова.
   Nikrub
 
19 - 26.11.04 - 13:39
Можно как то обновить заполненную таблицу?
   Волшебник
 
20 - 26.11.04 - 13:42
Форма.Обновить();
   Nikrub
 
21 - 26.11.04 - 13:53
(20)
неа, не помогло.
   Волшебник
 
22 - 26.11.04 - 13:54
Значит не так написал или не там.
   Nikrub
 
23 - 26.11.04 - 14:07
(20)
Процедура ВводЗнач(Элемент, Текст, Значение, СтандартнаяОбработка)
   Об = Ссылка.ПолучитьОбъект();
   Для Каждого Стр из Об.Категории цикл
      Стр.Наценка = Элемент.Значение;
   КонецЦикла;
   Об.Записать();
   ЭтаФорма.Обновить();
КонецПроцедуры
   SKrin
 
24 - 26.11.04 - 14:09
не "ЭтаФорма.Обновить()" а "Форма.Обновить()" попробуй
   Волшебник
 
25 - 26.11.04 - 14:10
(24) не получится.
   Nikrub
 
26 - 26.11.04 - 14:12
(24)
/25/ прав!
   Rovan
 
27 - 26.11.04 - 14:25
(23) ИМХО - надо писать не в сам объект, а в элемент формы - например
Для Каждого Стр из ЭлементыФормы.Категории цикл
  Стр.Наценка = Элемент.Значение; 
КонецЦикла;
   Shaytan
 
28 - 26.11.04 - 14:55
(27) Так не соработает. Нельзя передрать строки табличного поля.
   Shaytan
 
29 - 26.11.04 - 14:56
Если это в форме элемента то
  Для Каждого Стр из Категории цикл 
     Стр.Наценка = Элемент.Значение; 
  КонецЦикла; 
  Записать(); 
 //ЭтаФорма.Обновить(); 

КонецПроцедуры
   Shaytan
 
30 - 26.11.04 - 14:56
Точнее так
Если это в форме элемента то
 Для Каждого Стр из Категории цикл 
    Стр.Наценка = Элемент.Значение; 
 КонецЦикла; 
//Записать(); 

//ЭтаФорма.Обновить(); 

КонецПроцедуры
   Nikrub
 
31 - 26.11.04 - 15:19
(30)
нет, теперь совсем не работает, белее менее рабочий вариант остаеться (23)
   Shaytan
 
32 - 26.11.04 - 15:27
Опиши задачу подробнее. Откуда вызывется процедура, что и чем хочешь заполнить?
"Категории" это Табличная часть справочника?
   Shaytan
 
33 - 26.11.04 - 15:28
Попробуй с "ЭтаФорма.Обновить();"
 
  Рекламное место пустует
   Nikrub
 
34 - 26.11.04 - 15:38
(32)
Да, это табл. часть справочника.
Я планирую в поле ввода забить число и по Enter заполнить колонку.
вызов "Окончание ввода"
   Shaytan
 
35 - 26.11.04 - 16:17
Тогда (30) должна работать. Что происходит? Ошибка или не заполняет?
   Nikrub
 
36 - 26.11.04 - 17:05
(35)
ощибок нет, но не заполняется. ранее если после повторного открытия данные менялись, то в этом варианте ничего не происходит
   Shaytan
 
37 - 26.11.04 - 17:22
А выходишь из формы по кнопке "закрыть" или или "Ок"?
   Nikrub
 
38 - 26.11.04 - 17:38
(37)
закрыть, потом снова открываю ...
   Shaytan
 
39 - 26.11.04 - 17:52
Закрывать  / Открывать это не дело. Всё прекрасно делается в текущей форме. ЭтаФорма.Обновить(); пробовал? Чтобы записать изменения надо выходить по кнопке "ОК".
   Nikrub
 
40 - 26.11.04 - 17:58
Вариант(30) я уже пробывал.
у меня нет изменений, даже после ОК
   Shaytan
 
41 - 26.11.04 - 18:05
К какому событию привязана процедура ВводЗнач(Элемент, Текст, Значение, СтандартнаяОбработка)?
   Nikrub
 
42 - 26.11.04 - 18:08
(41) событие "Окончание ввода"
   Shaytan
 
43 - 26.11.04 - 18:12
1) Лучше прикрути к "ПриИзменении"
2) Не знаю в чём проблема, но (30) - рабочий код.
   Nikrub
 
44 - 26.11.04 - 18:29
окей, работает, огромное спасибо
   Shaytan
 
45 - 26.11.04 - 18:34
(44) Если это мне, то не за что.



Список тем форума
Рекламное место пустует  
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует