Вход | Регистрация

1С:Предприятие ::

Метки:

Список_СписковЗначений...Как бы реализовать?

Я
   user63
25.11.04 - 12:41
Вот, вопрос у меня.
 Надо создать список списков значений. Причем, размер списка заранее неизвестен. Можно ли воспользоваться тем что приведено ниже:
Функция ДобавитьЭлСп()
   Перем сп;
   Сп = СоздатьОбъект("СписокЗначений");
   Возврат Сп;
КонецФункции

//  КолЗнач - некот. число...

СпСписков = СоздатьОбъект("СписокЗначений");
Для Сч = 1 по КолЗнач Цикл
   СпСписков.ДобавитьЗначение(ДобавитьЭлСп(),"НомЗнач"+Сч);
КонецЦикла;

Собственно, вот и все. Будет работать?
Спасибо.
 
 
   Волшебник
 
1 - 25.11.04 - 12:42
А ты попробуй.
   laeg
 
2 - 25.11.04 - 12:58
(1) точно - точно .... :)
   user63
3 - 25.11.04 - 13:05
Работает!!!

Функция ДобавитьЭл()
    Возврат СоздатьОбъект("СписокЗначений") ;
КонецФункции    


//*******************************************

Процедура Сформировать()
    
    Сп = СоздатьОбъект("СписокЗначений") ;
    Сп.ДобавитьЗначение(ДобавитьЭл(),"1"); 
    Сп.ДобавитьЗначение(ДобавитьЭл(),"2");
    Сп.ПолучитьЗначение(1).ДобавитьЗначение("Первый элемент") ;
    Сп.ПолучитьЗначение(2).ДобавитьЗначение("Второй элемент") ;
    Сообщить(Сп.ПолучитьЗначение(1).ПолучитьЗначение(1)); 
    Сообщить(Сп.ПолучитьЗначение(2).ПолучитьЗначение(1));
    Сп.ПолучитьЗначение(1).ДобавитьЗначение("Второй первого..") ;
    Сп.ПолучитьЗначение(2).ДобавитьЗначение("Второй второго..") ;
    Сообщить(Сп.ПолучитьЗначение(1).ПолучитьЗначение(2)); 
    Сообщить(Сп.ПолучитьЗначение(2).ПолучитьЗначение(2));
КонецПроцедуры
   Волшебник
 
4 - 25.11.04 - 13:07
(3) Вот и славно. Получился не вопрос, а будень.
   Rovan
 
5 - 25.11.04 - 13:19
(0) Короче
Для Сч = 1 по КолЗнач Цикл 
  СпСписков.ДобавитьЗначение( СоздатьОбъект("СписокЗначений"), "НомЗнач"+Сч); 
КонецЦикла;
Зачем функция отдельная нужна ?
   user63
6 - 25.11.04 - 13:24
(5)И то верно! Спасибо.


Список тем форума
Рекламное место пустует   Рекламное место пустует
Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует