Вход | Регистрация

1С:Предприятие ::

Метки:

Как заменить запись в ДБФ.

Я
   Генс
25.11.04 - 11:38
Как заменить запись в ДБФ.
У меня задача такая. Если были какие-то изменения информации в таблицеЗначении, тогда приЗакрытии автоматом информация меняется. В чем проблема подскажите.

Табл - таблицеЗначении.
Процедура Замена()
    ДБФ = СоздатьОбъект("XBase");
    ДБФ.ОТкрытьФайл("arhiv.dbf");
    ДБФ.Первая();
    Пока ДБФ.Вконце()=0 Цикл 
        Табл.ВыбратьСтроки();
        Пока Табл.ПолучитьСтроку()=1 цикл
            Если (Табл.Пометка=1)и(Сокрлп(ДБФ.ARTIKELSNU)=Сокрлп(Табл.Артикул) ) тогда
                ДБФ.PICTOG=Табл.Пометка;
                Сообщить(""+ДБФ.НомерЗаписи());    
            КонецЕсли;
            ДБФ.Следующая();
            Дбф.Записать();
        КонецЦикла; 
    КонецЦикла; 
    ДБФ.ЗакрытьФайл();
КонецПроцедуры
 
 
   NS
 
1 - 25.11.04 - 11:40
Процедура Замена() 
   ДБФ = СоздатьОбъект("XBase"); 
   ДБФ.ОТкрытьФайл("arhiv.dbf"); 
   ДБФ.Первая(); 
   Пока ДБФ.Вконце()=0 Цикл 
       Табл.ВыбратьСтроки(); 
       Пока Табл.ПолучитьСтроку()=1 цикл 
           Если (Табл.Пометка=1)и(Сокрлп(ДБФ.ARTIKELSNU)=Сокрлп(Табл.Артикул) ) тогда 
               ДБФ.PICTOG=Табл.Пометка; 
               Дбф.Записать(); 
               Сообщить(""+ДБФ.НомерЗаписи()); 
// прервать;    

           КонецЕсли; 
           ДБФ.Следующая(); 
       КонецЦикла; 
   КонецЦикла; 
   ДБФ.ЗакрытьФайл(); 
КонецПроцедуры
   Генс
2 - 25.11.04 - 11:46
(1)Всё ОК спасибо. Работает как часы.
   miki
 
3 - 25.11.04 - 12:01
Либо юзать АвтоСохранение()


Список тем форума
Рекламное место пустует   Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует