Вход | Регистрация


Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Как можно определить из какой формы списка создали элемент справочника?

Ø
Я
   СпрошуКоеЧто
19.11.04 - 21:44
Сабж.
 
 
   Х125
1 - 19.11.04 - 21:50
Создай какой-нибудь реквизит в справочнике, типа "ФормаР", и в модулях форм заноси значение типа "Форма для выбора", "Основная форма", "Форма для юзеров" и т.д.
   Fеникс
2 - 19.11.04 - 21:53
Оставить возможность ввода новых элементов только в одной форме.
   СпрошуКоеЧто
3 - 19.11.04 - 21:54
Ну а первый раз как увидеть? Когда его создавали. Как узнать что заносить в реквизит?
   Х125
4 - 19.11.04 - 22:07
Как я понимаю у элементов справочника при стандарте нет такой возможности
   СпрошуКоеЧто
5 - 19.11.04 - 22:15
Вот и я о том же. ПРийдется через глоб переменную и молиться чтоб он две формы не открывал и не прыгал между ними.
   Fеникс
6 - 19.11.04 - 22:20
(5) Какой ты религиозный, однако. Иной бы взял да и запретил, а ты молиться собрался...
   СпрошуКоеЧто
7 - 19.11.04 - 22:22
А ты представь глаза юзера когда у него 100-надцать открытых окон и ему говорит мол одна форма списка уже открыта. Хватит с тебя.
   Fеникс
8 - 19.11.04 - 22:28
(7) И чо?
А на кой вообще держать кучу форм для одного и того же действия?
   СпрошуКоеЧто
9 - 19.11.04 - 22:33
Не кучу форм. Но в меню справочников - ФормаСписка. При подборе - ФормаПодбора. При выборе реквизита на форме - ФормаВыбора(только наименования элементов). В документах - ФормаОстатков(отображаются остатки). И из всех может юзверь создать элемент.
   Fеникс
10 - 19.11.04 - 22:34
(9) Вот и я о том же - нафига в формах выбора/подбора создавать элементы?
 
 
   СпрошуКоеЧто
11 - 19.11.04 - 22:41
Всеравно остается 2 формы и вопрос. Как запретить создавать из конкретной формы. Элементы вводятся не в строке - в форме. В глобальной переменной хранить форму не прадлагать - опять же таки может прыгать между формами.
   Fеникс
12 - 19.11.04 - 22:44
(11) Не понял - какие ещё 2 формы?
"Как запретить создавать из конкретной формы" - что, никак не запретить?
   СпрошуКоеЧто
13 - 19.11.04 - 22:47
1. В документах - ФормаОстатков(отображаются остатки)
2. Но в меню справочников - ФормаСписка.
А как запретить из конкретной формы?
   Fеникс
14 - 19.11.04 - 22:58
(13) Ну а в ФормеОстатков запретить новых вводить?
"А как запретить из конкретной формы?" - а как вообще, по-твоему, можно запретить???
   СпрошуКоеЧто
15 - 19.11.04 - 23:03
Пока вспомнил 2 способа:
1. Правами.
2. Проверкой при вводе нового.
Не один не катит.
1. - нельзя опрелелить для конкретной формы.
2. - проверять из какой формы, а это нереально.
   GrayT
16 - 19.11.04 - 23:14
Передавай параметр из той формы, из которой можно
   СпрошуКоеЧто
17 - 19.11.04 - 23:16
Когда передавать? Как поймать то, что создаем элемент эсли создаем в форме а не в строке?
   Fеникс
18 - 19.11.04 - 23:19
(15) А никогда не пробовал в модуле конкретной формы списка написать
Процедура ПриВводеСтроки()
  СтатусВозврата(0);
КонецПроцедуры
?
   СпрошуКоеЧто
19 - 19.11.04 - 23:21
Я ж в 17-м посте сказал что редактируем в форме. Откуда строка?
   Fеникс
20 - 19.11.04 - 23:26
(19) Где, простите?
Насколько мне известно, редактировать элемент можно:
1) в списке
2) в диалоге
3) через процедуру
Так где редактирование-то происходит?
   GrayT
21 - 19.11.04 - 23:27
Процедура ВводНового()
 Если ПустоеЗначение(Форма.Параметр)=0 тогда
    Сообщение("Развод?")
   СпрошуКоеЧто
22 - 19.11.04 - 23:42
(20) В диалоге(форма элемента).
(21)Ну так откуда ж возьмется Форма.Параметр если юзверь Инсерт тыкнул.
   GrayT
23 - 19.11.04 - 23:46
Ну поставь толькоПросмотр
   Fеникс
24 - 19.11.04 - 23:46
(22) Ну и какой смысл дурачить(ся)?
Как будто ты не знаешь, что в ВводНового() для формы элемента аналогично ПриВводеСтроки() для формы списка?
   Fеникс
25 - 19.11.04 - 23:48
+23 да и вообще - грохни все формы - я так чувствую - они всё равно лишние
   СпрошуКоеЧто
26 - 19.11.04 - 23:51
Ну так ввод нового на ворме элемента а приВводе на форме списка элементов - как связать их. Как определить из какой формы открыт диалог? Нет ведь предопределенных что ловят при вводе элемента в диалоге.
   БелСан
27 - 19.11.04 - 23:54
(0)Редактировать - 'Обоими способами',
...
В ненужных списках:
Процедура ПриВводеСтроки()
  СтатусВозврата(0);
КонецПроцедуры
Процедура ПриОткрытии()
  РедактироватьВДиалоге(0,0);
КонецПроцедуры
   СпрошуКоеЧто
28 - 19.11.04 - 23:56
Я понял. Вопрос принципиально не решаем при моих условиях. Если идти методами ограничений то без проблем но не хотелось ограничивать. Всем спасибо. Значит нет смысла копать в эту сторону.




Список тем форума

Форум Территория 1С

Рекламное место пустует   Рекламное место пустует
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует