Вход | Регистрация


Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Операция и строки

Ø
Я
   Dusseldorf
19.11.04 - 20:44
Где делись строки "Операции" ?? или их и небыло?
Д = СоздатьОбъект("Документ.Операция");
Д.ВыбратьДокументы(Дата1,Дата2);
Пока Д.ПолучитьДокумент()=1 Цикл
  Д.ВыбратьСтроки();
  Пока Д.ПолучитьСтроку()=1 Цикл
      Сообщить("Вот моя Супер_строка");
  КонецЦикла;
КонецЦикла;
 
 
   Dusseldorf
1 - 19.11.04 - 20:50
Если делать так:
, то будет уж очень медленно ..
Пока Опер.ПолучитьОперацию()=1 Цикл
  Опер.ВыбратьПроводки();
  
  Пока Опер.ПолучитьПроводку()=1 Цикл
    Если Опер.Дебет.Счет=СчетПоКоду("6811") Тогда
      Сообщить("Субконто "+Опер.Документ);
    КонецЕсли;
  КонецЦикла;
КонецЦикла;
   Х125
2 - 19.11.04 - 20:50
А ты видел такой документ "Операция"?
   Dusseldorf
3 - 19.11.04 - 20:54
Открой конфу:
Документы->Операция,
вот тебе и собственно и операция :)
   Х125
4 - 19.11.04 - 20:59
Да, действительно...
А по типу примера... (детализация по проводкам или операции)
БухИтоги.ВыполнитьЗапрос(Дата1, Дата2, , , , , "Проводки");
БухИтоги.ВыбратьСчета();
Пока БухИтоги.ПолучитьСчет() = 1 цикл
   БухИтоги.ВыбратьПериоды();
   Пока БухИтоги.ПолучитьПериод() = 1 цикл
      Сообщить("Операция " + БухИтоги.Операция.ПредставлениеПроводки());
   КонецЦикла;
КонецЦикла;
   Dusseldorf
5 - 19.11.04 - 20:59
можно и в 1С Документы->Операция,
   Dusseldorf
6 - 19.11.04 - 21:02
а я хочу работать с "документом Операция", так же как и с "документом АвансовыйОтчет", "документом Калькуляция" и т.д.
   Х125
7 - 19.11.04 - 21:06
Я когда-то тоже так хотел, возникли проблемы...
По ходу к операции просто так не обратишься
   Dusseldorf
8 - 19.11.04 - 21:06
По строках хочу прройтись !
Получается что строк нет :%(
   Х125
9 - 19.11.04 - 21:10
Вопрос? А зачем?
   Х125
10 - 19.11.04 - 21:12
Там не только строк нет... Можешь попробовать...
Д = СоздатьОбъект("Документ.Операция");
Д.ВыбратьДокументы(Дата1,Дата2);
Пока Д.ПолучитьДокумент()=1 Цикл
  Сообщить("Ура!!! Операция!");
  Д.ВыбратьСтроки();
  Пока Д.ПолучитьСтроку()=1 Цикл
      Сообщить("Вот моя Супер_строка");
  КонецЦикла;
КонецЦикла;
 
  Рекламное место пустует
   Х125
11 - 19.11.04 - 21:16
Может так...
Опер = СоздатьОбъект("Операция");
Опер.ВыбратьОперации(Дата1, Дата2);
Пока Опер.ПолучитьОперацию() = 1 Цикл
   Сообщить("Ура!!! Операция!!!);
   Опер.ВыбратьПроводки();
   Пока Опер.ПолучитьПроводку() = 1 Цикл
        Сообщить("Вот моя супер строка");
   КонецЦикла;
КонецЦикла;
   Dusseldorf
12 - 19.11.04 - 21:24
Сообщить("Ура!!! Операция!!!); пройдет!!
а сток нет :((
к чему сказано: "Там не только строк нет... Можешь попробовать...
" ??
   Х125
13 - 19.11.04 - 21:26
Где, в 10 или 11?
   Dusseldorf
14 - 19.11.04 - 21:26
просто работать с документами быстрее!! чем персить(сама 1С это делает) все операции по счетах!
   Dusseldorf
15 - 19.11.04 - 21:28
 в 11
   Х125
16 - 19.11.04 - 21:31
Ну ты меня запутал...
Неужели 11 не работает?
А вообще операции есть?
   Dusseldorf
17 - 19.11.04 - 21:36
11 работает., но "Супер строки" не выводятся!
Я так и не понл к чему сказано "Там не только строк нет... Можешь попробовать..." в 10??
   Х125
18 - 19.11.04 - 21:37
Если 11 работает, то должны и супер строки выводиться!
В 10 это было типа прикола, что в данном тексте даже "Ура!!! Операция!" не должно выводиться...
   Х125
19 - 19.11.04 - 21:40
Операции выбираешь от документов?
Если да, то в документе должно стоять "создавать операцию"...
   Dusseldorf
20 - 19.11.04 - 21:54
в (11) ты написал то, что я в (1) :)) но так мне надо выполнять одно условие - Если Опер.Дебет.Счет=СчетПоКоду("6811") Тогда ...
, а так очень долго..
Я вот хотел по операциях проходится, так как и по остальных документах
(между прочим в (10) "Ура!!! Операция!" выводится!!! Ж)
   Х125
21 - 19.11.04 - 22:04
Ну ты меня теперь точно запутал...
Может пить мне меньше надо:(
Во-первых: как у тебя работает 10 ("Ура!!! операция!") ? К операциям через "Документ.Операция" не обращаются... (у меня по крайней мере не работает)
Во-вторых: как обойтись без Опер.Дебет.Счет=СчетПоКоду("6811") Тогда...?




Список тем форума

Форум Территория 1С

  Рекламное место пустует
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует