Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

при попытке ТекДок.Записать(); Пишет "Не выбран документ"

Ø
Я
   GCStas
19.11.04 - 10:09
Процедура Выполнить()
Док=СоздатьОбъект("Документ.Расходная");
Док.ВыбратьДокументы(ДатаНачала,ДатаКонца);
Пока Док.получитьДокумент()=1 Цикл
  ТекДок=СоздатьОбъект("Документ.Расходная");
  ТекДок=Док.ТекущийДокумент();
  
   ТекДок.ВыбратьСтроки();
  
   Пока ТекДок.ПолучитьСтроку()=1 Цикл
   	 ТекДок.ЦенаР=ТекДок.Цена;
   	 ТекДок.СуммаР=ТекДок.Сумма;
   	 ТекДок.СуммаВ=0;
  КонецЦикла;
    
  ТекДок.Записать();
  ТекДок.Провести();
КонецЦикла;
КонецПроцедуры
 
 
   Bot
1 - 19.11.04 - 10:11
Процедура Выполнить()
Док=СоздатьОбъект("Документ.Расходная");
Док.ВыбратьДокументы(ДатаНачала,ДатаКонца);
Пока Док.получитьДокумент()=1 Цикл
  ТекДок=СоздатьОбъект("Документ.Расходная");
  ТекДок=Док.ТекущийДокумент();
  
   Док.ВыбратьСтроки();
  
   Пока Док.ПолучитьСтроку()=1 Цикл
   Док.ЦенаР=ТекДок.Цена;
   Док.СуммаР=ТекДок.Сумма;
   Док.СуммаВ=0;
  КонецЦикла;
    
  Док.Записать();
  Док.Провести();
КонецЦикла;
КонецПроцедуры
   Рамиль
2 - 19.11.04 - 10:12
а зачем вообще нужен ТекДок?
   Megalodon
3 - 19.11.04 - 10:12
Процедура Выполнить()
Док=СоздатьОбъект("Документ.Расходная");
Док.ВыбратьДокументы(ДатаНачала,ДатаКонца);
Пока Док.получитьДокумент()=1 Цикл
   Док.ВыбратьСтроки();
  
   Пока Док.ПолучитьСтроку()=1 Цикл
   Док.ЦенаР=Док.Цена;
   Док.СуммаР=Док.Сумма;
   Док.СуммаВ=0;
  КонецЦикла;
    
  Док.Записать();
  Док.Провести();
КонецЦикла;
КонецПроцедуры
   Смит
4 - 19.11.04 - 10:12
Хе-Хе.
   Bot
5 - 19.11.04 - 10:13
(2) забыл стереть.... или просто лень было... :))
   GCStas
6 - 19.11.04 - 10:14
Thanks :)



Список тем форума

Форум Территория 1С

Рекламное место пустует   Рекламное место пустует
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует