Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

7.7, форма списка справочника

Ø
Я
   Гурон
19.11.04 - 07:43
В форме списка справочника включен некий отбор. необходимо получить тот список элементов, который отображается в соответствии с этим отбором. Интересно получить список элементов именно в форме списка, без СоздатьОбъект("Справочник.ЭтотСправочник")
зы. очевидный вариант - ВыбратьЭлементыПоРеквизиту() известен.
 
 
   Гурон
1 - 19.11.04 - 08:33
попробовал такой вариант, но он не устраивает из-за того, что полный список можно получить только после пробежав по всему списку ручками.
в список ставим текст, формула ПолучитьТекст()
модуль:
Перем ТЗ;
Процедура ПриОткрытии()
    ТЗ=СоздатьОбъект("ТаблицаЗначений");
    ТЗ.НоваяКолонка("Эл","Справочник.ЭтотСправочник");
КонецПроцедуры
Функция ПолучитьТекст()
    НС=0;
    Если (ТЗ.НайтиЗначение(ТекущийЭлемент(),НС,"Эл")=0) Тогда
        ТЗ.НоваяСтрока();
        ТЗ.Эл=ТекущийЭлемент();
    КонецЕсли;
КонецФункции
   Гурон
2 - 19.11.04 - 09:05
up



Список тем форума

Форум Территория 1С

Рекламное место пустует   Рекламное место пустует
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует