Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

ВыбратьСчета

Ø
Я
   М0001
18.11.04 - 17:16
Ит.ИспользоватьСубконто("Раз);
Ит.ИспользоватьСубконто("Два");
Ит.ИспользоватьСубконто("Три");
Ит.ВыполнитьЗапрос(НачДата, КонДата);
Ит.ВыбратьСубконто(1);
Пока Ит.ПолучитьСубконто(1)=1 Цикл
-Обработочка1-
Ит.ВыбратьСубконто(2);
Пока Ит.ПолучитьСубконто(2)=1 Цикл
-Обработочка2-
Ит.ВыбратьСубконто(3);
Пока Ит.ПолучитьСубконто(3)=1 Цикл
-Обработочка3-
КонецЦикла;
КонецЦикла;
КонецЦикла;
Там ,где -Обработочки- еще и по счетам надо выбрать.Т.е.
Ит.ВыбратьСчета();
Ит.ПолучитьСчет();
Но как правильно?
 
 
   Полный Рост
1 - 18.11.04 - 17:24
Не совсем понятен вопрос.
   М0001
2 - 18.11.04 - 17:28
Что не именно?
На каждом этапе -Обработочки-
нужно получить суммы по некоторым счетам(не вдаюсь) и их соотношение формирует строку отчета.
Сложность создают второй и третий субконто.
   Полный Рост
3 - 18.11.04 - 17:35
Если сделать Выбрать/ПолучитьСчет внутри первого цикла - получишь разрез первого субконто по счетам, если внутри второго - разрез второго субконто в разрезе первого по счетам и т.д. ИМХО, так
   IAm
4 - 18.11.04 - 17:36
Сделай выборку счетов перед первой выборкой субконто
   М0001
5 - 18.11.04 - 17:40
В реалии у меня 5 субконто.
Если вначале выбирать счета,то дико усложняется формирование отчета.
   М0001
6 - 19.11.04 - 09:27
ВыбратьСчета



Список тем форума

Форум Территория 1С

Рекламное место пустует  
Кaк может человек ожидaть, что его мольбaм о снисхождении ответит Тот, кто превыше, когдa сaм он откaзывaет в милосердии тем, кто ниже его? Петр Трубецкой
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует