Вход | Регистрация

  1  2
1С:Предприятие ::

Метки:Приемы программирования

О том, как женщины пишут на 1С, или классика женского модулеписания...

↓ [Волшебник, 24.11.04 - 18:46]
Я
   Львенок
 
24.11.04 - 15:07
Привожу кусок кода, обнаруженный мной при доработке одного документа. Писала девушка. Привожу без комментариев только одну процедуру из него (А там их несколько и все однотипны):

Процедура СформироватьПеремещения()   
    
    Цены=СоздатьОбъект("Справочник.Цены"); 
    ТипЦены=СоздатьОбъект("Справочник.ТипыЦен"); 
    ТипЦены.НайтиПоНаименованию("Розничные",0.0);  
    РознЦена=ТипЦены.ТекущийЭлемент();    

    СпрНП=СоздатьОбъект("Справочник.СтавкиНП");  
    СпрНП.НайтиПоНаименованию("Без налога",0.0);
    НП=СпрНП.ТекущийЭлемент();
    НДС=Перечисление.СтавкиНДС.БезНДС;

    Док11=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док11.Новый();
    Док11.ДатаДок=ДатаДок;     
    Док11.Фирма=Фирма;   
    Док11.Автор    = глПользователь;
    Док11.Склад=Маг1;
    Док11.ФирмаПолучатель=Док11.Фирма;
    Док11.СкладПолучатель=Склад;
    Док11.УчитыватьНДС=0;
    Док11.УчитыватьНП=0;
    Док11.СуммаВклНДС=0;
    Док11.СуммаВклНП=0;  
    Док11.ТипЦен=РознЦена;
    Док11.Валюта=РознЦена.Валюта;
    Док11.Курс=1; 
    Док11.Комментарий=Комментарий;     
                             
    Док1=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док1.Новый();
    Док1.ДатаДок=ДатаДок;     
    Док1.Фирма=Фирма;   
    Док1.Автор    = глПользователь;
    Док1.Склад=Склад;
    Док1.ФирмаПолучатель=Док1.Фирма;
    Док1.СкладПолучатель=Маг1;
    Док1.УчитыватьНДС=0;
    Док1.УчитыватьНП=0;
    Док1.СуммаВклНДС=0;
    Док1.СуммаВклНП=0;  
    Док1.ТипЦен=РознЦена;
    Док1.Валюта=РознЦена.Валюта;
    Док1.Курс=1; 
    Док1.Комментарий=Комментарий;     
                             
    Док21=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док21.Новый();
    Док21.ДатаДок=ДатаДок;     
    Док21.Фирма=Фирма;   
    Док21.Автор    = глПользователь;
    Док21.Склад=Маг2;
    Док21.ФирмаПолучатель=Док21.Фирма;
    Док21.СкладПолучатель=Склад;
    Док21.УчитыватьНДС=0;
    Док21.УчитыватьНП=0;
    Док21.СуммаВклНДС=0;
    Док21.СуммаВклНП=0;  
    Док21.ТипЦен=РознЦена;
    Док21.Валюта=РознЦена.Валюта;
    Док21.Курс=1; 
    Док21.Комментарий=Комментарий;     
                             
    Док2=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док2.Новый();
    Док2.ДатаДок=ДатаДок;
    Док2.Фирма=Фирма;   
    Док2.Автор    = глПользователь;
    Док2.Склад=Склад;
    Док2.ФирмаПолучатель=Док2.Фирма;
    Док2.СкладПолучатель=Маг2;
    Док2.УчитыватьНДС=0;
    Док2.УчитыватьНП=0;
    Док2.СуммаВклНДС=0;
    Док2.СуммаВклНП=0;  
    Док2.ТипЦен=РознЦена;
    Док2.Валюта=РознЦена.Валюта;
    Док2.Курс=1; 
    Док2.Комментарий=Комментарий;     
                             
    Док31=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док31.Новый();
    Док31.ДатаДок=ДатаДок;     
    Док31.Фирма=Фирма;   
    Док31.Автор    = глПользователь;
    Док31.Склад=Маг3;
    Док31.ФирмаПолучатель=Док31.Фирма;
    Док31.СкладПолучатель=Склад;
    Док31.УчитыватьНДС=0;
    Док31.УчитыватьНП=0;
    Док31.СуммаВклНДС=0;
    Док31.СуммаВклНП=0;  
    Док31.ТипЦен=РознЦена;
    Док31.Валюта=РознЦена.Валюта;
    Док31.Курс=1; 
    Док31.Комментарий=Комментарий;     
                             
    Док3=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док3.Новый();
    Док3.ДатаДок=ДатаДок;
    Док3.Фирма=Фирма;   
    Док3.Автор    = глПользователь;
    Док3.Склад=Склад;
    Док3.ФирмаПолучатель=Док3.Фирма;
    Док3.СкладПолучатель=Маг3;
    Док3.УчитыватьНДС=0;
    Док3.УчитыватьНП=0;
    Док3.СуммаВклНДС=0;
    Док3.СуммаВклНП=0;  
    Док3.ТипЦен=РознЦена;
    Док3.Валюта=РознЦена.Валюта;
    Док3.Курс=1; 
    Док3.Комментарий=Комментарий;     
                             
    Док41=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док41.Новый();
    Док41.ДатаДок=ДатаДок;     
    Док41.Фирма=Фирма;   
    Док41.Автор    = глПользователь;
    Док41.Склад=Маг4;
    Док41.ФирмаПолучатель=Док41.Фирма;
    Док41.СкладПолучатель=Склад;
    Док41.УчитыватьНДС=0;
    Док41.УчитыватьНП=0;
    Док41.СуммаВклНДС=0;
    Док41.СуммаВклНП=0;  
    Док41.ТипЦен=РознЦена;
    Док41.Валюта=РознЦена.Валюта;
    Док41.Курс=1; 
    Док41.Комментарий=Комментарий;     
                             
    Док4=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док4.Новый();
    Док4.ДатаДок=ДатаДок;
    Док4.Фирма=Фирма;   
    Док4.Автор    = глПользователь;
    Док4.Склад=Склад;
    Док4.ФирмаПолучатель=Док4.Фирма;
    Док4.СкладПолучатель=Маг4;
    Док4.УчитыватьНДС=0;
    Док4.УчитыватьНП=0;
    Док4.СуммаВклНДС=0;
    Док4.СуммаВклНП=0;  
    Док4.ТипЦен=РознЦена;
    Док4.Валюта=РознЦена.Валюта;
    Док4.Курс=1; 
    Док4.Комментарий=Комментарий;     
                             
    Док51=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док51.Новый();
    Док51.ДатаДок=ДатаДок;     
    Док51.Фирма=Фирма;   
    Док51.Автор    = глПользователь;
    Док51.Склад=Маг5;
    Док51.ФирмаПолучатель=Док51.Фирма;
    Док51.СкладПолучатель=Склад;
    Док51.УчитыватьНДС=0;
    Док51.УчитыватьНП=0;
    Док51.СуммаВклНДС=0;
    Док51.СуммаВклНП=0;  
    Док51.ТипЦен=РознЦена;
    Док51.Валюта=РознЦена.Валюта;
    Док51.Курс=1; 
    Док51.Комментарий=Комментарий;     
                             
    Док5=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док5.Новый();
    Док5.ДатаДок=ДатаДок;
    Док5.Фирма=Фирма;   
    Док5.Автор    = глПользователь;
    Док5.Склад=Склад;
    Док5.ФирмаПолучатель=Док5.Фирма;
    Док5.СкладПолучатель=Маг5;
    Док5.УчитыватьНДС=0;
    Док5.УчитыватьНП=0;
    Док5.СуммаВклНДС=0;
    Док5.СуммаВклНП=0;  
    Док5.ТипЦен=РознЦена;
    Док5.Валюта=РознЦена.Валюта;
    Док5.Курс=1; 
    Док5.Комментарий=Комментарий;     
                             
    Док61=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док61.Новый();
    Док61.ДатаДок=ДатаДок;     
    Док61.Фирма=Фирма;   
    Док61.Автор    = глПользователь;
    Док61.Склад=Маг6;
    Док61.ФирмаПолучатель=Док61.Фирма;
    Док61.СкладПолучатель=Склад;
    Док61.УчитыватьНДС=0;
    Док61.УчитыватьНП=0;
    Док61.СуммаВклНДС=0;
    Док61.СуммаВклНП=0;  
    Док61.ТипЦен=РознЦена;
    Док61.Валюта=РознЦена.Валюта;
    Док61.Курс=1; 
    Док61.Комментарий=Комментарий;     
                             
    Док6=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док6.Новый();
    Док6.ДатаДок=ДатаДок;
    Док6.Фирма=Фирма;   
    Док6.Автор    = глПользователь;
    Док6.Склад=Склад;
    Док6.ФирмаПолучатель=Док6.Фирма;
    Док6.СкладПолучатель=Маг6;
    Док6.УчитыватьНДС=0;
    Док6.УчитыватьНП=0;
    Док6.СуммаВклНДС=0;
    Док6.СуммаВклНП=0;  
    Док6.ТипЦен=РознЦена;
    Док6.Валюта=РознЦена.Валюта;
    Док6.Курс=1; 
    Док6.Комментарий=Комментарий;     
                             
    Док71=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док71.Новый();
    Док71.ДатаДок=ДатаДок;     
    Док71.Фирма=Фирма;   
    Док71.Автор    = глПользователь;
    Док71.Склад=Маг7;
    Док71.ФирмаПолучатель=Док71.Фирма;
    Док71.СкладПолучатель=Склад;
    Док71.УчитыватьНДС=0;
    Док71.УчитыватьНП=0;
    Док71.СуммаВклНДС=0;
    Док71.СуммаВклНП=0;  
    Док71.ТипЦен=РознЦена;
    Док71.Валюта=РознЦена.Валюта;
    Док71.Курс=1; 
    Док71.Комментарий=Комментарий;     
                             
    Док7=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док7.Новый();
    Док7.ДатаДок=ДатаДок;
    Док7.Фирма=Фирма;   
    Док7.Автор    = глПользователь;
    Док7.Склад=Склад;
    Док7.ФирмаПолучатель=Док7.Фирма;
    Док7.СкладПолучатель=Маг7;
    Док7.УчитыватьНДС=0;
    Док7.УчитыватьНП=0;
    Док7.СуммаВклНДС=0;
    Док7.СуммаВклНП=0;  
    Док7.ТипЦен=РознЦена;
    Док7.Валюта=РознЦена.Валюта;
    Док7.Курс=1; 
    Док7.Комментарий=Комментарий;     
                             
    Док81=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док81.Новый();
    Док81.ДатаДок=ДатаДок;     
    Док81.Фирма=Фирма;   
    Док81.Автор    = глПользователь;
    Док81.Склад=Маг8;
    Док81.ФирмаПолучатель=Док81.Фирма;
    Док81.СкладПолучатель=Склад;
    Док81.УчитыватьНДС=0;
    Док81.УчитыватьНП=0;
    Док81.СуммаВклНДС=0;
    Док81.СуммаВклНП=0;  
    Док81.ТипЦен=РознЦена;
    Док81.Валюта=РознЦена.Валюта;
    Док81.Курс=1; 
    Док81.Комментарий=Комментарий;     
                             
    Док8=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док8.Новый();
    Док8.ДатаДок=ДатаДок;
    Док8.Фирма=Фирма;   
    Док8.Автор    = глПользователь;
    Док8.Склад=Склад;
    Док8.ФирмаПолучатель=Док8.Фирма;
    Док8.СкладПолучатель=Маг8;
    Док8.УчитыватьНДС=0;
    Док8.УчитыватьНП=0;
    Док8.СуммаВклНДС=0;
    Док8.СуммаВклНП=0;  
    Док8.ТипЦен=РознЦена;
    Док8.Валюта=РознЦена.Валюта;
    Док8.Курс=1; 
    Док8.Комментарий=Комментарий;     
                             
    Док91=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док91.Новый();
    Док91.ДатаДок=ДатаДок;     
    Док91.Фирма=Фирма;   
    Док91.Автор    = глПользователь;
    Док91.Склад=Маг9;
    Док91.ФирмаПолучатель=Док91.Фирма;
    Док91.СкладПолучатель=Склад;
    Док91.УчитыватьНДС=0;
    Док91.УчитыватьНП=0;
    Док91.СуммаВклНДС=0;
    Док91.СуммаВклНП=0;  
    Док91.ТипЦен=РознЦена;
    Док91.Валюта=РознЦена.Валюта;
    Док91.Курс=1; 
    Док91.Комментарий=Комментарий;     
                             
    Док9=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док9.Новый();
    Док9.ДатаДок=ДатаДок;
    Док9.Фирма=Фирма;   
    Док9.Автор    = глПользователь;
    Док9.Склад=Склад;
    Док9.ФирмаПолучатель=Док9.Фирма;
    Док9.СкладПолучатель=Маг9;
    Док9.УчитыватьНДС=0;
    Док9.УчитыватьНП=0;
    Док9.СуммаВклНДС=0;
    Док9.СуммаВклНП=0;  
    Док9.ТипЦен=РознЦена;
    Док9.Валюта=РознЦена.Валюта;
    Док9.Курс=1; 
    Док9.Комментарий=Комментарий;     
                             
    Док101=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док101.Новый();
    Док101.ДатаДок=ДатаДок;     
    Док101.Фирма=Фирма;   
    Док101.Автор    = глПользователь;
    Док101.Склад=Маг10;
    Док101.ФирмаПолучатель=Док101.Фирма;
    Док101.СкладПолучатель=Склад;
    Док101.УчитыватьНДС=0;
    Док101.УчитыватьНП=0;
    Док101.СуммаВклНДС=0;
    Док101.СуммаВклНП=0;  
    Док101.ТипЦен=РознЦена;
    Док101.Валюта=РознЦена.Валюта;
    Док101.Курс=1; 
    Док101.Комментарий=Комментарий;     
                             
    Док10=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док10.Новый();
    Док10.ДатаДок=ДатаДок;     
    Док10.Фирма=Фирма;   
    Док10.Автор    = глПользователь;
    Док10.Склад=Склад;
    Док10.ФирмаПолучатель=Док10.Фирма;
    Док10.СкладПолучатель=Маг10;
    Док10.УчитыватьНДС=0;
    Док10.УчитыватьНП=0;
    Док10.СуммаВклНДС=0;
    Док10.СуммаВклНП=0;  
    Док10.ТипЦен=РознЦена;
    Док10.Валюта=РознЦена.Валюта;
    Док10.Курс=1; 
    Док10.Комментарий=Комментарий;     
                             
    Док111=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док111.Новый();
    Док111.ДатаДок=ДатаДок;     
    Док111.Фирма=Фирма;   
    Док111.Автор    = глПользователь;
    Док111.Склад=Маг11;
    Док111.ФирмаПолучатель=Док111.Фирма;
    Док111.СкладПолучатель=Склад;
    Док111.УчитыватьНДС=0;
    Док111.УчитыватьНП=0;
    Док111.СуммаВклНДС=0;
    Док111.СуммаВклНП=0;  
    Док111.ТипЦен=РознЦена;
    Док111.Валюта=РознЦена.Валюта;
    Док111.Курс=1; 
    Док111.Комментарий=Комментарий;     
                             
    Док011=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док011.Новый();
    Док011.ДатаДок=ДатаДок;     
    Док011.Фирма=Фирма;   
    Док011.Автор    = глПользователь;
    Док011.Склад=Склад;
    Док011.ФирмаПолучатель=Док011.Фирма;
    Док011.СкладПолучатель=Маг11;
    Док011.УчитыватьНДС=0;
    Док011.УчитыватьНП=0;
    Док011.СуммаВклНДС=0;
    Док011.СуммаВклНП=0;  
    Док011.ТипЦен=РознЦена;
    Док011.Валюта=РознЦена.Валюта;
    Док011.Курс=1; 
    Док011.Комментарий=Комментарий;     
                             
    Док121=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док121.Новый();
    Док121.ДатаДок=ДатаДок;     
    Док121.Фирма=Фирма;   
    Док121.Автор    = глПользователь;
    Док121.Склад=Маг12;
    Док121.ФирмаПолучатель=Док121.Фирма;
    Док121.СкладПолучатель=Склад;
    Док121.УчитыватьНДС=0;
    Док121.УчитыватьНП=0;
    Док121.СуммаВклНДС=0;
    Док121.СуммаВклНП=0;  
    Док121.ТипЦен=РознЦена;
    Док121.Валюта=РознЦена.Валюта;
    Док121.Курс=1; 
    Док121.Комментарий=Комментарий;     
                             
    Док12=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док12.Новый();
    Док12.ДатаДок=ДатаДок;     
    Док12.Фирма=Фирма;   
    Док12.Автор    = глПользователь;
    Док12.Склад=Склад;
    Док12.ФирмаПолучатель=Док12.Фирма;
    Док12.СкладПолучатель=Маг12;
    Док12.УчитыватьНДС=0;
    Док12.УчитыватьНП=0;
    Док12.СуммаВклНДС=0;
    Док12.СуммаВклНП=0;  
    Док12.ТипЦен=РознЦена;
    Док12.Валюта=РознЦена.Валюта;
    Док12.Курс=1; 
    Док12.Комментарий=Комментарий;     
                             
    Док131=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док131.Новый();
    Док131.ДатаДок=ДатаДок;     
    Док131.Фирма=Фирма;   
    Док131.Автор    = глПользователь;
    Док131.Склад=Маг13;
    Док131.ФирмаПолучатель=Док131.Фирма;
    Док131.СкладПолучатель=Склад;
    Док131.УчитыватьНДС=0;
    Док131.УчитыватьНП=0;
    Док131.СуммаВклНДС=0;
    Док131.СуммаВклНП=0;  
    Док131.ТипЦен=РознЦена;
    Док131.Валюта=РознЦена.Валюта;
    Док131.Курс=1; 
    Док131.Комментарий=Комментарий;     
                             
    Док13=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док13.Новый();
    Док13.ДатаДок=ДатаДок;     
    Док13.Фирма=Фирма;   
    Док13.Автор    = глПользователь;
    Док13.Склад=Склад;
    Док13.ФирмаПолучатель=Док13.Фирма;
    Док13.СкладПолучатель=Маг13;
    Док13.УчитыватьНДС=0;
    Док13.УчитыватьНП=0;
    Док13.СуммаВклНДС=0;
    Док13.СуммаВклНП=0;  
    Док13.ТипЦен=РознЦена;
    Док13.Валюта=РознЦена.Валюта;
    Док13.Курс=1; 
    Док13.Комментарий=Комментарий;     
                             
    Док141=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док141.Новый();
    Док141.ДатаДок=ДатаДок;     
    Док141.Фирма=Фирма;   
    Док141.Автор    = глПользователь;
    Док141.Склад=Маг14;
    Док141.ФирмаПолучатель=Док141.Фирма;
    Док141.СкладПолучатель=Склад;
    Док141.УчитыватьНДС=0;
    Док141.УчитыватьНП=0;
    Док141.СуммаВклНДС=0;
    Док141.СуммаВклНП=0;  
    Док141.ТипЦен=РознЦена;
    Док141.Валюта=РознЦена.Валюта;
    Док141.Курс=1; 
    Док141.Комментарий=Комментарий;     
                             
    Док14=СоздатьОбъект("Документ.ПеремещениеТМЦ");
    Док14.Новый();
    Док14.ДатаДок=ДатаДок;     
    Док14.Фирма=Фирма;   
    Док14.Автор    = глПользователь;
    Док14.Склад=Склад;
    Док14.ФирмаПолучатель=Док14.Фирма;
    Док14.СкладПолучатель=Маг14;
    Док14.УчитыватьНДС=0;
    Док14.УчитыватьНП=0;
    Док14.СуммаВклНДС=0;
    Док14.СуммаВклНП=0;  
    Док14.ТипЦен=РознЦена;
    Док14.Валюта=РознЦена.Валюта;
    Док14.Курс=1; 
    Док14.Комментарий=Комментарий;     
                             
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл  
        
        Цены.ИспользоватьВладельца(Номенклатура);
        Если Цены.НайтиПоРеквизиту("ТипЦен",РознЦена,0)=1 Тогда
            ПрЦена=Цены.Цена.Получить(ДатаДок);
        КонецЕсли; 
        
        Если КолМаг1>0 Тогда
            Док1.НоваяСтрока();
            Док1.Номенклатура=Номенклатура;    
            Док1.Единица=Единица;
            Док1.Количество=КолМаг1 ;
            Док1.Коэффициент=Коэффициент;    
            Док1.Цена=ПрЦена;
            Док1.Сумма=КолМаг1*Док1.Цена; 
            Док1.СтавкаНДС=НДС;
            Док1.СтавкаНП=НП;
            Док1.СуммаНДС=0;
            Док1.СуммаНП=0;
        ИначеЕсли КолМаг1<0 Тогда
            Док11.НоваяСтрока();
            Док11.Номенклатура=Номенклатура;    
            Док11.Единица=Единица;
            Док11.Количество=(-1)*КолМаг1 ;
            Док11.Коэффициент=Коэффициент;    
            Док11.Цена=ПрЦена;
            Док11.Сумма=(-1)*КолМаг1*Док11.Цена; 
            Док11.СтавкаНДС=НДС;
            Док11.СтавкаНП=НП;
            Док11.СуммаНДС=0;
            Док11.СуммаНП=0;
        КонецЕсли;    
        
        Если КолМаг2>0 Тогда
            Док2.НоваяСтрока();
            Док2.Номенклатура=Номенклатура;    
            Док2.Единица=Единица;
            Док2.Количество=КолМаг2 ;
            Док2.Коэффициент=Коэффициент;    
            Док2.Цена=ПрЦена;
            Док2.Сумма=КолМаг2*Док2.Цена; 
            Док2.СтавкаНДС=НДС;
            Док2.СтавкаНП=НП;
            Док2.СуммаНДС=0;
            Док2.СуммаНП=0;
        ИначеЕсли КолМаг2<0 Тогда
            Док21.НоваяСтрока();
            Док21.Номенклатура=Номенклатура;    
            Док21.Единица=Единица;
            Док21.Количество=(-1)*КолМаг2 ;
            Док21.Коэффициент=Коэффициент;    
            Док21.Цена=ПрЦена;
            Док21.Сумма=(-1)*КолМаг2*Док21.Цена; 
            Док21.СтавкаНДС=НДС;
            Док21.СтавкаНП=НП;
            Док21.СуммаНДС=0;
            Док21.СуммаНП=0;
        КонецЕсли;    
        
        Если КолМаг3>0 Тогда
            Док3.НоваяСтрока();
            Док3.Номенклатура=Номенклатура;    
            Док3.Единица=Единица;
            Док3.Количество=КолМаг3 ;
            Док3.Коэффициент=Коэффициент;    
            Док3.Цена=ПрЦена;
            Док3.Сумма=КолМаг3*Док3.Цена; 
            Док3.СтавкаНДС=НДС;
            Док3.СтавкаНП=НП;
            Док3.СуммаНДС=0;
            Док3.СуммаНП=0;
        ИначеЕсли КолМаг3<0 Тогда
            Док31.НоваяСтрока();
            Док31.Номенклатура=Номенклатура;    
            Док31.Единица=Единица;
            Док31.Количество=(-1)*КолМаг3 ;
            Док31.Коэффициент=Коэффициент;    
            Док31.Цена=ПрЦена;
            Док31.Сумма=(-1)*КолМаг3*Док31.Цена; 
            Док31.СтавкаНДС=НДС;
            Док31.СтавкаНП=НП;
            Док31.СуммаНДС=0;
            Док31.СуммаНП=0;
        КонецЕсли;    
        
        Если КолМаг4>0 Тогда
            Док4.НоваяСтрока();
            Док4.Номенклатура=Номенклатура;    
            Док4.Единица=Единица;
            Док4.Количество=КолМаг4 ;
            Док4.Коэффициент=Коэффициент;    
            Док4.Цена=ПрЦена;
            Док4.Сумма=КолМаг4*Док4.Цена; 
            Док4.СтавкаНДС=НДС;
            Док4.СтавкаНП=НП;
            Док4.СуммаНДС=0;
            Док4.СуммаНП=0;
        ИначеЕсли КолМаг4<0 Тогда
            Док41.НоваяСтрока();
            Док41.Номенклатура=Номенклатура;    
            Док41.Единица=Единица;
            Док41.Количество=(-1)*КолМаг4 ;
            Док41.Коэффициент=Коэффициент;    
            Док41.Цена=ПрЦена;
            Док41.Сумма=(-1)*КолМаг4*Док41.Цена; 
            Док41.СтавкаНДС=НДС;
            Док41.СтавкаНП=НП;
            Док41.СуммаНДС=0;
            Док41.СуммаНП=0;
        КонецЕсли;    
        
        Если КолМаг5>0 Тогда
            Док5.НоваяСтрока();
            Док5.Номенклатура=Номенклатура;    
            Док5.Единица=Единица;
            Док5.Количество=КолМаг5 ;
            Док5.Коэффициент=Коэффициент;    
            Док5.Цена=ПрЦена;
            Док5.Сумма=КолМаг5*Док5.Цена; 
            Док5.СтавкаНДС=НДС;
            Док5.СтавкаНП=НП;
            Док5.СуммаНДС=0;
            Док5.СуммаНП=0;
        ИначеЕсли КолМаг5<0 Тогда
            Док51.НоваяСтрока();
            Док51.Номенклатура=Номенклатура;    
            Док51.Единица=Единица;
            Док51.Количество=(-1)*КолМаг5 ;
            Док51.Коэффициент=Коэффициент;    
            Док51.Цена=ПрЦена;
            Док51.Сумма=(-1)*КолМаг5*Док51.Цена; 
            Док51.СтавкаНДС=НДС;
            Док51.СтавкаНП=НП;
            Док51.СуммаНДС=0;
            Док51.СуммаНП=0;
        КонецЕсли;    
        
        Если КолМаг6>0 Тогда
            Док6.НоваяСтрока();
            Док6.Номенклатура=Номенклатура;    
            Док6.Единица=Единица;
            Док6.Количество=КолМаг6 ;
            Док6.Коэффициент=Коэффициент;    
            Док6.Цена=ПрЦена;
            Док6.Сумма=КолМаг6*Док6.Цена; 
            Док6.СтавкаНДС=НДС;
            Док6.СтавкаНП=НП;
            Док6.СуммаНДС=0;
            Док6.СуммаНП=0;
        ИначеЕсли КолМаг6<0 Тогда
            Док61.НоваяСтрока();
            Док61.Номенклатура=Номенклатура;    
            Док61.Единица=Единица;
            Док61.Количество=(-1)*КолМаг6 ;
            Док61.Коэффициент=Коэффициент;    
            Док61.Цена=ПрЦена;
            Док61.Сумма=(-1)*КолМаг6*Док61.Цена; 
            Док61.СтавкаНДС=НДС;
            Док61.СтавкаНП=НП;
            Док61.СуммаНДС=0;
            Док61.СуммаНП=0;
        КонецЕсли;    
        
        Если КолМаг7>0 Тогда
            Док7.НоваяСтрока();
            Док7.Номенклатура=Номенклатура;    
            Док7.Единица=Единица;
            Док7.Количество=КолМаг7 ;
            Док7.Коэффициент=Коэффициент;    
            Док7.Цена=ПрЦена;
            Док7.Сумма=КолМаг7*Док7.Цена; 
            Док7.СтавкаНДС=НДС;
            Док7.СтавкаНП=НП;
            Док7.СуммаНДС=0;
            Док7.СуммаНП=0;
        ИначеЕсли КолМаг7<0 Тогда
            Док71.НоваяСтрока();
            Док71.Номенклатура=Номенклатура;    
            Док71.Единица=Единица;
            Док71.Количество=(-1)*КолМаг7 ;
            Док71.Коэффициент=Коэффициент;    
            Док71.Цена=ПрЦена;
            Док71.Сумма=(-1)*КолМаг7*Док71.Цена; 
            Док71.СтавкаНДС=НДС;
            Док71.СтавкаНП=НП;
            Док71.СуммаНДС=0;
            Док71.СуммаНП=0;
        КонецЕсли;    
        
        Если КолМаг8>0 Тогда
            Док8.НоваяСтрока();
            Док8.Номенклатура=Номенклатура;    
            Док8.Единица=Единица;
            Док8.Количество=КолМаг8 ;
            Док8.Коэффициент=Коэффициент;    
            Док8.Цена=ПрЦена;
            Док8.Сумма=КолМаг8*Док8.Цена; 
            Док8.СтавкаНДС=НДС;
            Док8.СтавкаНП=НП;
            Док8.СуммаНДС=0;
            Док8.СуммаНП=0;
        ИначеЕсли КолМаг8<0 Тогда
            Док81.НоваяСтрока();
            Док81.Номенклатура=Номенклатура;    
            Док81.Единица=Единица;
            Док81.Количество=(-1)*КолМаг8 ;
            Док81.Коэффициент=Коэффициент;    
            Док81.Цена=ПрЦена;
            Док81.Сумма=(-1)*КолМаг8*Док81.Цена; 
            Док81.СтавкаНДС=НДС;
            Док81.СтавкаНП=НП;
            Док81.СуммаНДС=0;
            Док81.СуммаНП=0;
        КонецЕсли;    
        
        Если КолМаг9>0 Тогда
            Док9.НоваяСтрока();
            Док9.Номенклатура=Номенклатура;    
            Док9.Единица=Единица;
            Док9.Количество=КолМаг9 ;
            Док9.Коэффициент=Коэффициент;    
            Док9.Цена=ПрЦена;
            Док9.Сумма=КолМаг9*Док9.Цена; 
            Док9.СтавкаНДС=НДС;
            Док9.СтавкаНП=НП;
            Док9.СуммаНДС=0;
            Док9.СуммаНП=0;
        ИначеЕсли КолМаг9<0 Тогда
            Док91.НоваяСтрока();
            Док91.Номенклатура=Номенклатура;    
            Док91.Единица=Единица;
            Док91.Количество=(-1)*КолМаг9 ;
            Док91.Коэффициент=Коэффициент;    
            Док91.Цена=ПрЦена;
            Док91.Сумма=(-1)*КолМаг9*Док91.Цена; 
            Док91.СтавкаНДС=НДС;
            Док91.СтавкаНП=НП;
            Док91.СуммаНДС=0;
            Док91.СуммаНП=0;
        КонецЕсли;    
        
        Если КолМаг10>0 Тогда
            Док10.НоваяСтрока();
            Док10.Номенклатура=Номенклатура;    
            Док10.Единица=Единица;
            Док10.Количество=КолМаг10 ;
            Док10.Коэффициент=Коэффициент;    
            Док10.Цена=ПрЦена;
            Док10.Сумма=КолМаг10*Док10.Цена; 
            Док10.СтавкаНДС=НДС;
            Док10.СтавкаНП=НП;
            Док10.СуммаНДС=0;
            Док10.СуммаНП=0;
        ИначеЕсли КолМаг10<0 Тогда
            Док101.НоваяСтрока();
            Док101.Номенклатура=Номенклатура;    
            Док101.Единица=Единица;
            Док101.Количество=(-1)*КолМаг10 ;
            Док101.Коэффициент=Коэффициент;    
            Док101.Цена=ПрЦена;
            Док101.Сумма=(-1)*КолМаг10*Док101.Цена; 
            Док101.СтавкаНДС=НДС;
            Док101.СтавкаНП=НП;
            Док101.СуммаНДС=0;
            Док101.СуммаНП=0;
        КонецЕсли;    
        
        Если КолМаг11>0 Тогда
            Док011.НоваяСтрока();
            Док011.Номенклатура=Номенклатура;    
            Док011.Единица=Единица;
            Док011.Количество=КолМаг11 ;
            Док011.Коэффициент=Коэффициент;    
            Док011.Цена=ПрЦена;
            Док011.Сумма=КолМаг11*Док011.Цена; 
            Док011.СтавкаНДС=НДС;
            Док011.СтавкаНП=НП;
            Док011.СуммаНДС=0;
            Док011.СуммаНП=0;
        ИначеЕсли КолМаг10<0 Тогда
            Док111.НоваяСтрока();
            Док111.Номенклатура=Номенклатура;    
            Док111.Единица=Единица;
            Док111.Количество=(-1)*КолМаг11 ;
            Док111.Коэффициент=Коэффициент;    
            Док111.Цена=ПрЦена;
            Док111.Сумма=(-1)*КолМаг11*Док111.Цена; 
            Док111.СтавкаНДС=НДС;
            Док111.СтавкаНП=НП;
            Док111.СуммаНДС=0;
            Док111.СуммаНП=0;
        КонецЕсли;    
        
        Если КолМаг12>0 Тогда
            Док12.НоваяСтрока();
            Док12.Номенклатура=Номенклатура;    
            Док12.Единица=Единица;
            Док12.Количество=КолМаг12 ;
            Док12.Коэффициент=Коэффициент;    
            Док12.Цена=ПрЦена;
            Док12.Сумма=КолМаг12*Док12.Цена; 
            Док12.СтавкаНДС=НДС;
            Док12.СтавкаНП=НП;
            Док12.СуммаНДС=0;
            Док12.СуммаНП=0;
        ИначеЕсли КолМаг12<0 Тогда
            Док121.НоваяСтрока();
            Док121.Номенклатура=Номенклатура;    
            Док121.Единица=Единица;
            Док121.Количество=(-1)*КолМаг12 ;
            Док121.Коэффициент=Коэффициент;    
            Док121.Цена=ПрЦена;
            Док121.Сумма=(-1)*КолМаг12*Док121.Цена; 
            Док121.СтавкаНДС=НДС;
            Док121.СтавкаНП=НП;
            Док121.СуммаНДС=0;
            Док121.СуммаНП=0;
        КонецЕсли;    
        
        Если КолМаг13>0 Тогда
            Док13.НоваяСтрока();
            Док13.Номенклатура=Номенклатура;    
            Док13.Единица=Единица;
            Док13.Количество=КолМаг13 ;
            Док13.Коэффициент=Коэффициент;    
            Док13.Цена=ПрЦена;
            Док13.Сумма=КолМаг13*Док13.Цена; 
            Док13.СтавкаНДС=НДС;
            Док13.СтавкаНП=НП;
            Док13.СуммаНДС=0;
            Док13.СуммаНП=0;
        ИначеЕсли КолМаг13<0 Тогда
            Док131.НоваяСтрока();
            Док131.Номенклатура=Номенклатура;    
            Док131.Единица=Единица;
            Док131.Количество=(-1)*КолМаг13 ;
            Док131.Коэффициент=Коэффициент;    
            Док131.Цена=ПрЦена;
            Док131.Сумма=(-1)*КолМаг13*Док131.Цена; 
            Док131.СтавкаНДС=НДС;
            Док131.СтавкаНП=НП;
            Док131.СуммаНДС=0;
            Док131.СуммаНП=0;
        КонецЕсли;    
        
        Если КолМаг14>0 Тогда
            Док14.НоваяСтрока();
            Док14.Номенклатура=Номенклатура;    
            Док14.Единица=Единица;
            Док14.Количество=КолМаг14 ;
            Док14.Коэффициент=Коэффициент;    
            Док14.Цена=ПрЦена;
            Док14.Сумма=КолМаг14*Док14.Цена; 
            Док14.СтавкаНДС=НДС;
            Док14.СтавкаНП=НП;
            Док14.СуммаНДС=0;
            Док14.СуммаНП=0;
        ИначеЕсли КолМаг14<0 Тогда
            Док141.НоваяСтрока();
            Док141.Номенклатура=Номенклатура;    
            Док141.Единица=Единица;
            Док141.Количество=(-1)*КолМаг14 ;
            Док141.Коэффициент=Коэффициент;    
            Док141.Цена=ПрЦена;
            Док141.Сумма=(-1)*КолМаг14*Док141.Цена; 
            Док141.СтавкаНДС=НДС;
            Док141.СтавкаНП=НП;
            Док141.СуммаНДС=0;
            Док141.СуммаНП=0;
        КонецЕсли;    
        
    КонецЦикла;    
    
    Если Док11.КоличествоСтрок()>0 Тогда
        Док11.Записать(); 
        Сообщить("Сформирован документ "+Док11);
     КонецЕсли;
    Если Док21.КоличествоСтрок()>0 Тогда
        Док21.Записать();
         Сообщить("Сформирован документ "+Док21);
    КонецЕсли;  
    Если Док31.КоличествоСтрок()>0 Тогда
        Док31.Записать();
         Сообщить("Сформирован документ "+Док31);
    КонецЕсли;
    Если Док41.КоличествоСтрок()>0 Тогда
        Док41.Записать();
        Сообщить("Сформирован документ "+Док41);
     КонецЕсли;
    Если Док51.КоличествоСтрок()>0 Тогда
        Док51.Записать();
         Сообщить("Сформирован документ "+Док51);
    КонецЕсли;
    Если Док61.КоличествоСтрок()>0 Тогда
        Док61.Записать();
        Сообщить("Сформирован документ "+Док61);
     КонецЕсли;
    Если Док71.КоличествоСтрок()>0 Тогда
        Док71.Записать();
        Сообщить("Сформирован документ "+Док71);
     КонецЕсли;
    Если Док81.КоличествоСтрок()>0 Тогда
        Док81.Записать();
        Сообщить("Сформирован документ "+Док81);
     КонецЕсли;
    Если Док91.КоличествоСтрок()>0 Тогда
        Док91.Записать();
        Сообщить("Сформирован документ "+Док91);
     КонецЕсли;
    Если Док101.КоличествоСтрок()>0 Тогда
        Док101.Записать();
        Сообщить("Сформирован документ "+Док101);
     КонецЕсли;
     Если Док111.КоличествоСтрок()>0 Тогда
        Док111.Записать();
        Сообщить("Сформирован документ "+Док111);
     КонецЕсли;
    Если Док121.КоличествоСтрок()>0 Тогда
        Док121.Записать();
        Сообщить("Сформирован документ "+Док121);
     КонецЕсли;
    Если Док131.КоличествоСтрок()>0 Тогда
        Док131.Записать();
        Сообщить("Сформирован документ "+Док131);
     КонецЕсли;
    Если Док141.КоличествоСтрок()>0 Тогда
        Док141.Записать();
        Сообщить("Сформирован документ "+Док141);
     КонецЕсли;
    
    Если Док1.КоличествоСтрок()>0 Тогда
        Док1.Записать(); 
        Сообщить("Сформирован документ "+Док1);
     КонецЕсли;
    Если Док2.КоличествоСтрок()>0 Тогда
        Док2.Записать();
         Сообщить("Сформирован документ "+Док2);
    КонецЕсли;
    Если Док3.КоличествоСтрок()>0 Тогда
        Док3.Записать();
         Сообщить("Сформирован документ "+Док3);
    КонецЕсли;
    Если Док4.КоличествоСтрок()>0 Тогда
        Док4.Записать();
        Сообщить("Сформирован документ "+Док4);
     КонецЕсли;
    Если Док5.КоличествоСтрок()>0 Тогда
        Док5.Записать();
         Сообщить("Сформирован документ "+Док5);
    КонецЕсли;
    Если Док6.КоличествоСтрок()>0 Тогда
        Док6.Записать();
        Сообщить("Сформирован документ "+Док6);
     КонецЕсли;
    Если Док7.КоличествоСтрок()>0 Тогда
        Док7.Записать();
        Сообщить("Сформирован документ "+Док7);
     КонецЕсли;
    Если Док8.КоличествоСтрок()>0 Тогда
        Док8.Записать();
        Сообщить("Сформирован документ "+Док8);
     КонецЕсли;
    Если Док9.КоличествоСтрок()>0 Тогда
        Док9.Записать();
        Сообщить("Сформирован документ "+Док9);
     КонецЕсли;
    Если Док10.КоличествоСтрок()>0 Тогда
        Док10.Записать();
        Сообщить("Сформирован документ "+Док10);
     КонецЕсли;
    Если Док011.КоличествоСтрок()>0 Тогда
        Док011.Записать();
        Сообщить("Сформирован документ "+Док11);
     КонецЕсли;
    Если Док12.КоличествоСтрок()>0 Тогда
        Док12.Записать();
        Сообщить("Сформирован документ "+Док12);
     КонецЕсли;
    Если Док13.КоличествоСтрок()>0 Тогда
        Док13.Записать();
        Сообщить("Сформирован документ "+Док13);
     КонецЕсли;
    Если Док14.КоличествоСтрок()>0 Тогда
        Док14.Записать();
        Сообщить("Сформирован документ "+Док14);
     КонецЕсли;
    
КонецПроцедуры
 
 
   Asmody
 
101 - 24.11.04 - 17:06
(98) да. чего только в СССР не пили... да все пили. что горело, то и пили >;))
   big
 
102 - 24.11.04 - 17:07
(101) Нет, друг мой, бражка не горела - она как подлый шпион неожиданно валила с ног.
   Барбариска
 
103 - 24.11.04 - 17:09
(98) хотя...пару недель назад выпила литра полтора слегка подбродившего виноградного сока - из домашнего, "северного" винограда... с удовольствием... Это бражка или не бражка?
А насчет возраста -  может это тоже ты просто забыл год рождения?
   Asmody
 
104 - 24.11.04 - 17:09
(100+) ТОВАРИЩИ!!! объявляется сбор средств на прижизненный памятник NS'у!
Кто сколько может, не стесняемся товарищи!
   NS
 
105 - 24.11.04 - 17:10
(104) Пжалуйста - средства перечислять на мой счет, либо на счет моего доверенного лица.
   Asmody
 
106 - 24.11.04 - 17:11
(105) фиг! мы, если общественность будет не против, скульптуру у Церетели закажем! чтоб с размахом!
   NS
 
107 - 24.11.04 - 17:13
(106) Эта... Что угодно, только не Церетели...
Что я такого плохого сделал???
   big
 
108 - 24.11.04 - 17:13
(103) 1. Так... Вот Вам рецепт. На флягу теплой воды 1 кг. дрожжей, 9 кг. сахара, литр сметаны, специи по вкусу. 2 недели настаивать и можно пить. А если прогнать через аппаратуру, то получится самогон. При добавлении соответствующих ингредиентов получится виски или текила. А у Вас было недобродившее вино, которое иногда начинает "дображивать" в животе. Получается весьма интересный эффект - как внутренний так и внешний.
2. Про год рождения, честно говоря, не понял.
   France
 
109 - 24.11.04 - 17:14
(106) + и возле памятника Петру воздвигнем его
   big
 
110 - 24.11.04 - 17:16
(105) А где гарантии целевого использования средств? Нельзя его допускать к нашим деньгам.
Когда же мы будем делить наши деньги? (с) Ильф и Петров. Золотой теленок.
 
 
   Asmody
 
111 - 24.11.04 - 17:17
(109) нафиг в Москве еще один Петр? фига, пусть вон в Питере место готовят >;))
   Asmody
 
112 - 24.11.04 - 17:19
(111+) стрелка Васильевского острова я думаю как раз подойдет >;))
   Барбариска
 
113 - 24.11.04 - 17:20
(108) ...Э...и девушка ТАКОЕ пила??? сметана-то зачем? у меня была точно не бражка, и еще даже и не вино недобродившее - просто слегка подбродивший сок, эффектов не было.
Насчет года рождения - у меня был знакомый, который в свои 30 хвастался, что "молодо выглядит, даже кондукторы в автобусе спрашивают - "вам полный или льготный?""... озадачила его встречным вопросом - "может, они тебя за пенсионера принимают?"...времена старые помнишь, лицо девушки не помнишь (то ли склероз, то ли...) - и говоришь, что не старый? :)))
   big
 
114 - 24.11.04 - 17:21
(112) Есть Алесандрийский столп, а это будет NS-столп. Напротив или рядом. А наверху NS с протянутой ЖКК в сторону Финского залива.
   LOSS
 
115 - 24.11.04 - 17:26
(20) Костя не осознал до сих пор? Что ты гемор
   big
 
116 - 24.11.04 - 17:27
(113) Сметана - чтобы в процессе брожения сильно не бурлило. Хотел написАть что же она пилА, но передумал. Хватит негатива. Было это где-то в период с 1989 по 1992 год. Точно не помню. За 12 лет имею право забыть и место действия и время и девушку. Я же ее больше не видел. Вот.
   France
 
117 - 24.11.04 - 17:27
(114)+
он памятник воздвиг себе нерукотворный
к нему не зарастет программеров тропа..
вознесется он главой своею несогласной
выше александрийского столпа...
________________________________
(c) А.С.Пушкин в вольной обработке France
   big
 
118 - 24.11.04 - 17:30
(117) Предлагаю создать креативный коллектив. Авторство поровну. Деньги тоже.
Когда же мы будем делить наши деньги? (с) Ильф и Петров. Золотой теленок
   France
 
119 - 24.11.04 - 17:32
а что будем Create()-ровать?
   Барбариска
 
120 - 24.11.04 - 17:34
(117)  при чем здесь александрийский столп? Тут уж как-нибудь Аду Лавлейс упомянуть нужно... только вот рифма в голову не приходит.
   big
 
121 - 24.11.04 - 17:35
(119) Столп и надписи на нем. Это только со стороны кажется, что делать нечего. Ты попробуй натурщика уговорить, а посмотрю что у тебя получится. NS - согласить натУрить? Раздевайся.
   France
 
122 - 24.11.04 - 17:42
Все тихо... Ветер не шумит
Там, где над тропкой программистов
Вознесся памятник герою
который есть NS with ЖКК
и дочери моей, Аде Августине. Над страною
памятник вечно тот царит,
О славных людях говорит
И издалека парус белый
в заливе Финском
Приветом радостным дарит.
Родится ль вновь программер?..
_________________________________________________      
(с) Джордж Гордон Байрон. "Гяур" в вольной обработке France
(120) так, решили же, что памятник возле александрийского столпа воздвигать
а рифма от самого батюшки Ады...
   Таня
 
123 - 24.11.04 - 17:43
в (0) конечно шедевр :)

Костя, чья бы корова мычала, твоя бы ...
   Барбариска
 
124 - 24.11.04 - 17:43
(121) неа, не получится ничего из твоего креатива.  NS уже давно сбежал, еще только как про Церетели услышал. А жаль...
   NS
 
125 - 24.11.04 - 17:44
(124) Куда это я сбежал?
   Таня
 
126 - 24.11.04 - 17:45
а я год в Питере живу, на Александрийской площади всего один раз была :( меня не куда не водят :(
   big
 
127 - 24.11.04 - 17:46
(124) А он уже и не нужен. Раскрученный процесс уже не остановить.
Он когда в туалет пошел - я капу нажал. Скрипач не нужен. (с) к/ф Кин-дза-дза.
   Барбариска
 
128 - 24.11.04 - 17:46
(125) а, понятно, ты просто молча раздевался... Порядок. Все ОК.
   big
 
129 - 24.11.04 - 17:48
(126) Нельзя туда инфицированным. По выздоровлению куда Вас сводить?
   Таня
 
130 - 24.11.04 - 17:50
(129) вот так всегда, сначала некогда, потом нельзя.
Сводите :)
   Барбариска
 
131 - 24.11.04 - 17:52
(122) это уже ближе. Только как-то нужно подчеркнуть, что NS все-таки выше, чем Ада - потому что в отличие от нее - он не плод ничьего больного воображения...
   big
 
132 - 24.11.04 - 17:54
(130) Как-то сильно кратко: -Сводите. Может лучше Вы к нам - Третьяковку детям покажем и все такое.
   Таня
 
133 - 24.11.04 - 17:55
У меня есть книжка, в ней все подробненько про нее написано, даже язык программирования такой есть. Если про человека пишут книжку не художественную, а научную, то человек был есть и будет (не есть а просто будет).
 
  Рекламное место пустует
   Asmody
 
134 - 24.11.04 - 18:01
(133) гм... интересная мысль! может ну его наф, этот памятник. может мы про NS'а книжку нехудожественную напишем для потомков?
   ком
135 - 24.11.04 - 18:04
134. ох, и не художественная книжка получится!!! я себе представляю..
   big
 
136 - 24.11.04 - 18:05
(134) Памятник нужОн однозначно - там денег больше. Книжку тоже можно написать, но это уже сложнее. Русский язык надо знать хорошо. Лучше комиксы или Flash. NSяня.
   Барбариска
 
137 - 24.11.04 - 18:13
Книжку зато тиражировать можно... Если проблемы с русским - можно на английском написать... или на 1С... )))
   Таня
 
138 - 24.11.04 - 18:14
если там будет язык программирования NaSa, то я даже средства готова вложить...
   big
 
139 - 24.11.04 - 18:15
(137) Про английский серьезно? А на 1С это ишшо как?
   Барбариска
 
140 - 24.11.04 - 18:18
(138) я тоже иногда средства в книжки вкладываю... самое главное не забыть, в каком именно томе Ленина сделана заначка.
(139) ну так договорились же, нехудожественную - значит можно и на 1С. Можно даже в женском стиле - гонорары будут больше.
   big
 
141 - 24.11.04 - 18:21
Я что это NS молчит? Он наверное сидит и хихикает в платочек, видя как мы тут ему денежки собрались заработать. Признайся NS - это правда?
   Барбариска
 
142 - 24.11.04 - 18:31
(141) похоже, что процесс раздевания его сильно увлек. Не мешай )))
   Asmody
 
143 - 24.11.04 - 18:36
(136) русский язык знать не обязательно (см. поиск по форуму "bazvan")
(140) я думаю, заначка томе в 35-м... или в 14-м.
(139) как на 1С книжки писать тебе Волшебник популярно объяснит
>;))
   Барбариска
 
144 - 24.11.04 - 18:39
(143) не вижу логики или закономерности с выбором томов )))
Ленин - опасное место - можно потом вечер на поиски убить. Сейчас все больше в Гегеля, там всего три тома ))
   big
 
145 - 24.11.04 - 18:40
(141) Откуда знаешь? Любишь подглядывать? Или догадалась по довольному сопению?
(143) Стоп-стоп-стоп. Вот это вот что значит: >;))  А?
   Asmody
 
146 - 24.11.04 - 18:41
(145) ну я же всетаки немножко демон... с рогами. подмигивающий, весело хохоча >;))
   Барбариска
 
147 - 24.11.04 - 18:42
(145) да это вообще всего лишь мое больное воображение, этот сопящий NS )))
   big
 
148 - 24.11.04 - 18:50
(147) Точно - сопение по причине сна. Разделся и уснул. И слюнку на подушку. Классика жанра.
   Барбариска
 
149 - 24.11.04 - 18:53
(148) та нет, просто насморк у человека... питерская сырость однако...
 
 
   Asmody
 
150 - 24.11.04 - 18:55
Волшебник - злыдень! Утопил ветку!
   big
 
151 - 24.11.04 - 18:56
(149) Раздетый, с насморком, в сырости... Совсем плохо.
Барбариска, скажи мне, а что вот это значит: >;))
   Барбариска
 
152 - 24.11.04 - 18:57
(150) Нечего было обижать в (143), сам виноват...
   Барбариска
 
153 - 24.11.04 - 18:58
(152) я бы сказала, что это улыбающийся и подмигивающий панк с ирокезом
С рожками у меня почему-то не ассоциируется )))
Все, убегаю, всем пока... )))
   big
 
154 - 24.11.04 - 19:00
(153) Строго до 19.00 До свиданьица...
   Барбариска
 
155 - 24.11.04 - 19:01
(154) профилактика на сервере, выгоняют с рабочего места...))
   Asmody
 
156 - 24.11.04 - 19:17
(152) я? Волшебника? да ни в жисть! кто его обидит - дня не проживет (на форуме)
(153) то, что ты назвала будет =;))
(154) ээй! а какже фура, стоящая в пробке в Митино? или сегодня нет таковой? >;))
   big
 
157 - 24.11.04 - 19:27
(156) Гы... Первая уже рагружается. Вторая будет около 23.00 Вообще-то я это написАл по-поводу убегающей девицы.

  1  2

Список тем форума
Рекламное место пустует   Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует