Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Открыть форму существующего документа при запуске системы

Ø
Я
   PopovIP
18.11.04 - 15:02
Хочу открыть док "планируемые задание" при входе в систему
вставляю в процедуру ПриНачалеРаботыСистемы()
Предварительно прочитав в книжке ->
Замечание. Метод ОткрытьФорму нельзя вызывать в «теле» глобального мо­дуля (части глобального модуля, расположенной после последней проце­дуры). Для его вызова при старте программы следует размещать его в процедуре ПриНачалеРаботыСистемы.
Значит можно.
Вставляю
мДок = СоздатьОбъект("Документ.ПланыСнабженца");
мДок.ВыбратьДокументы(ТекущаяДата(), ТекущаяДата());
Пока мДок.ПолучитьДокумент() = 1 Цикл
ОткрытьФорму(мДок,,0);
КонецЦикла;
Синтаксис:
ОткрытьФорму(<Документ>,<КонтекстФормы>,<РежимПросмотра>)
НЕ РАБОТАЕТ. что неправильно
Окажите любезность пожалуйста.
Из обработки таже песня
Текст обработки
Процедура ПриОткрытии()
Форма.Закрыть();
КонецПроцедуры
Процедура ПриЗакрытии()
мДок = СоздатьОбъект("Документ.ПланыСнабженца");
мДок.ВыбратьДокументы(ТекущаяДата(), ТекущаяДата());
Пока мДок.ПолучитьДокумент() = 1 Цикл
ОткрытьФорму(мДок,"Работа",0);
КонецЦикла;
КонецПроцедуры
 
  Рекламное место пустует
   Фолькишер Беобахтер
1 - 18.11.04 - 15:07
ОткрытьФорму(мДок.ТекущийДокумент(),,0);
   PopovIP
2 - 18.11.04 - 15:13
(1) Спасибо, заработало, предположил что он и так спозоционирован.



Список тем форума

Форум Территория 1С

  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует