Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Как обработкой в справ.товаров перенести некоторые элем. из одной груп. в другую

Ø
Я
   Novichek
18.11.04 - 07:07
Если можно покажите на примере
 
  Рекламное место пустует
   MetaEditor
1 - 18.11.04 - 07:14
на форме два поля ввода типа "справочник.<...>".
в первом - группаОткуда , во втором группаКуда..
на кнопке:
спр.ИспользоватьРодителя(группаОткуда)
спр.выбратьэлементы();
..............
в цикле:
спр.родитель=группаКуда
спр.записать()
зы, люблю такие вопросы.....
   который не честный
2 - 18.11.04 - 07:17
1 - обычно на ьтакие вопросы отвечают RTFM.
   MetaEditor
3 - 18.11.04 - 07:19
0) RTFM :-D
   Novichek
4 - 18.11.04 - 07:29
(1) Можно подробнее про текст модуля?
На форму кинул 2 реквезита "Справочник.Товары"
Обозвал, например: группаОткуда и группаКуда
   MetaEditor
5 - 18.11.04 - 07:36
спр.Создатьобъект("Справочник.Товары");
спр.ИспользоватьРодителя(группаОткуда);
спр.выбратьэлементы();
пока спр.получитьэлемент()=1 Цикл
спр.родитель=группаКуда;
спр.записать();
конеццикла
сразу подсказка: посмотри про ВыборГруппы()
   Novichek
6 - 18.11.04 - 08:25
MetaEditor спасибо за помощь!
Делаю так
Процедура Сформировать()
  Спр=СоздатьОбъект("Справочник.Товары");
  РегТовары = СоздатьОбъект("Регистр.ОстаткиТоваров");
  Спр.ИспользоватьРодителя(группаОткуда);
  Спр.ВыбратьЭлементы();
  Пока Спр.ПолучитьЭлемент()=1 Цикл
    Если (Спр.ТекущийЭлемент().ЭтоГруппа()=0) Тогда
      Если РегТовары.СводныйОстаток(Спр.ТекущийЭлемент(),,"ОстатокТовара")=0 Тогда
        Спр.Родитель=ГруппаКуда;			
      КонецЕсли;
    КонецЕсли;
    Спр.Записать();
  КонецЦикла
КонецПроцедуры
Получается что при нажатии кнопаря у меня ищется товар с нулевым остатком и переносится в другую группу.
Вопросы такие:
1) Как зациклить все это дело, а то один раз нажмешь и всего одно наименование переносится
2) И ещё можно ли в группаОткуда указать весь справочник, а не определенную группу? А то групп из которых выбирать товары много.
   Novichek
7 - 18.11.04 - 08:57
Получается что на Спр.Записать(); процедура завершает свою работу?
   zzz
8 - 18.11.04 - 09:17
  Спр=СоздатьОбъект("Справочник.Контрагенты");
  Спр.ОбратныйПорядок(1);
  Спр.ВыбратьЭлементы();
  Пока Спр.ПолучитьЭлемент()=1 Цикл
    Если (Спр.Уровень()=1) И (Спр.ЭтоГруппа()=0) И (Спр.ПометкаУдаления()=0) Тогда
      Сообщить( ""+Спр.ТекущийЭлемент() );
      Спр.Родитель = выбПапка;
      Спр.Записать();
      Спр.ВыбратьЭлементы();
    КонецЕсли;
  КонецЦикла;



Список тем форума

Форум Территория 1С

 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует