Вход | Регистрация

1С:Предприятие ::

Метки:

Заполнение документа

Я
   Wow__cooL
17.02.04 - 22:51
Этот кусок должен загружать данные из файла в новый выбранный документ. Это правильно:?

Док=СоздатьОбъект("Документ."+Метаданные.Документ(ФормДокумент.ТекущаяСтрока()).Идентификатор);
ДокТовар=СоздатьОбъект("Справочник.Номенклатура");
Файл.Первая();//позиционируемся на первой записи  

Док.Новый();
Пока Файл.ВКонце()=0 Цикл 
   НомерЗаписи = Файл.НомерЗаписи();     
   КодТовара = Файл.Kode; 
   КоличествоТовара = Файл.Zakaz; 
   Док.НоваяСтрока();
   ДокТовар.НайтиПоКоду(КодТовара);
   Док.Товар=ДокТовар.Наименование;
   Док.Количество=КоличествоТовара;
   Док.Цена=ДокТовар.Цена;               
   Файл.Следующая();//переходим на следующую запись

КонецЦикла;                                          


И еще вопрос: как вместо
Док.Товар=ДокТовар.Наименование;
написать строку где Товар - Задаваемое пользователем поле документа?
 
  Рекламное место пустует
   SnarkHunter
 
1 - 17.02.04 - 23:18
Неправильно.
И не спрашивай почему...
   Кое-кто@где-то.там
2 - 17.02.04 - 23:26
Тэкс, работу с ДБФками вроде освоил, правда не видно инициализации, может и там косяки.
Надо так:
...
Док.НоваяСтрока();
Если ДокТовар.НайтиПоКоду(КодТовара)=0 тогда
Сообщить("Не найден товар с кодом "+КодТовара);
Иначе
  Док.НоваяСтрока();
  Док.Товар=ДокТовар.ТекущийЭлемент(); 
  Док.Количество=КоличествоТовара; 
  Док.Цена=ДокТовар.Цена;               
КонецЕсли;  
...
КонецЦикла;
Док.Записать();
   SnarkHunter
 
3 - 17.02.04 - 23:33
(2)Представляешь как будет здорово, когда выяснится, что в двух базах под одним и тем же кодом разные товары?
   Wow__cooL
8 - 18.02.04 - 15:07
(1) Ладно, не буду...

   Почему?
   Wow__cooL
9 - 18.02.04 - 15:08
А еще такой вопрос: где остальные 5 сообщений? это я их не вижу, или их убрали по определенным соображениям?
   GrayT
 
10 - 18.02.04 - 15:12
(9)Угу
 
 
   Wow__cooL
11 - 18.02.04 - 15:19
(10)  :))
а теперь сам задай мой вопрос (9) и представь, что тебе ответили "Угу"...
(получится: только ты их не видишь и их убрали по определенным соображениям) :))
   GrayT
 
12 - 18.02.04 - 15:21
Извини, их убрали по определенным соображениям.
   Wow__cooL
13 - 18.02.04 - 15:24
да я так и подумала...
последнее время здесь очень "весело" - сколько веток по поводу выяснения отношений создали!

Да, кстати, поздравляю тебя как новоиспеченного эксперта первого (я ведь не ошибаюсь) уровня!
   GrayT
 
14 - 18.02.04 - 15:28
Спасибо.
Много веток просто посрубали. Тут жарко было :)


Список тем форума
Рекламное место пустует   Рекламное место пустует
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует